summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-03-03 19:42:21 -0600
committerLuis Martinez2021-03-03 19:42:21 -0600
commit47e4fca0924765abb14f9e45eec93f10997fdff0 (patch)
tree53560080ca7ba32a2d02e698b4e561880c12aa8d
parent04165cbdc8af65c1540392edb6be398eca3ec35b (diff)
downloadaur-47e4fca0924765abb14f9e45eec93f10997fdff0.tar.gz
use arch-meson instead
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD13
2 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07ef4bfadb85..cb9780ff1047 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = fnott
pkgdesc = Keyboard driven and lightweight Wayland notification daemon
pkgver = 1.0.1
- pkgrel = 1
+ pkgrel = 2
url = https://codeberg.org/dnkl/fnott
arch = x86_64
license = MIT
makedepends = git
makedepends = meson
- makedepends = ninja
makedepends = scdoc
makedepends = wayland-protocols
makedepends = tllist>=1.0.1
diff --git a/PKGBUILD b/PKGBUILD
index 7eed95f7a4ac..413a6ba53c26 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,22 @@
# Maintainer: lmartinez-mirror
pkgname=fnott
pkgver=1.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="Keyboard driven and lightweight Wayland notification daemon"
arch=('x86_64')
url="https://codeberg.org/dnkl/fnott"
license=('MIT')
depends=('dbus' 'fcft' 'wlroots')
-makedepends=('git' 'meson' 'ninja' 'scdoc' 'wayland-protocols' 'tllist>=1.0.1')
+makedepends=('git' 'meson' 'scdoc' 'wayland-protocols' 'tllist>=1.0.1')
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
sha512sums=('5f8c3ba29af792875b0ac2e585cfebd453c92be064711b9d82a5cf6249fccda2cdeacc2a96b0b8b4a485590f10255d3e257339d85c99cccc3158ebc516959f22')
build() {
- cd "$pkgname"
- meson --prefix=/usr --buildtype=release build
- ninja -C build
+ arch-meson "$pkgname" build
+ meson compile -C build
}
package() {
- cd "$pkgname"
- DESTDIR="$pkgdir/" ninja -C build install
+ DESTDIR="$pkgdir/" meson install -C build
+ install -Dm 644 "$pkgname/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
}