summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Schneider2015-06-09 14:55:21 +0200
committerThomas Schneider2015-06-09 14:55:21 +0200
commit4800a84d7e770c0aea9bf5532bb72a5e32b703ae (patch)
tree04abafa59047910a7f9ccebac96ef0d92f01b87c
downloadaur-4800a84d7e770c0aea9bf5532bb72a5e32b703ae.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD37
-rw-r--r--mupen64plus_libretro.info12
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8679afab3491
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = libretro-mupen64plus-git
+ pkgdesc = libretro implementation of mupen64plus with dynarec (even for rpi)
+ pkgver = 3064.a0158bd
+ pkgrel = 1
+ url = https://github.com/libretro/mupen64plus-libretro
+ arch = i686
+ arch = x86_64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ license = custom
+ license = GPL
+ license = LGPL
+ makedepends = git
+ source = mupen64plus-libretro::git://github.com/libretro/mupen64plus-libretro.git
+ source = https://raw.github.com/libretro/libretro-super/master/dist/info/mupen64plus_libretro.info
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = libretro-mupen64plus-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0038fe80c658
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Thomas Schneider <maxmusterm@gmail.com>
+
+pkgname=libretro-mupen64plus-git
+_gitname=mupen64plus-libretro
+pkgver=3064.a0158bd
+pkgrel=1
+pkgdesc="libretro implementation of mupen64plus with dynarec (even for rpi)"
+arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
+url="https://github.com/libretro/mupen64plus-libretro"
+license=('custom' 'GPL' 'LGPL')
+makedepends=('git')
+source=("${_gitname}::git://github.com/libretro/${_gitname}.git"
+ "https://raw.github.com/libretro/libretro-super/master/dist/info/mupen64plus_libretro.info")
+
+md5sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd "${_gitname}"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "${_gitname}"
+ if [ $CARCH == "armv6h" ];then
+ platform=rpi make WITH_DYNAREC=arm
+ elif [ $CARCH == "i686" ];then
+ make WITH_DYNAREC=x86
+ else
+ make WITH_DYNAREC=$CARCH
+ fi
+}
+
+package() {
+ install -Dm644 "${srcdir}/mupen64plus_libretro.info" "${pkgdir}/usr/lib/libretro/libretro-mupen64plus.info"
+ install -Dm644 "${_gitname}/mupen64plus_libretro.so" "${pkgdir}/usr/lib/libretro/libretro-mupen64plus.so"
+}
diff --git a/mupen64plus_libretro.info b/mupen64plus_libretro.info
new file mode 100644
index 000000000000..e4c5a32f7c08
--- /dev/null
+++ b/mupen64plus_libretro.info
@@ -0,0 +1,12 @@
+display_name = "Nintendo 64 (Mupen64Plus)"
+authors = "Hacktarux|Mupen64Plus Team|Squarepusher"
+supported_extensions = "n64|v64|z64|bin|u1"
+corename = "Mupen64Plus"
+manufacturer = "Nintendo"
+categories = "Emulator"
+systemname = "Nintendo 64"
+database = "Nintendo - Nintendo 64"
+license = "GPLv2"
+permissions = "dynarec_optional"
+display_version = "2.0-rc2"
+supports_no_game = "false"