summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzocker-1602022-03-28 15:24:07 +0200
committerzocker-1602022-03-28 15:24:07 +0200
commit480b6ce1f264f8b6cddda95900ca67a549a25a3f (patch)
treea95af8131e43f3dea2484ffa3e71cef6051e2d7f
parent1f3ca20b0f5957f3a182feb76c57db005ab24c28 (diff)
downloadaur-480b6ce1f264f8b6cddda95900ca67a549a25a3f.tar.gz
fix build errors and source url
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD16
2 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf401a0da8cf..21221862db08 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = bless-git
pkgdesc = High-quality, full-featured hex editor (git version)
- pkgver = r181.59aaaba
- pkgrel = 4
+ pkgver = r190.103fbd6
+ pkgrel = 1
url = https://github.com/afrantzis/bless
arch = any
license = GPL2
makedepends = libxslt
makedepends = meson
makedepends = git
+ makedepends = itstool
depends = gtk-sharp-2
depends = mono
conflicts = bless
- source = git://github.com/afrantzis/bless.git
+ source = git+https://github.com/afrantzis/bless.git
sha256sums = SKIP
pkgname = bless-git
diff --git a/PKGBUILD b/PKGBUILD
index 94a8b61b31db..af9f71ce23df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,26 +7,28 @@
pkgname=bless-git
_gitname=bless
-pkgver=r181.59aaaba
-pkgrel=4
+pkgver=r190.103fbd6
+pkgrel=1
pkgdesc="High-quality, full-featured hex editor (git version)"
arch=('any')
url="https://github.com/afrantzis/bless"
license=('GPL2')
-depends=('gtk-sharp-2' 'mono')
conflicts=('bless')
-makedepends=('libxslt' 'meson' 'git')
-source=("git://github.com/afrantzis/bless.git")
+
+depends=('gtk-sharp-2' 'mono')
+makedepends=('libxslt' 'meson' 'git' 'itstool')
+
+source=("git+https://github.com/afrantzis/bless.git")
sha256sums=('SKIP')
pkgver() {
- cd ${srcdir}/${_gitname}/
+ cd ${srcdir}/${_gitname}
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
cd ${srcdir}/${_gitname}
- meson setup build -Dprefix=/usr -Dtests=false --buildtype=release
+ meson setup build -Dprefix=/usr -Dtests=false -Dhtml_user_doc=false --buildtype=release
}
build() {