summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Steel2015-06-08 18:30:26 +0100
committerJonathan Steel2015-06-08 18:30:26 +0100
commit481c71a1e4a4be22ebf602a4db645c1f4d374bd2 (patch)
tree17f4ad09e8478c36b3b9f7eacec5e0369925d7df
downloadaur-481c71a1e4a4be22ebf602a4db645c1f4d374bd2.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
-rw-r--r--somagic-easycap-tools.install4
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d994a378b59e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = somagic-easycap-tools
+ pkgdesc = Tool to extract the firmware for the Somagic EasyCAP DC60 and EasyCAP002 (original CD needed)
+ pkgver = 1.1
+ pkgrel = 1
+ url = http://code.google.com/p/easycap-somagic-linux
+ install = somagic-easycap-tools.install
+ arch = x86_64
+ arch = i686
+ license = GPL2
+ depends = libgcrypt
+ source = http://easycap-somagic-linux.googlecode.com/files/somagic-easycap-tools_1.1.tar.gz
+ md5sums = e75476b067560e7d55d95e0a0931d70d
+
+pkgname = somagic-easycap-tools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..26313c94b5f5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: jsteel <mail at jsteel dot org>
+
+pkgname=somagic-easycap-tools
+pkgver=1.1
+pkgrel=1
+pkgdesc="Tool to extract the firmware for the Somagic EasyCAP DC60 and EasyCAP002 (original CD needed)"
+url="http://code.google.com/p/easycap-somagic-linux"
+arch=('x86_64' 'i686')
+license=('GPL2')
+depends=('libgcrypt')
+install=$pkgname.install
+source=(http://easycap-somagic-linux.googlecode.com/files/${pkgname}_$pkgver.tar.gz)
+md5sums=('e75476b067560e7d55d95e0a0931d70d')
+
+build() {
+ cd "$srcdir"/${pkgname}_$pkgver
+
+ make
+}
+
+package() {
+ cd "$srcdir"/${pkgname}_$pkgver
+
+ make PREFIX="$pkgdir"/usr/ install
+}
diff --git a/somagic-easycap-tools.install b/somagic-easycap-tools.install
new file mode 100644
index 000000000000..8bb0b015e7c2
--- /dev/null
+++ b/somagic-easycap-tools.install
@@ -0,0 +1,4 @@
+post_install() {
+ echo "You will need the installation CD to extract the firmware. \
+Then follow http://code.google.com/p/easycap-somagic-linux/wiki/GettingStarted#Extracting_firmware"
+}