summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-12-02 00:17:30 -0800
committerxiota2023-12-02 00:17:51 -0800
commit481eb98722cc7ca27186744e7c99b1ce6f10c411 (patch)
tree7a41538698119bae8228d1bdc58e2bb07473fbc2
parent135cc5e41928f7fdd749083fcc1a5f31a57dd9ef (diff)
downloadaur-481eb98722cc7ca27186744e7c99b1ce6f10c411.tar.gz
5.0.r20511: update depends
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD72
2 files changed, 50 insertions, 58 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 709e5407f391..ead61953dad3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,58 +1,58 @@
pkgbase = dolphin-emu-debugfast-git
pkgdesc = A Gamecube / Wii / Triforce emulator
- pkgver = 5.0.r20495.g89963c287c
+ pkgver = 5.0.r20511.gc54e8d733f
pkgrel = 1
url = https://github.com/dolphin-emu/dolphin
arch = x86_64
license = GPL2
makedepends = cmake
makedepends = git
- makedepends = ninja
makedepends = python
depends = alsa-lib
depends = bluez-libs
- depends = enet
+ depends = curl
+ depends = ffmpeg
depends = gcc-libs
depends = glibc
- depends = hidapi
- depends = libavcodec.so
- depends = libavformat.so
- depends = libavutil.so
- depends = libcurl.so
depends = libevdev
depends = libgl
- depends = libminiupnpc.so
depends = libpulse
- depends = libsfml-network.so
- depends = libsfml-system.so
- depends = libswscale.so
depends = libudev.so
- depends = libusb-1.0.so
depends = libx11
depends = libxi
depends = libxrandr
- depends = lzo
- depends = minizip-ng
- depends = pugixml
depends = qt6-base
depends = qt6-svg
- depends = sfml
+ depends = bzip2
depends = cubeb
+ depends = curl
depends = fmt
+ depends = hidapi
+ depends = libiconv
+ depends = liblzma.so
depends = libspng
+ depends = libusb
+ depends = lz4
+ depends = lzo
depends = mbedtls2
+ depends = miniupnpc
+ depends = minizip-ng
+ depends = pugixml
+ depends = sdl2
+ depends = sfml
+ depends = zstd
optdepends = pulseaudio: PulseAudio backend
provides = dolphin-emu
conflicts = dolphin-emu
options = !emptydirs
options = !lto
source = dolphin-emu::git+https://github.com/dolphin-emu/dolphin.git
- source = zlib-ng::git+https://github.com/zlib-ng/zlib-ng.git
source = cyan4973.xxhash::git+https://github.com/Cyan4973/xxHash.git
source = epezent.implot::git+https://github.com/epezent/implot.git
source = gpuopen-librariesandsdks.vulkanmemoryallocator::git+https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator.git
source = mgba-emu.mgba::git+https://github.com/mgba-emu/mgba.git
source = retroachievements.rcheevos::git+https://github.com/RetroAchievements/rcheevos.git
+ source = zlib-ng::git+https://github.com/zlib-ng/zlib-ng.git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index dccd1472ee9b..1b350f0dbe52 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,6 @@
# options
: ${_debugfast:=false}
-: ${_system_zlib:=false}
: ${_avx_build:=false}
: ${_pkgtype:=debugfast-git}
@@ -25,7 +24,7 @@ fi
# basic info
_pkgname="dolphin-emu"
pkgname="$_pkgname${_pkgtype:+-$_pkgtype}"
-pkgver=5.0.r20495.g89963c287c
+pkgver=5.0.r20511.gc54e8d733f
pkgrel=1
pkgdesc='A Gamecube / Wii / Triforce emulator'
arch=(x86_64)
@@ -36,47 +35,51 @@ license=(GPL2)
# main package
_main_package() {
depends=(
- # extra/dolphin-emu
alsa-lib
bluez-libs
- enet
+ curl
+ ffmpeg
gcc-libs
glibc
- hidapi
- libavcodec.so
- libavformat.so
- libavutil.so
- libcurl.so
libevdev
libgl
- libminiupnpc.so
libpulse
- libsfml-network.so
- libsfml-system.so
- libswscale.so
libudev.so
- libusb-1.0.so
libx11
libxi
libxrandr
- lzo
- minizip-ng
- pugixml
qt6-base
qt6-svg
- sfml
- ## dolphin-emu-git
- #libmgba
+ ## optional
+ bzip2
cubeb
+ curl
fmt
+ hidapi
+ libiconv
+ liblzma.so
libspng
+ libusb
+ lz4
+ lzo
mbedtls2
+ miniupnpc
+ minizip-ng
+ pugixml
+ sdl2
+ sfml
+ zstd
+
+ ## broken
+ #enet
+ #libmgba
+ #xxhash
+ #zlib-ng
)
makedepends+=(
cmake
git
- ninja
python
)
optdepends=(
@@ -96,13 +99,6 @@ _main_package() {
# submodules
_source_dolphin_emu() {
- if [ x"${_system_zlib::1}" == "xt" ] ; then
- depends+=(zlib-ng)
- else
- source+=('zlib-ng'::'git+https://github.com/zlib-ng/zlib-ng.git')
- sha256sums+=('SKIP')
- fi
-
source+=(
#'bylaws.libadrenotools'::'git+https://github.com/bylaws/libadrenotools.git'
#'curl'::'git+https://github.com/curl/curl.git'
@@ -122,6 +118,7 @@ _source_dolphin_emu() {
'gpuopen-librariesandsdks.vulkanmemoryallocator'::'git+https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator.git'
'mgba-emu.mgba'::'git+https://github.com/mgba-emu/mgba.git'
'retroachievements.rcheevos'::'git+https://github.com/RetroAchievements/rcheevos.git'
+ 'zlib-ng'::'git+https://github.com/zlib-ng/zlib-ng.git'
)
sha256sums+=(
#'SKIP'
@@ -142,6 +139,7 @@ _source_dolphin_emu() {
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
)
_prepare_dolphin_emu() (
@@ -165,14 +163,8 @@ _source_dolphin_emu() {
['gpuopen-librariesandsdks.vulkanmemoryallocator']='Externals/VulkanMemoryAllocator'
['mgba-emu.mgba']='Externals/mGBA/mgba'
['retroachievements.rcheevos']='Externals/rcheevos/rcheevos'
+ ['zlib-ng']='Externals/zlib-ng/zlib-ng'
)
-
- if [ x"${_system_zlib::1}" != "xt" ] ; then
- _submodules+=(
- ['zlib-ng']='Externals/zlib-ng/zlib-ng'
- )
- fi
-
_submodule_update
)
}
@@ -223,10 +215,6 @@ prepare() {
}
build() {
- if [ x"${_system_zlib::1}" == "xt" ] ; then
- export LDFLAGS="-Wl,--copy-dt-needed-entries"
- fi
-
if [[ x"${_avx_build::1}" == "xt" ]] ; then
export CFLAGS="$(echo "$CFLAGS" | sed -E 's@(\s*-(march|mtune)=\S+\s*)@ @g;s@\s*-O[0-9]\s*@ @g;s@\s+@ @g') -march=x86-64-v3 -mtune=skylake -O3"
export CXXFLAGS="$(echo "$CFLAGS" | sed -E 's@(\s*-(march|mtune)=\S+\s*)@ @g;s@\s*-O[0-9]\s*@ @g;s@\s+@ @g') -march=x86-64-v3 -mtune=skylake -O3"
@@ -235,14 +223,18 @@ build() {
local _cmake_options=(
-B build
-S "$_pkgname"
- -G Ninja
+
-DCMAKE_BUILD_TYPE=None
-DCMAKE_INSTALL_PREFIX='/usr'
-DDISTRIBUTOR='aur.chaotic.cx'
-DENABLE_AUTOUPDATE=OFF
# -DENABLE_ANALYTICS=OFF # ON is opt-in
# -DUSE_SYSTEM_LIBS=ON # AUTO
+
+ -DUSE_SYSTEM_ENET=OFF
-DUSE_SYSTEM_LIBMGBA=OFF
+ -DUSE_SYSTEM_XXHASH=OFF
+ -DUSE_SYSTEM_ZLIB=OFF
-DENABLE_LTO=OFF # segfault when on
-DENABLE_TESTS=OFF