summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjoshcarp2023-03-08 17:57:26 -0500
committerjoshcarp2023-03-08 17:57:26 -0500
commit4825f171b8e26b5e3bf8ce7b73e1c224b12fa2a5 (patch)
tree8b0525a6f7affcc17c8e1dc2829000cf724c197a
parent1afdc58a877761623eba04c5e0b2b26889b1bbf9 (diff)
downloadaur-4825f171b8e26b5e3bf8ce7b73e1c224b12fa2a5.tar.gz
Update to v1.15.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9bccc789074..2270aff34072 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = buf
pkgdesc = A new way of working with Protocol Buffers
- pkgver = 1.15.0
+ pkgver = 1.15.1
pkgrel = 1
url = https://buf.build
arch = any
license = Apache
makedepends = go
- source = https://github.com/bufbuild/buf/archive/v1.15.0.tar.gz
- sha256sums = afdf204db262b6b4ce848df727f974c64c90e8034faac86ce7eb1a3ca36f863b
+ source = https://github.com/bufbuild/buf/archive/v1.15.1.tar.gz
+ sha256sums = b41e98ee5e2beecf21a90c657acdfc7a86cec3e5a60a333984ecb9184f9f5fec
pkgname = buf
diff --git a/PKGBUILD b/PKGBUILD
index 743a8af6dce4..ef35565ecd03 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Buf <bot@buf.build>
# Contributor: Alexander Menzhinsky <amenzhinsky@gmail.com>
pkgname=buf
-pkgver=1.15.0
+pkgver=1.15.1
pkgrel=1
pkgdesc="A new way of working with Protocol Buffers"
arch=("any")
url="https://buf.build"
license=('Apache')
makedepends=('go')
-source=("https://github.com/bufbuild/buf/archive/v1.15.0.tar.gz")
+source=("https://github.com/bufbuild/buf/archive/v1.15.1.tar.gz")
build() {
- cd ${pkgname}-1.15.0
+ cd ${pkgname}-1.15.1
go build -trimpath -buildmode=pie -mod=readonly -modcacherw -buildvcs=false -o . ./cmd/{buf,protoc-gen-buf-lint,protoc-gen-buf-breaking}
./buf completion bash >completion.bash
./buf completion zsh >completion.zsh
@@ -21,13 +21,13 @@ build() {
}
package() {
- install -Dm755 "${pkgname}-1.15.0/buf" "${pkgdir}/usr/bin/buf"
- install -Dm755 "${pkgname}-1.15.0/protoc-gen-buf-lint" "${pkgdir}/usr/bin/protoc-gen-buf-lint"
- install -Dm755 "${pkgname}-1.15.0/protoc-gen-buf-breaking" "${pkgdir}/usr/bin/protoc-gen-buf-breaking"
- install -Dm644 "${pkgname}-1.15.0/completion.bash" "${pkgdir}/etc/bash_completion.d/buf"
- install -Dm644 "${pkgname}-1.15.0/completion.zsh" "${pkgdir}/usr/share/zsh/site-functions/_buf"
- install -Dm644 "${pkgname}-1.15.0/completion.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/buf.fish"
- install -Dm644 "${pkgname}-1.15.0/manpages/${pkgname}"* -t "${pkgdir}/usr/share/man/man1/"
+ install -Dm755 "${pkgname}-1.15.1/buf" "${pkgdir}/usr/bin/buf"
+ install -Dm755 "${pkgname}-1.15.1/protoc-gen-buf-lint" "${pkgdir}/usr/bin/protoc-gen-buf-lint"
+ install -Dm755 "${pkgname}-1.15.1/protoc-gen-buf-breaking" "${pkgdir}/usr/bin/protoc-gen-buf-breaking"
+ install -Dm644 "${pkgname}-1.15.1/completion.bash" "${pkgdir}/etc/bash_completion.d/buf"
+ install -Dm644 "${pkgname}-1.15.1/completion.zsh" "${pkgdir}/usr/share/zsh/site-functions/_buf"
+ install -Dm644 "${pkgname}-1.15.1/completion.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/buf.fish"
+ install -Dm644 "${pkgname}-1.15.1/manpages/${pkgname}"* -t "${pkgdir}/usr/share/man/man1/"
}
-sha256sums=('afdf204db262b6b4ce848df727f974c64c90e8034faac86ce7eb1a3ca36f863b')
+sha256sums=('b41e98ee5e2beecf21a90c657acdfc7a86cec3e5a60a333984ecb9184f9f5fec')