summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreomanis2019-05-14 22:30:48 +0200
committereomanis2019-05-14 22:30:48 +0200
commit4829002e65a6012b937029224f51972e1959618c (patch)
tree552faa77c6dbc0d285fa04bfd8f9771f6d595c07
parentd70d160bc466d6c7d6958a9d6fa6f61081ca7ccf (diff)
downloadaur-4829002e65a6012b937029224f51972e1959618c.tar.gz
Update to version 0.1.1
-rw-r--r--.SRCINFO10
-rwxr-xr-xPKGBUILD13
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9735806748fb..25f7fb5a8635 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = inherit-acl
pkgdesc = Tool that applies to a path its parent directory's permissions and ACL
- pkgver = 0.1.0
- pkgrel = 2
- url = https://eomanis.duckdns.org/permshare/inherit-acl/index.xhtml
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://eomanis.duckdns.org/permshare/inherit-acl/
arch = any
license = GPL3
depends = bash>=4.3
@@ -10,8 +10,8 @@ pkgbase = inherit-acl
depends = sed
depends = acl
optdepends = sudo: Sudo integration
- source = https://eomanis.duckdns.org/permshare/inherit-acl/inherit-acl-0.1.0.tar.gz
- sha384sums = f3417fa441abd1a1cc44cb0f3897fd29bb850f72688708bf7792a9f4abb67c8d12a7d2aa3b95026dfe5254b31d48e56e
+ source = https://eomanis.duckdns.org/permshare/inherit-acl/inherit-acl-0.1.1.tar.gz
+ sha384sums = ece6bd69da7efb8535978ff31124c95589f3e7d2f42ad5aa9c2306b8aa442c3681f90160d0e186a4e8c671f6067df0c8
pkgname = inherit-acl
diff --git a/PKGBUILD b/PKGBUILD
index 89a5ce35d9bf..4c63042bd871 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,26 @@
# Maintainer: eomanis at web dot de
pkgname='inherit-acl'
-_pkgverUpstream="0.1.0"
+_pkgverUpstream="0.1.1"
pkgver="${_pkgverUpstream//-/.}"
-pkgrel=2
+pkgrel=1
pkgdesc="Tool that applies to a path its parent directory's permissions and ACL"
arch=('any')
-url='https://eomanis.duckdns.org/permshare/inherit-acl/index.xhtml'
+url='https://eomanis.duckdns.org/permshare/inherit-acl/'
license=('GPL3')
depends=('bash>=4.3' 'coreutils' 'sed' 'acl')
optdepends=('sudo: Sudo integration')
source=("https://eomanis.duckdns.org/permshare/inherit-acl/inherit-acl-${_pkgverUpstream}.tar.gz")
-sha384sums=('f3417fa441abd1a1cc44cb0f3897fd29bb850f72688708bf7792a9f4abb67c8d12a7d2aa3b95026dfe5254b31d48e56e')
+sha384sums=('ece6bd69da7efb8535978ff31124c95589f3e7d2f42ad5aa9c2306b8aa442c3681f90160d0e186a4e8c671f6067df0c8')
package() {
+ local srcRootDir="${srcdir}/${pkgname}-${_pkgverUpstream}"
# Place the main bash scripts into /usr/bin
mkdir -p "${pkgdir}/usr/bin"
cd "${pkgdir}/usr/bin"
- cp -t . "${srcdir}/inherit-acl"
+ cp -t . "${srcRootDir}/inherit-acl"
chmod u=rwx,go=rx "inherit-acl"
- cp -t . "${srcdir}/inherit-acl-run"
+ cp -t . "${srcRootDir}/inherit-acl-run"
chmod u=rwx,go=rx "inherit-acl-run"
}