summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgrey@christoforo.net2015-08-23 16:09:21 +0100
committergrey@christoforo.net2015-08-23 16:09:21 +0100
commit48316087268521ae9070150d8c6b70a087d756ac (patch)
treef16f9d58afcf11b151863159e729de968ff6fe94
downloadaur-48316087268521ae9070150d8c6b70a087d756ac.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1fa58f6d360d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = curaengine
+ pkgdesc = CuraEngine is a powerful, fast and robust engine for processing 3D models into 3D printing instruction for Ultimaker and other GCode based 3D printers. It is part of the larger open source project called Cura.
+ pkgver = 15.06.03
+ pkgrel = 1
+ url = https://github.com/Ultimaker/CuraEngine
+ arch = i686
+ arch = x86_64
+ license = GPLv3
+ makedepends = cmake
+ source = https://github.com/Ultimaker/curaengine/archive/15.06.03.tar.gz
+ md5sums = a7cd980dfed2aeeb28ca8610f541fb3d
+
+pkgname = curaengine
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4552cbc6889a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar*
+pkg
+src
+*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f25800b5ff9a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
+
+pkgname=curaengine
+pkgver=15.06.03
+pkgrel=1
+pkgdesc="CuraEngine is a powerful, fast and robust engine for processing 3D models into 3D printing instruction for Ultimaker and other GCode based 3D printers. It is part of the larger open source project called Cura."
+url="https://github.com/Ultimaker/CuraEngine"
+arch=('i686' 'x86_64')
+license=('GPLv3')
+makedepends=('cmake')
+source=("https://github.com/Ultimaker/${pkgname}/archive/${pkgver}.tar.gz")
+md5sums=('a7cd980dfed2aeeb28ca8610f541fb3d')
+
+build() {
+ cd CuraEngine-${pkgver}
+ cmake ./ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd CuraEngine-${pkgver}
+ make DESTDIR="${pkgdir}" install
+ #install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
+
+# vim:set ts=2 sw=2 et: