summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-09-25 08:31:35 -0600
committerMark Wagie2021-09-25 08:31:35 -0600
commit4831ca10c56c23f9dcbb5c08a77453ab857c3e3c (patch)
tree7c03db4481523437d22366fd38819dde46152973
parent7852ae93b84686920b9a90ebc262aad6572f9919 (diff)
downloadaur-4831ca10c56c23f9dcbb5c08a77453ab857c3e3c.tar.gz
3.22.15
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bdf543d18668..e83076cc49f5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xfce-theme-greybird
pkgdesc = Desktop Suite for Xfce
- pkgver = 3.22.14
- pkgrel = 2
+ pkgver = 3.22.15
+ pkgrel = 1
url = https://shimmerproject.org
arch = any
license = CC-BY-SA-3.0
@@ -10,12 +10,12 @@ pkgbase = xfce-theme-greybird
makedepends = meson
makedepends = sassc
optdepends = elementary-xfce-icons: matching icon set; use the dark icon theme
+ optdepends = gtk3: required for CSS/GTK3 theme
optdepends = lightdm-gtk-greeter: required for the LightDM GTK theme
optdepends = shimmer-wallpapers: contains the Greybird wallpaper, among others
optdepends = gtk-engine-murrine: GTK2 theme support
optdepends = lib32-gtk-engine-murrine: required for multilib
- source = xfce-theme-greybird-3.22.14.tar.gz::https://github.com/shimmerproject/Greybird/archive/v3.22.14.tar.gz
- sha256sums = 37fc4b8f83ff667e43e9889f6605a9e5da2ce2f5c5801c1ceef90814fb57b294
+ source = xfce-theme-greybird-3.22.15.tar.gz::https://github.com/shimmerproject/Greybird/archive/v3.22.15.tar.gz
+ sha256sums = dbf8440d9904bd8d9fb9b612ece5b9cd604c08ff308755a46d41db7e9ea4b617
pkgname = xfce-theme-greybird
-
diff --git a/PKGBUILD b/PKGBUILD
index edfe5314ca1e..b72a15efe910 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,29 +3,30 @@
# Contributor: Bjoern Franke <bjo at nord-west.org>
# Contributor: flan_suse
pkgname=xfce-theme-greybird
-pkgver=3.22.14
-pkgrel=2
+pkgver=3.22.15
+pkgrel=1
pkgdesc="Desktop Suite for Xfce"
arch=('any')
url="https://shimmerproject.org"
license=('CC-BY-SA-3.0' 'GPL')
makedepends=('librsvg' 'meson' 'sassc')
optdepends=('elementary-xfce-icons: matching icon set; use the dark icon theme'
+ 'gtk3: required for CSS/GTK3 theme'
'lightdm-gtk-greeter: required for the LightDM GTK theme'
'shimmer-wallpapers: contains the Greybird wallpaper, among others'
'gtk-engine-murrine: GTK2 theme support'
'lib32-gtk-engine-murrine: required for multilib')
source=("$pkgname-$pkgver.tar.gz"::"https://github.com/shimmerproject/Greybird/archive/v$pkgver.tar.gz")
-sha256sums=('37fc4b8f83ff667e43e9889f6605a9e5da2ce2f5c5801c1ceef90814fb57b294')
+sha256sums=('dbf8440d9904bd8d9fb9b612ece5b9cd604c08ff308755a46d41db7e9ea4b617')
build() {
- arch-meson "Greybird-$pkgver" build
- meson compile -C build
+ arch-meson "Greybird-$pkgver" build
+ meson compile -C build
}
package() {
- DESTDIR="$pkgdir" meson install -C build
+ meson install -C build --destdir "$pkgdir"
- cd "Greybird-$pkgver"
- install -Dm644 LICENSE.CC -t "$pkgdir/usr/share/licenses/$pkgname"
+ cd "Greybird-$pkgver"
+ install -Dm644 LICENSE.CC -t "$pkgdir/usr/share/licenses/$pkgname"
}