summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoaquim Monteiro2024-04-22 05:43:26 +0100
committerJoaquim Monteiro2024-04-22 05:43:26 +0100
commit483a6ffafe06bab4a87c9ea1c142425c145a35f5 (patch)
tree94d5bab9db93ef3d9325d40bafa161bea2e620b2
parenta48a8459235b05f2c88c0cf7c0735a2dde1ffedf (diff)
downloadaur-483a6ffafe06bab4a87c9ea1c142425c145a35f5.tar.gz
Migrate to standards based build and rebuild for Python 3.12
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
2 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ebfcd23d4947..5d639e55949b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = python-orjson-git
pkgdesc = Fast, correct Python JSON library supporting dataclasses and datetimes (Git version)
- pkgver = 2.5.2.r1.gd31e37b
- pkgrel = 1
+ pkgver = 3.10.1.r0.g632345a
+ pkgrel = 2
url = https://github.com/ijl/orjson
arch = x86_64
arch = i686
arch = aarch64
arch = armv7h
- license = Apache
+ license = Apache-2.0
license = MIT
makedepends = git
- makedepends = python-pip
+ makedepends = python-installer
+ makedepends = python-maturin
makedepends = rust
depends = python
provides = python-orjson
@@ -19,4 +20,3 @@ pkgbase = python-orjson-git
sha512sums = SKIP
pkgname = python-orjson-git
-
diff --git a/PKGBUILD b/PKGBUILD
index a05f3f65a404..b1a585ee9dde 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,18 @@
-# Maintainer: gmes78 <gmes.078 at gmail dot com>
-
-# NOTE: building this package requires a nightly build of the Rust compiler.
+# Maintainer: Joaquim Monteiro <joaquim dot monteiro at protonmail dot com>
pkgname=python-orjson-git
-pkgver=2.5.2.r1.gd31e37b
-pkgrel=1
+pkgver=3.10.1.r0.g632345a
+pkgrel=2
pkgdesc="Fast, correct Python JSON library supporting dataclasses and datetimes (Git version)"
arch=(x86_64 i686 aarch64 armv7h)
url="https://github.com/ijl/orjson"
-license=('Apache' 'MIT')
+license=('Apache-2.0' 'MIT')
provides=('python-orjson')
conflicts=('python-orjson')
depends=('python')
-makedepends=('git' 'python-pip' 'rust')
+makedepends=('git' 'python-installer' 'python-maturin' 'rust')
source=("git+https://github.com/ijl/orjson.git")
sha512sums=('SKIP')
@@ -24,9 +22,13 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+build() {
+ cd orjson
+ maturin build --release --strip
+}
+
package() {
cd orjson
install -Dm644 LICENSE-MIT "$pkgdir/usr/share/licenses/$pkgname/LICENSE-MIT"
-
- PIP_CONFIG_FILE=/dev/null pip install --root="$pkgdir" --isolated --ignore-installed --no-deps --no-binary=orjson --use-pep517 .
+ python -m installer --destdir="$pkgdir" target/wheels/*.whl
}