summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederic Bezies2020-01-06 23:39:43 +0100
committerFrederic Bezies2020-01-06 23:39:43 +0100
commit483c98b1be33ebb820dc1849964b922c33dd114b (patch)
tree55ef071d1dec0226edd77bb43de34ada9ddcbd53
parentfe984f4d6ccb9eb28da4022a2706f2c2a7dba24f (diff)
downloadaur-483c98b1be33ebb820dc1849964b922c33dd114b.tar.gz
1.4.0 update
-rwxr-xr-x.SRCINFO14
-rw-r--r--0001-Fixed-compilation-with-Qt-5.11.patch37
-rwxr-xr-xPKGBUILD42
3 files changed, 17 insertions, 76 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad3c1cac75f5..ed9bd57e2454 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qomp
pkgdesc = Quick(Qt) Online Music Player
- pkgver = 1.3.1
+ pkgver = 1.4
pkgrel = 1
url = http://qomp.sourceforge.net/
arch = i686
@@ -19,16 +19,8 @@ pkgbase = qomp
depends = gst-plugins-good
optdepends = gst-plugins-bad
optdepends = gst-plugins-ugly
- source = git+https://github.com/qomp/qomp#commit=230443ed40a99cedbfee7624dcce6db16977a9f6
- source = git+https://github.com/qomp/translations
- source = git+https://github.com/qomp/themes
- source = git+https://github.com/wadealer/SingleApplication
- source = 0001-Fixed-compilation-with-Qt-5.11.patch
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = 83664a00dc0d2ea7cd81a69ff51c40f3
+ source = git+https://github.com/qomp/qomp.git#commit=3cbc6ccc5653737b3e1e0b4884bb370e67144604
+ sha256sums = SKIP
pkgname = qomp
diff --git a/0001-Fixed-compilation-with-Qt-5.11.patch b/0001-Fixed-compilation-with-Qt-5.11.patch
deleted file mode 100644
index 66ddf9532628..000000000000
--- a/0001-Fixed-compilation-with-Qt-5.11.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From 78886eda1a7c6d7d6fa8a4ce41f36ab3d9daccb4 Mon Sep 17 00:00:00 2001
-From: Vitozz <thetvg@gmail.com>
-Date: Fri, 1 Jun 2018 17:36:33 +0300
-Subject: [PATCH] Fixed compilation with Qt-5.11
-
----
- libqomp/src/plugins/qompplugingettunesdlg.cpp | 1 +
- plugins/tunetofileplugin/tunetofilesettings.cpp | 1 +
- 2 files changed, 2 insertions(+)
-
-diff --git a/libqomp/src/plugins/qompplugingettunesdlg.cpp b/libqomp/src/plugins/qompplugingettunesdlg.cpp
-index 5fed017..5f7f0b3 100644
---- a/libqomp/src/plugins/qompplugingettunesdlg.cpp
-+++ b/libqomp/src/plugins/qompplugingettunesdlg.cpp
-@@ -32,6 +32,7 @@
- #include <QTimer>
- #include <QDialog>
- #include <QMessageBox>
-+#include <QAbstractItemView>
-
- static const int sugTimerInterval = 500;
-
-diff --git a/plugins/tunetofileplugin/tunetofilesettings.cpp b/plugins/tunetofileplugin/tunetofilesettings.cpp
-index 42212dd..e29ea00 100644
---- a/plugins/tunetofileplugin/tunetofilesettings.cpp
-+++ b/plugins/tunetofileplugin/tunetofilesettings.cpp
-@@ -23,6 +23,7 @@
- #include "ui_tunetofilesettings.h"
-
- #include <QFileDialog>
-+#include <QStyle>
- #ifdef Q_OS_WIN
- #include <QProcessEnvironment>
- #endif
---
-2.17.1
-
diff --git a/PKGBUILD b/PKGBUILD
index 29d1a84a364b..5b2405881a53 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
-# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
+# Maintainer: Frederic Bezies <fredbezies at gmail dot com>
+# Contributor: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
# Contributor: alex korobtsov <korobcoff@gmail.com>
# Contributor: Alexander Bantyev <balsoft@yandex.ru>
pkgname=qomp
-pkgver=1.3.1
+pkgver=1.4
pkgrel=1
pkgdesc="Quick(Qt) Online Music Player"
arch=('i686' 'x86_64')
@@ -15,17 +16,9 @@ depends=('taglib' 'qt5-base' 'qt5-tools' 'qt5-x11extras'
optdepends=('gst-plugins-bad'
'gst-plugins-ugly')
makedepends=('git' 'cmake')
-_commit=230443ed40a99cedbfee7624dcce6db16977a9f6 #tag 1.3.1
-source=("git+https://github.com/qomp/qomp#commit=$_commit"
- "git+https://github.com/qomp/translations"
- "git+https://github.com/qomp/themes"
- "git+https://github.com/wadealer/SingleApplication"
- 0001-Fixed-compilation-with-Qt-5.11.patch)
-md5sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- '83664a00dc0d2ea7cd81a69ff51c40f3')
+_commit=3cbc6ccc5653737b3e1e0b4884bb370e67144604 #tag 1.4.0
+source=(git+https://github.com/qomp/qomp.git#commit=$_commit)
+sha256sums=('SKIP')
pkgver() {
cd $pkgname
@@ -33,30 +26,23 @@ pkgver() {
}
prepare() {
- cd "$srcdir/${pkgname}"
- patch -Np1 -i ../0001-Fixed-compilation-with-Qt-5.11.patch
- git submodule init
-
- git config 'submodule.translations.url' "${srcdir}/translations"
- git config 'submodule.themes.url' "${srcdir}/themes"
- git config 'submodule.src/singleapplication.url' "${srcdir}/SingleApplication"
-
- git submodule update
+ cd "$srcdir/$pkgname"
+ git submodule init
+ git submodule update
}
build() {
- cd "$srcdir/${pkgname}"
+ cd "$srcdir/$pkgname"
- cmake \
- -DCMAKE_INSTALL_PREFIX=/usr/ \
- -DUSE_QT5=ON \
- -DCMAKE_BUILD_TYPE=Release
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
make
}
package() {
- cd "$srcdir/${pkgname}"
+ cd "$srcdir/$pkgname"
make DESTDIR="$pkgdir/" install
}
+
+