summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Fent2021-03-08 22:34:58 +0100
committerPhilipp Fent2021-03-08 22:34:58 +0100
commit484f57447eeabd510338feff5c4a2d72f27c528a (patch)
tree99e927e2481b737682f60291bb0d6ef9d6c1325c
parentbaf78ddcc55c746219dbdbe7aedaafd6a29ef720 (diff)
parent61da3fe5890092500dd401097cebdcd76533ed22 (diff)
downloadaur-484f57447eeabd510338feff5c4a2d72f27c528a.tar.gz
Merge remote-tracking branch 'icecream/master'
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ee21b6e94b2..71c7e17bfccf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,10 +6,14 @@ pkgbase = icecream-git
install = icecream.install
arch = x86_64
license = GPL2
+ makedepends = docbook2x
depends = bash
depends = libcap-ng
+ depends = libarchive
depends = lzo
- optdepends = iceberg-git: A Qt based monitor for icecream nodes
+ depends = zstd
+ optdepends = icecream-sundae: A commandline monitor for Icecream
+ optdepends = icemon: Icecream GUI monitor
optdepends = ccache: ccache enabled remote builds.
provides = icecream
conflicts = icecream
diff --git a/PKGBUILD b/PKGBUILD
index 71cc74773c88..e3256f9d0941 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,10 +10,11 @@ pkgrel=1
pkgdesc="takes compile jobs from your build and distributes it to remote machines allowing a parallel build on several machines."
url="http://en.opensuse.org/Icecream"
license=('GPL2')
-makedepends=('')
-depends=('bash' 'libcap-ng' 'lzo')
+makedepends=('docbook2x')
+depends=('bash' 'libcap-ng' 'libarchive' 'lzo' 'zstd')
provides=('icecream')
-optdepends=('iceberg-git: A Qt based monitor for icecream nodes'
+optdepends=('icecream-sundae: A commandline monitor for Icecream'
+ 'icemon: Icecream GUI monitor'
'ccache: ccache enabled remote builds.')
conflicts=('icecream')
backup=('etc/icecream.conf')
@@ -44,7 +45,7 @@ build() {
cd "$srcdir/${_pkgname}"
./autogen.sh
- ./configure --prefix=/usr/lib/icecream --enable-shared --disable-static --without-man
+ ./configure --prefix=/usr/lib/icecream --enable-shared --disable-static --mandir=/usr/share/man
make
}