summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKnut Ahlers2021-04-15 11:09:04 +0200
committerKnut Ahlers2021-04-15 11:09:04 +0200
commit487963bc932f52f5e35eaaaf14a803432cce10b1 (patch)
tree019e9328561bb52a7a38fe4494f6581afb9b8894
parent00d5ca01e81b2bc66ef6ac4f35a2d68938ef37eb (diff)
downloadaur-487963bc932f52f5e35eaaaf14a803432cce10b1.tar.gz
Fix: Update pkgrel only when version did change
Signed-off-by: Knut Ahlers <knut@ahlers.me>
-rwxr-xr-xupdate_version.sh5
1 files changed, 4 insertions, 1 deletions
diff --git a/update_version.sh b/update_version.sh
index 2471f7792dd9..34106bf1c8b3 100755
--- a/update_version.sh
+++ b/update_version.sh
@@ -14,7 +14,6 @@ VER=$(curl -sSf https://dl.google.com/linux/chrome/deb/dists/stable/main/binary-
# Insert latest version into PKGBUILD and update hashes
sed -i \
-e "s/^pkgver=.*/pkgver=${VER}/" \
- -e 's/pkgrel=.*/pkgrel=1/' \
PKGBUILD
# Check whether this changed anything
@@ -23,6 +22,10 @@ if (git diff --exit-code PKGBUILD); then
exit 0
fi
+sed -i \
+ -e 's/pkgrel=.*/pkgrel=1/' \
+ PKGBUILD
+
updpkgsums
# Update .SRCINFO