summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJörg Thalheim2015-09-30 10:54:45 +0200
committerJörg Thalheim2015-09-30 10:55:14 +0200
commit487d747e3427ec855ee409c92dc3dd60a241c339 (patch)
tree9d097ae3dc29c87f8d2f51f92b844f8085fcd2da
parentbfa23080a60cfb543ab0a7767213a52aeca9fab0 (diff)
downloadaur-487d747e3427ec855ee409c92dc3dd60a241c339.tar.gz
example for umu
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
-rw-r--r--eduroam-umu19
-rw-r--r--install1
4 files changed, 23 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 72a28822e17c..67bd7f09b778 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = netctl-eduroam
pkgdesc = Example netctl profile for eduroam
- pkgver = 0.3
+ pkgver = 0.4
pkgrel = 1
url = http://higgsboson.tk/
install = install
diff --git a/PKGBUILD b/PKGBUILD
index 206bbe18d043..0796b36f8ed6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=netctl-eduroam
-pkgver=0.3
+pkgver=0.4
pkgrel=1
pkgdesc='Example netctl profile for eduroam'
arch=(i686 x86_64)
@@ -8,10 +8,10 @@ license=(MIT)
depends=(ca-certificates netctl)
source=(eduroam)
install=install
-
package() {
mkdir -p $pkgdir/etc/netctl/examples/
cp eduroam $pkgdir/etc/netctl/examples/
+ cp eduroam-umu $pkgdir/etc/netctl/examples/
}
md5sums=('57f90a14c3ab8d82217cbbe0749a9a4c')
sha1sums=('1e393ca918ca902f6d6f1d6f78e6d0891acd0214')
diff --git a/eduroam-umu b/eduroam-umu
new file mode 100644
index 000000000000..5ecf62d30e7c
--- /dev/null
+++ b/eduroam-umu
@@ -0,0 +1,19 @@
+# Configuration example for Umeå university (https://www.eduroam.umu.se/)
+# see http://www.eeemil.com/guides/2015/08/29/netctl-eduroam.html
+# author: Emil Marklund <eeemil@acc.umu.se>
+Description='Eduroam connection'
+Interface=wlan0
+Connection=wireless
+Security='wpa-configsection'
+IP='dhcp'
+WPAConfigSection=(
+ 'ssid="eduroam"'
+ 'key_mgmt=WPA-EAP'
+ 'eap=TLS'
+ 'proto=WPA RSN'
+ 'identity="ABCD0123@umu.se"'
+ 'private_key="/etc/netctl/umu_eduroam_ABCD0123.p12"'
+ 'private_key_passwd="YOURPASSWORD"'
+ 'ca_cert="/etc/ca-certificates/extracted/cadir/UmU_eduroam_MasterRoot_CA.pem"'
+ 'ca_cert2="/etc/ca-certificates/extracted/cadir/UmU_eduroam_MasterRoot_CA.pem"'
+)
diff --git a/install b/install
index 43a60bdea61f..574a65e290a8 100644
--- a/install
+++ b/install
@@ -2,4 +2,5 @@ post_upgrade() {
echo "To use eduroam: copy the template..."
echo " cp /etc/netctl/examples/eduroam /etc/netctl/eduroam"
echo "... and edit it, to match your credentials"
+ echo "For students of the Umeå university take a look at /etc/netctl/examples/eduroam-umu"
}