summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTeoh Han Hui2020-11-05 11:39:33 +0800
committerTeoh Han Hui2020-11-05 11:43:14 +0800
commit4898ed40dec535f61355a5c8671d3177954f3364 (patch)
treeac3b69cc2d40f535a6f490cc643be58a99f95d89
parentec794b205065b74f95971f3c19c376d79f3109fa (diff)
downloadaur-4898ed40dec535f61355a5c8671d3177954f3364.tar.gz
Adjust patch
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
-rw-r--r--adjust-resources-path.patch36
3 files changed, 26 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e723329901dc..3f01584ff465 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = makepad-git
- pkgdesc = A creative software development platform built around Rust
- pkgver = 0.1.0.r360.01a43ce
+ pkgdesc = VR, web and native collaborative shader programming environment
+ pkgver = 0.1.0.r827.8dfad9ff
pkgrel = 1
url = https://github.com/makepad/makepad
arch = i686
@@ -16,7 +16,7 @@ pkgbase = makepad-git
source = makepad-git::git+https://github.com/makepad/makepad#branch=master
source = adjust-resources-path.patch
sha256sums = SKIP
- sha256sums = 8162b3da86389ff26d97923ca144910c54ee982648cb5d12cd974e00741f9322
+ sha256sums = 8b638b723e1b3d6f1d71a6f67cde2de48973e737d2f22fbab39bc18d2b874933
pkgname = makepad-git
diff --git a/PKGBUILD b/PKGBUILD
index 7e98cd01667b..8637297dbfd6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
_pkgname=makepad
pkgname=makepad-git
-pkgver=0.1.0.r360.01a43ce
+pkgver=0.1.0.r827.8dfad9ff
pkgrel=1
-pkgdesc='A creative software development platform built around Rust'
+pkgdesc='VR, web and native collaborative shader programming environment'
arch=('i686' 'x86_64')
url='https://github.com/makepad/makepad'
license=('MIT')
@@ -16,7 +16,7 @@ conflicts=('makepad')
source=("${pkgname}::git+https://github.com/makepad/makepad#branch=master"
'adjust-resources-path.patch')
sha256sums=('SKIP'
- '8162b3da86389ff26d97923ca144910c54ee982648cb5d12cd974e00741f9322')
+ '8b638b723e1b3d6f1d71a6f67cde2de48973e737d2f22fbab39bc18d2b874933')
prepare() {
cd "${srcdir}/${pkgname}"
@@ -33,12 +33,12 @@ pkgver() {
build() {
cd "${srcdir}/${pkgname}"
- cargo build --release --locked --package "${_pkgname}"
+ cargo build --release --package "${_pkgname}"
}
check() {
cd "${srcdir}/${pkgname}"
- cargo test --release --locked --package "${_pkgname}"
+ cargo test --release --package "${_pkgname}"
}
package() {
diff --git a/adjust-resources-path.patch b/adjust-resources-path.patch
index caee4046da63..6421d719646f 100644
--- a/adjust-resources-path.patch
+++ b/adjust-resources-path.patch
@@ -1,22 +1,22 @@
diff --git a/widget/src/widgetstyle.rs b/widget/src/widgetstyle.rs
-index 5dd6235..083b204 100644
+index eb235fd..815845e 100644
--- a/widget/src/widgetstyle.rs
+++ b/widget/src/widgetstyle.rs
-@@ -141,7 +141,7 @@ pub fn set_widget_style(cx: &mut Cx, opt: &StyleOptions) {
- TextEditor::color_defocus().set(cx, color256(128, 128, 128));
- //}
+@@ -4,7 +4,7 @@ pub fn set_widget_style(cx: &mut Cx) {
-- let font = cx.load_font("resources/Ubuntu-R.ttf");
-+ let font = cx.load_font("%%USR_SHARE_PKG%%/resources/Ubuntu-R.ttf");
- Theme::text_style_unscaled().set(cx, TextStyle {
- font: font,
- font_size: 8.0,
-@@ -157,7 +157,7 @@ pub fn set_widget_style(cx: &mut Cx, opt: &StyleOptions) {
- ..Theme::text_style_unscaled().get(cx)
- });
-
-- let font = cx.load_font("resources/LiberationMono-Regular.ttf");
-+ let font = cx.load_font("%%USR_SHARE_PKG%%/resources/LiberationMono-Regular.ttf");
- Theme::text_style_fixed().set(cx, TextStyle {
- font: font,
- brightness: 1.1,
+ live_body!(cx, r#"
+ self::text_style_unscaled: TextStyle{
+- font: "resources/Ubuntu-R.ttf",
++ font: "%%USR_SHARE_PKG%%/resources/Ubuntu-R.ttf",
+ font_size: 8.0,
+ brightness: 1.0,
+ curve: 0.6,
+@@ -19,7 +19,7 @@ pub fn set_widget_style(cx: &mut Cx) {
+ }
+
+ self::text_style_fixed: TextStyle{
+- font: "resources/LiberationMono-Regular.ttf",
++ font: "%%USR_SHARE_PKG%%/resources/LiberationMono-Regular.ttf",
+ brightness: 1.1,
+ font_size: 8.0,
+ line_spacing: 1.8,