summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukáš Jirkovský2015-07-01 22:25:31 +0200
committerLukáš Jirkovský2015-07-01 22:25:31 +0200
commit48a8c642e06190c72360268d6dbc499a28137806 (patch)
tree2c6d482046c055f5084bc92a21dbc384f7943bae
downloadaur-48a8c642e06190c72360268d6dbc499a28137806.tar.gz
initial import
-rw-r--r--.SRCINFO18
-rw-r--r--LICENSE5
-rw-r--r--PKGBUILD43
-rw-r--r--unshake.install6
-rw-r--r--unshake.sh3
5 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..727bf4903c3a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = unshake
+ pkgdesc = Sharpens photos which are blurred, poorly focused or shaken
+ pkgver = 1.5r1
+ pkgrel = 3
+ url = http://www.unshake.co.uk/
+ install = unshake.install
+ arch = any
+ license = custom
+ depends = java-runtime
+ source = http://www.zen147963.zen.co.uk/Unshake/Unshake15r1.zip
+ source = unshake.sh
+ source = LICENSE
+ md5sums = 7082391e5862217f70f747552ea9138a
+ md5sums = 70761d25da1fcd9de1c89d84b836384c
+ md5sums = 784de31896415c2f6a09862c83831a56
+
+pkgname = unshake
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..bf18ff424348
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,5 @@
+Unshake is the property of M.D. Cahill, and is offered for private use only. By downloading Unshake, I am agreeing not to attempt to gain financially by its acquisition or use.
+
+I shall not attempt to disassemble, decompile or reverse-engineer Unshake, nor use information gained thereby for the financial profit of myself or others.
+
+I understand that Unshake is offered free of charge, and without warranty of any kind. It is my responsibility to judge whether it is right or safe to use, and to ensure that my computer is backed-up prior to the installation or use of any new software.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..81f09a3b75e9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Lukas Jirkovsky <l.jirkovsky@gmail.com>
+pkgname=unshake
+pkgver=1.5r1
+pkgrel=3
+pkgdesc="Sharpens photos which are blurred, poorly focused or shaken"
+arch=('any')
+if [ $CARCH == "i686" ]; then
+ arch=('i686')
+fi
+url="http://www.unshake.co.uk/"
+license=('custom')
+depends=('java-runtime')
+makedepends_i686=('netpbm')
+optdepends_i686=('netpbm: unshake command-line tool for PNM files')
+install=unshake.install
+source=(http://www.zen147963.zen.co.uk/Unshake/Unshake15r1.zip unshake.sh LICENSE)
+md5sums=('7082391e5862217f70f747552ea9138a'
+ '70761d25da1fcd9de1c89d84b836384c'
+ '784de31896415c2f6a09862c83831a56')
+
+package() {
+ cd "$srcdir/Unshake"
+ # install java version (the main program)
+ install -D -m644 Unshake.jar "$pkgdir"/usr/share/java/$pkgname/Unshake.jar
+ install -D -m755 "$srcdir"/unshake.sh "$pkgdir"/usr/bin/unshake
+
+ if [ $CARCH == "i686" ]; then
+ # install C version
+ tar xf UnshakeC$pkgver.tar.gz
+ cd UnshakeC$pkgver
+ make LOPTS="-lnetpbm -lm -L. -L/usr/local/lib -lUnshake -lphase" \
+ COPTS="-O3 -I/usr/include/netpbm -ansi"
+ install -D -m755 Unshake "$pkgdir"/usr/bin/unshake-console
+ install -D -m644 Unshake.1 "$pkgdir"/usr/share/man/man1/Unshake.1
+ #install license
+ install -D -m644 LICENCE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE-unshake-console
+ fi
+
+ #install license
+ install -D -m644 "$srcdir"/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/unshake.install b/unshake.install
new file mode 100644
index 000000000000..74d01c3f25c4
--- /dev/null
+++ b/unshake.install
@@ -0,0 +1,6 @@
+
+pre_install() {
+ echo "You have to read license located in /usr/share/licenses/unshake before using unshake."
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/unshake.sh b/unshake.sh
new file mode 100644
index 000000000000..646ddbb33ab7
--- /dev/null
+++ b/unshake.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+java -Xmx512m -jar /usr/share/java/unshake/Unshake.jar
+