summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon De Andrade2022-01-13 21:28:39 +0000
committerLeon De Andrade2022-01-13 21:28:39 +0000
commit48b3a54a186646c6ec12947255eeb53b9ee38142 (patch)
tree26e3c3bbb0ae7a0fabdeb7f4266ca83f887a877d
parentfc7e5b4311ffd89baf6437379445074b63e47063 (diff)
parent3e4c3140e6c904ba1dc798012bbf32ce6f0f0eb1 (diff)
downloadaur-48b3a54a186646c6ec12947255eeb53b9ee38142.tar.gz
Merge branch 'release/1.21.0' into 'master'
Update to 1.21.0 See merge request bencehornak/arch-theia-electron!17
-rw-r--r--PKGBUILD4
-rw-r--r--package.json90
2 files changed, 48 insertions, 46 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 77d535893218..a1946424085a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Leon De Andrade <leondeandrade@hotmail.com>
pkgname=theia-electron
-pkgver=1.19.0
+pkgver=1.21.0
pkgrel=1
arch=('any')
url='https://www.theia-ide.org/'
@@ -22,7 +22,7 @@ source=(
"https://raw.githubusercontent.com/eclipse-theia/theia/v$pkgver/LICENSE"
)
md5sums=('5a26cc7b1b461bec8533266dbe64c87e'
- 'a30ccc4fd97ca2218bbe85220b32a6a2'
+ '229647ed23942b7ae4c449e0d9619018'
'8a3461a9d1c50f6bfe60902d020bb797'
'd387a0df41b11ba3d33360812bfbbe2c'
'1dde0e422484895d3509f4ee9bb8d980'
diff --git a/package.json b/package.json
index 9ab732fa9e48..1d641a9e35e1 100644
--- a/package.json
+++ b/package.json
@@ -1,6 +1,6 @@
{
"private": true,
- "version": "1.19.0",
+ "version": "1.21.0",
"main": "src-gen/frontend/electron-main.js",
"license": "EPL-2.0 OR GPL-2.0 WITH Classpath-exception-2.0",
"theia": {
@@ -48,6 +48,8 @@
"vscode-builtin-markdown": "https://open-vsx.org/api/vscode/markdown/1.53.2/file/vscode.markdown-1.53.2.vsix",
"vscode-builtin-markdown-language-features": "https://open-vsx.org/api/vscode/markdown-language-features/1.39.2/file/vscode.markdown-language-features-1.39.2.vsix",
"vscode-builtin-merge-conflict": "https://open-vsx.org/api/vscode/merge-conflict/1.53.2/file/vscode.merge-conflict-1.53.2.vsix",
+ "vscode-builtin-node-debug": "https://open-vsx.org/api/ms-vscode/node-debug/1.45.0/file/ms-vscode.node-debug-1.45.0.vsix",
+ "vscode-builtin-node-debug2": "https://open-vsx.org/api/ms-vscode/node-debug2/1.43.0/file/ms-vscode.node-debug2-1.43.0.vsix",
"vscode-builtin-npm": "https://open-vsx.org/api/vscode/npm/1.53.2/file/vscode.npm-1.53.2.vsix",
"vscode-builtin-objective-c": "https://open-vsx.org/api/vscode/objective-c/1.53.2/file/vscode.objective-c-1.53.2.vsix",
"vscode-builtin-perl": "https://open-vsx.org/api/vscode/perl/1.53.2/file/vscode.perl-1.53.2.vsix",
@@ -82,51 +84,51 @@
"vscode-references-view": "https://open-vsx.org/api/ms-vscode/references-view/0.0.81/file/ms-vscode.references-view-0.0.81.vsix"
},
"dependencies": {
- "@theia/bulk-edit": "1.19.0",
- "@theia/callhierarchy": "1.19.0",
- "@theia/console": "1.19.0",
- "@theia/core": "1.19.0",
- "@theia/debug": "1.19.0",
- "@theia/editor": "1.19.0",
- "@theia/editor-preview": "1.19.0",
- "@theia/electron": "1.19.0",
- "@theia/external-terminal": "1.19.0",
- "@theia/file-search": "1.19.0",
- "@theia/filesystem": "1.19.0",
- "@theia/getting-started": "1.19.0",
- "@theia/git": "1.19.0",
- "@theia/keymaps": "1.19.0",
- "@theia/markers": "1.19.0",
- "@theia/messages": "1.19.0",
- "@theia/metrics": "1.19.0",
- "@theia/mini-browser": "1.19.0",
- "@theia/monaco": "1.19.0",
- "@theia/navigator": "1.19.0",
- "@theia/outline-view": "1.19.0",
- "@theia/output": "1.19.0",
- "@theia/plugin": "1.19.0",
- "@theia/plugin-dev": "1.19.0",
- "@theia/plugin-ext": "1.19.0",
- "@theia/plugin-ext-vscode": "1.19.0",
- "@theia/plugin-metrics": "1.19.0",
- "@theia/preferences": "1.19.0",
- "@theia/preview": "1.19.0",
- "@theia/process": "1.19.0",
- "@theia/property-view": "1.19.0",
- "@theia/scm": "1.19.0",
- "@theia/scm-extra": "1.19.0",
- "@theia/search-in-workspace": "1.19.0",
- "@theia/task": "1.19.0",
- "@theia/terminal": "1.19.0",
- "@theia/timeline": "1.19.0",
- "@theia/typehierarchy": "1.19.0",
- "@theia/userstorage": "1.19.0",
- "@theia/variable-resolver": "1.19.0",
- "@theia/vsx-registry": "1.19.0",
- "@theia/workspace": "1.19.0"
+ "@theia/bulk-edit": "1.21.0",
+ "@theia/callhierarchy": "1.21.0",
+ "@theia/console": "1.21.0",
+ "@theia/core": "1.21.0",
+ "@theia/debug": "1.21.0",
+ "@theia/editor": "1.21.0",
+ "@theia/editor-preview": "1.21.0",
+ "@theia/electron": "1.21.0",
+ "@theia/external-terminal": "1.21.0",
+ "@theia/file-search": "1.21.0",
+ "@theia/filesystem": "1.21.0",
+ "@theia/getting-started": "1.21.0",
+ "@theia/git": "1.21.0",
+ "@theia/keymaps": "1.21.0",
+ "@theia/markers": "1.21.0",
+ "@theia/messages": "1.21.0",
+ "@theia/metrics": "1.21.0",
+ "@theia/mini-browser": "1.21.0",
+ "@theia/monaco": "1.21.0",
+ "@theia/navigator": "1.21.0",
+ "@theia/outline-view": "1.21.0",
+ "@theia/output": "1.21.0",
+ "@theia/plugin": "1.21.0",
+ "@theia/plugin-dev": "1.21.0",
+ "@theia/plugin-ext": "1.21.0",
+ "@theia/plugin-ext-vscode": "1.21.0",
+ "@theia/plugin-metrics": "1.21.0",
+ "@theia/preferences": "1.21.0",
+ "@theia/preview": "1.21.0",
+ "@theia/process": "1.21.0",
+ "@theia/property-view": "1.21.0",
+ "@theia/scm": "1.21.0",
+ "@theia/scm-extra": "1.21.0",
+ "@theia/search-in-workspace": "1.21.0",
+ "@theia/task": "1.21.0",
+ "@theia/terminal": "1.21.0",
+ "@theia/timeline": "1.21.0",
+ "@theia/typehierarchy": "1.21.0",
+ "@theia/userstorage": "1.21.0",
+ "@theia/variable-resolver": "1.21.0",
+ "@theia/vsx-registry": "1.21.0",
+ "@theia/workspace": "1.21.0"
},
"devDependencies": {
- "@theia/cli": "1.19.0"
+ "@theia/cli": "1.21.0"
},
"scripts": {
"build": "electron-rebuild && theia download:plugins && theia build --mode production",