summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-07-07 18:11:53 -0600
committerMark Wagie2022-07-07 18:11:53 -0600
commit48b45d13b1451e954204bc6a9997663ee0afb681 (patch)
tree96b8a73c27be5edf214423d869ef18f450a57fbb
parent063ebb7e45a944e430c0910709bffe9206b917ed (diff)
downloadaur-48b45d13b1451e954204bc6a9997663ee0afb681.tar.gz
42.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 35d7a36c9271..a060178a19e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,27 @@
pkgbase = workbench
pkgdesc = Learn and prototype with GNOME technologies
- pkgver = 42.0
- pkgrel = 2
+ pkgver = 42.1
+ pkgrel = 1
url = https://github.com/sonnyp/Workbench
install = workbench.install
arch = x86_64
license = GPL3
checkdepends = appstream-glib
- makedepends = blueprint-compiler
makedepends = git
makedepends = gobject-introspection
makedepends = meson
makedepends = npm
- makedepends = vala
+ depends = blueprint-compiler
depends = gjs
depends = gtksourceview5
depends = libadwaita
depends = libportal-gtk4
+ depends = vala
depends = vte4-git
optdepends = gtk4-demos: GTK Demo, GTK Widget Factory, GTK Icon Browser
optdepends = highlight: syntax highlighting
optdepends = libadwaita-demos: Adwaita Demo
- source = git+https://github.com/sonnyp/Workbench.git#commit=b86cdfb3e6440e4e034fcb6c609ff84401630faa
+ source = git+https://github.com/sonnyp/Workbench.git#commit=16f2ebc7cccad61ac44d219c24ffcb9f8722b232
source = git+https://gitlab.gnome.org/Teams/Design/icon-development-kit-www.git
source = git+https://github.com/sonnyp/troll.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 829950d834cf..e434febbdcfb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,20 @@
# Co-Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=workbench
-pkgver=42.0
-pkgrel=2
+pkgver=42.1
+pkgrel=1
pkgdesc="Learn and prototype with GNOME technologies"
arch=('x86_64')
url="https://github.com/sonnyp/Workbench"
license=('GPL3')
-depends=('gjs' 'gtksourceview5' 'libadwaita' 'libportal-gtk4' 'vte4-git')
-makedepends=('blueprint-compiler' 'git' 'gobject-introspection' 'meson' 'npm' 'vala')
+depends=('blueprint-compiler' 'gjs' 'gtksourceview5' 'libadwaita' 'libportal-gtk4' 'vala' 'vte4-git')
+makedepends=('git' 'gobject-introspection' 'meson' 'npm')
checkdepends=('appstream-glib')
optdepends=('gtk4-demos: GTK Demo, GTK Widget Factory, GTK Icon Browser'
'highlight: syntax highlighting'
'libadwaita-demos: Adwaita Demo')
install="$pkgname.install"
-_commit=b86cdfb3e6440e4e034fcb6c609ff84401630faa
+_commit=16f2ebc7cccad61ac44d219c24ffcb9f8722b232
source=("git+https://github.com/sonnyp/Workbench.git#commit=${_commit}"
'git+https://gitlab.gnome.org/Teams/Design/icon-development-kit-www.git'
'git+https://github.com/sonnyp/troll.git')
@@ -35,7 +35,9 @@ prepare() {
git config submodule.src/troll.url "$srcdir/troll"
git submodule update
+ # This is not a Flatpak
sed -i 's|app/share|usr/share|g' src/re.sonny.Workbench
+ sed -i '/Flatpak/d' src/about.js
}
build() {