summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2023-04-23 15:30:09 +0200
committerPhilipp A2023-04-23 15:30:09 +0200
commit48bcdc4bc3f8257980f6d52608ca0f74ed245449 (patch)
treeefa775fa946e337851851d9b3192ab5ecf370241
parent263f00ef4df89e65e88a8722a6a61ac1c45b2be3 (diff)
downloadaur-48bcdc4bc3f8257980f6d52608ca0f74ed245449.tar.gz
v1.93
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD11
3 files changed, 18 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8a64e53ca05..80b66dd292b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = scanpy
pkgdesc = Single-Cell Analysis in Python
- pkgver = 1.9.1
- pkgrel = 2
+ pkgver = 1.9.3
+ pkgrel = 1
url = https://github.com/theislab/scanpy
arch = any
license = BSD
@@ -28,6 +28,7 @@ pkgbase = scanpy
depends = python-umap-learn>=0.3.10
depends = python-packaging
depends = python-sinfo
+ optdepends = python-igraph: PAGA support (also transitively needed for Louvain/Leiden)
optdepends = python-louvain-igraph: Louvain clustering
optdepends = python-leidenalg: leiden community detection
optdepends = python-bbknn: Batch balanced KNN (batch correction)
@@ -37,9 +38,13 @@ pkgbase = scanpy
optdepends = python-harmonypy: Harmony dataset integration algorithm
optdepends = python-scanorama: Scanorama dataset integration algorithm
optdepends = python-scrublet: Cell doublet detection
+ optdepends = rapids-cudf: NVIDIA RAPIDS acceleration
+ optdepends = rapids-cuml: NVIDIA RAPIDS acceleration
+ optdepends = rapids-cugraph: NVIDIA RAPIDS acceleration
+ optdepends = python-dask: Dask parallelization
provides = scanpy
provides = python-scanpy
- source = https://files.pythonhosted.org/packages/source/s/scanpy/scanpy-1.9.1.tar.gz
- sha256sums = 00c9a83b649da7e0171c91e9a08cff632102faa760614fd05cd4d1dbba4eb541
+ source = https://files.pythonhosted.org/packages/source/s/scanpy/scanpy-1.9.3.tar.gz
+ sha256sums = dfe65f9acd9f4c1740079a099f89fa6a44b6f0ef75ecaf85247ad4af859144d7
pkgname = scanpy
diff --git a/.gitignore b/.gitignore
index 7e480d700bee..6b535dcf8f80 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@
/src/
/*.pkg.*
/*.tar.gz
+/*.log
diff --git a/PKGBUILD b/PKGBUILD
index f73e9eabb73d..b0eb9a298440 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Philipp A. <flying-sheep@web.de>
pkgname=scanpy
-pkgver=1.9.1
-pkgrel=2
+pkgver=1.9.3
+pkgrel=1
pkgdesc='Single-Cell Analysis in Python'
arch=(any)
provides=(scanpy python-scanpy)
@@ -29,6 +29,7 @@ depends=(
python-sinfo
)
optdepends=(
+ 'python-igraph: PAGA support (also transitively needed for Louvain/Leiden)'
'python-louvain-igraph: Louvain clustering'
'python-leidenalg: leiden community detection'
'python-bbknn: Batch balanced KNN (batch correction)'
@@ -38,10 +39,14 @@ optdepends=(
'python-harmonypy: Harmony dataset integration algorithm'
'python-scanorama: Scanorama dataset integration algorithm'
'python-scrublet: Cell doublet detection'
+ 'rapids-cudf: NVIDIA RAPIDS acceleration'
+ 'rapids-cuml: NVIDIA RAPIDS acceleration'
+ 'rapids-cugraph: NVIDIA RAPIDS acceleration'
+ 'python-dask: Dask parallelization'
)
makedepends=(python-flit-core python-setuptools-scm python-build python-installer python-wheel)
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
-sha256sums=('00c9a83b649da7e0171c91e9a08cff632102faa760614fd05cd4d1dbba4eb541')
+sha256sums=('dfe65f9acd9f4c1740079a099f89fa6a44b6f0ef75ecaf85247ad4af859144d7')
build() {
cd "$pkgname-$pkgver"