summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2021-05-12 19:57:16 +0800
committerUniversebenzene2021-05-12 19:57:16 +0800
commit48d2d2ba24e70773a889f6101a6ce5fcb736abeb (patch)
tree340f2353009ea33c06737062bf873429c3e62c77
downloadaur-48d2d2ba24e70773a889f6101a6ce5fcb736abeb.tar.gz
Initial import 0.4.2
-rw-r--r--.SRCINFO32
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD61
3 files changed, 101 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b2a3487e8ae8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = python-jupyter-cache
+ pkgdesc = A defined interface for working with a cache of jupyter notebooks
+ pkgver = 0.4.2
+ pkgrel = 1
+ url = https://jupyter-cache.readthedocs.io
+ arch = i686
+ arch = x86_64
+ license = MIT
+ checkdepends = jupyter-notebook
+ checkdepends = python-requests
+ checkdepends = python-nbdime
+ checkdepends = jupyter-nbclient
+ checkdepends = python-sqlalchemy
+ checkdepends = python-jinja
+ checkdepends = python-click-completion
+ checkdepends = python-click-log
+ makedepends = python-setuptools
+ source = https://files.pythonhosted.org/packages/source/j/jupyter-cache/jupyter-cache-0.4.2.tar.gz
+ md5sums = a1f1a9846e4462ce79a81a5b2cee6270
+
+pkgname = python-jupyter-cache
+ depends = python-nbdime
+ depends = jupyter-nbclient
+ depends = python-sqlalchemy
+ optdepends = python-click-completion: cli
+ optdepends = python-click-log: cli
+ optdepends = python-tabulate: cli
+ optdepends = python-yaml: cli
+ optdepends = flake8: code_style
+ optdepends = python-black: code_style
+ optdepends = python-pre-commit: code_style
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3002ef3c4dc8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+src
+pkg
+*.log
+*.src.tar.gz
+*.tar.gz
+*.tar.bz2
+*.part
+*.pkg.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dce0d15043cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer: Astro Benzene <universebenzene at sina dot com>
+pkgbase=python-jupyter-cache
+_pyname=${pkgbase#python-}
+pkgname=("python-${_pyname}")
+#"python-${_pyname}-doc")
+pkgver=0.4.2
+pkgrel=1
+pkgdesc="A defined interface for working with a cache of jupyter notebooks"
+arch=('i686' 'x86_64')
+url="https://jupyter-cache.readthedocs.io"
+license=('MIT')
+makedepends=('python-setuptools')
+checkdepends=('jupyter-notebook'
+ 'python-requests'
+ 'python-nbdime'
+ 'jupyter-nbclient'
+ 'python-sqlalchemy'
+ 'python-jinja'
+ 'python-click-completion'
+ 'python-click-log')
+source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
+md5sums=('a1f1a9846e4462ce79a81a5b2cee6270')
+
+build() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+ python setup.py build
+
+# msg "Building Docs"
+# python setup.py build_sphinx
+}
+
+check() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ python setup.py test
+# pytest #|| warning "Tests failed"
+}
+
+package_python-jupyter-cache() {
+ depends=('python-nbdime' 'jupyter-nbclient' 'python-sqlalchemy')
+ optdepends=('python-click-completion: cli'
+ 'python-click-log: cli'
+ 'python-tabulate: cli'
+ 'python-yaml: cli'
+ 'flake8: code_style'
+ 'python-black: code_style'
+ 'python-pre-commit: code_style')
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ install -D -m644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -D -m644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+ python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+}
+
+#package_python-jupyter-cache-doc() {
+# pkgdesc="Documentation for Sphinx-Gallery extension"
+# cd ${srcdir}/${_pyname}-${pkgver}/doc/_build
+#
+# install -d -m755 "${pkgdir}/usr/share/doc/${pkgbase}"
+# cp -a html "${pkgdir}/usr/share/doc/${pkgbase}"
+#}