summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2020-12-26 10:59:47 -0500
committerVincent Grande2020-12-26 10:59:47 -0500
commit48ea9728282036e20520be96370f830ac574ad30 (patch)
tree3300b784e2a7ee811d73d812b7e9193b11cdc732
downloadaur-48ea9728282036e20520be96370f830ac574ad30.tar.gz
initial upload
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD89
-rw-r--r--krb5-config_LDFLAGS.patch12
3 files changed, 123 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..13385cca49be
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = lib32-krb5minimal--git
+ pkgdesc = The Kerberos network authentication system (32-bit)
+ pkgver = 1.18.3
+ pkgrel = 1
+ url = https://web.mit.edu/kerberos/
+ arch = x86_64
+ license = custom
+ makedepends = perl
+ depends = lib32-e2fsprogs
+ depends = lib32-libldap
+ depends = lib32-keyutils
+ depends = krb5
+ provides = lib32-krb5
+ conflicts = lib32-krb5
+ options = !emptydirs
+ source = git+https://github.com/krb5/krb5
+ source = krb5-config_LDFLAGS.patch
+ sha512sums = SKIP
+ sha512sums = SKIP
+
+pkgname = lib32-krb5minimal--git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f0a90d9b6d1f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,89 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor: Florian Pritz <flo@xinu.at>
+# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
+
+_pkgbasename=krb5
+pkgname=lib32-${_pkgbasename}minimal--git
+pkgver=1.18.3
+pkgrel=1
+pkgdesc='The Kerberos network authentication system (32-bit)'
+url='https://web.mit.edu/kerberos/'
+arch=('x86_64')
+license=('custom')
+depends=('lib32-e2fsprogs' 'lib32-libldap' 'lib32-keyutils' "${_pkgbasename}")
+makedepends=('perl')
+provides=(lib32-krb5)
+conflicts=(lib32-krb5)
+options=('!emptydirs')
+source=("git+https://github.com/krb5/krb5"
+ krb5-config_LDFLAGS.patch)
+sha512sums=('SKIP'
+ 'SKIP')
+#validpgpkeys=('2C732B1C0DBEF678AB3AF606A32F17FD0055C305' # Tom Yu <tlyu@mit.edu>
+# 'C4493CB739F4A89F9852CBC20CBA08575F8372DF') # Greg Hudson <ghudson@mit.edu>
+
+pkgver() {
+ cd krb5
+ git describe --tags --always | sed 's/-/+/g'
+}
+
+prepare() {
+ cd krb5
+
+ # cf https://bugs.gentoo.org/show_bug.cgi?id=448778
+ patch -p1 < "${srcdir}"/krb5-config_LDFLAGS.patch
+
+ # FS#25384
+ sed -i "/KRB5ROOT=/s/\/local//" src/util/ac_check_krb5.m4
+}
+
+build() {
+ cd "${srcdir}/krb5/src"
+
+ export CC="gcc -m32"
+ export CXX="g++ -m32"
+ export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+
+ export CFLAGS+=" -fPIC -fno-strict-aliasing -fstack-protector-all"
+ export CPPFLAGS+=" -I/usr/include/et"
+
+ autoreconf -fi
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --libdir=/usr/lib32 \
+ --enable-shared \
+ --with-system-et \
+ --with-system-ss \
+ --disable-rpath \
+ --without-tcl \
+ --disable-dns-for-realm \
+ --without-ldap \
+ --without-vague-errors \
+ --disable-audit-plugin \
+ --disable-asan \
+ --without-lmdb \
+ --without-system-verto
+ make
+}
+
+#check() {
+ # We can't do this in the build directory.
+
+ # only works if the hostname is set properly/resolves to something. whatever...
+ #cd "${srcdir}/${_pkgbasename}-${pkgver}"
+ #make -C src check
+#}
+
+package() {
+ cd krb5/src
+ make DESTDIR="${pkgdir}" install
+
+ rm -rf "${pkgdir}"/usr/{include,share,bin,sbin}
+ install -d "${pkgdir}/usr/share/licenses"
+ ln -s krb5 "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/krb5-config_LDFLAGS.patch b/krb5-config_LDFLAGS.patch
new file mode 100644
index 000000000000..1b850867398b
--- /dev/null
+++ b/krb5-config_LDFLAGS.patch
@@ -0,0 +1,12 @@
+Bug #448778
+--- krb5-1.11/src/build-tools/krb5-config.in 2012-12-18 02:47:04.000000000 +0000
++++ krb5-1.11/src/build-tools/krb5-config.in 2012-12-28 07:13:16.582693363 +0000
+@@ -217,7 +217,7 @@
+ -e 's#\$(PROG_RPATH)#'$libdir'#' \
+ -e 's#\$(PROG_LIBPATH)#'$libdirarg'#' \
+ -e 's#\$(RPATH_FLAG)#'"$RPATH_FLAG"'#' \
+- -e 's#\$(LDFLAGS)#'"$LDFLAGS"'#' \
++ -e 's#\$(LDFLAGS)##' \
+ -e 's#\$(PTHREAD_CFLAGS)#'"$PTHREAD_CFLAGS"'#' \
+ -e 's#\$(CFLAGS)##'`
+