summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2014-03-11 22:02:58 +0200
committerCaleb Maclennan2014-03-11 22:02:58 +0200
commit4908a4c5fbc04fb731f123f6f34fb5232650388f (patch)
treef94bd59b7bd4127b7f1e47e4f0e9a969fd7979c9
downloadaur-4908a4c5fbc04fb731f123f6f34fb5232650388f.tar.gz
began working on install for aguilas
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD29
-rw-r--r--config.php97
-rw-r--r--tempfile.patch15
4 files changed, 161 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9d9d256a2ae8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = aguilas
+ pkgdesc = An LDAP user manager and password self-service webaapp.
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://code.google.com/p/aguilas/
+ arch = any
+ license = GPL3
+ makedepends = python-sphinx
+ makedepends = icoutils
+ makedepends = python-docutils
+ makedepends = imagemagick
+ source = https://github.com/LuisAlejandro/aguilas/archive/1.0.2.tar.gz
+ source = tempfile.patch
+ source = config.php
+ md5sums = b6f23c4bc771a0ca512e45fd7e265749
+ md5sums = 7b285c7af3d739d26efe17c34c9957ee
+ md5sums = 354f77b0725b89efedd7c8682ad7e5de
+
+pkgname = aguilas
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7756b9aed4e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+#
+# WARNING: Unfinished, aguilas has a lot of stuff in the makefile that needs
+# fixing (hard coded Debian paths) before use
+#
+pkgname=aguilas
+pkgver=1.0.2
+pkgrel=1
+url=https://code.google.com/p/aguilas/
+pkgdesc="An LDAP user manager and password self-service webaapp."
+arch=('any')
+license=('GPL3')
+#depends=('php' 'php-mcrypt' 'php-gd' 'php-ldap' 'php-suhosin' 'smtp-forwarder' 'mailx')
+makedepends=('python-sphinx' 'icoutils' 'python-docutils' 'imagemagick')
+# libmagickcore-extra
+source=("https://github.com/LuisAlejandro/$pkgname/archive/$pkgver.tar.gz" 'tempfile.patch' 'config.php')
+md5sums=('b6f23c4bc771a0ca512e45fd7e265749'
+ '7b285c7af3d739d26efe17c34c9957ee'
+ '354f77b0725b89efedd7c8682ad7e5de')
+
+build () {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -p1 -i "${srcdir}"/tempfile.patch
+}
+
+package () {
+ cd "$srcdir/$pkgname-$pkgver"
+ find
+}
diff --git a/config.php b/config.php
new file mode 100644
index 000000000000..e3b82ea07b19
--- /dev/null
+++ b/config.php
@@ -0,0 +1,97 @@
+<?php
+
+/**********************************
+ * CONFIGURATION FILE FOR AGUILAS *
+ **********************************/
+
+/* ========== Branding ========== */
+
+// Name
+/// Name of the Application. e.g. "Debian User Management"
+$app_name = "Aguilas User Management";
+// Operator
+/// The person or group responsible for managing the application. e.g. "Venezuela Linux User Group"
+$app_operator = "Organization";
+// Application e-mail
+/// The e-mail address that will appear as sender in all operation e-mails to registered users.
+$app_mail = "admin@example.com";
+// Operator e-mail
+/// The e-mail address you wish to use for sending error reports
+$op_mail = "aguilas@example.com";
+// Application language
+/// The language that you wish to see in your application. Must be available in the po/ folder
+$app_locale = "en_US";
+// Application theme
+/// The theme applied to the application. Must be available in the themes/ folder
+$app_theme = "canaima";
+// Application URL
+// The public address of the aplication, in the form of "example.org" (without http://)
+$app_url = $_SERVER['SERVER_NAME']."/aguilas";
+// Application links
+// an array of link_title => link of the applications connected
+// to the LDAP and whose registration process have been delegated to AGUILAS
+// this will appear on the main menu
+$app_links = array( "APP1" => "http://$app_url",
+ "APP2" => "http://$app_url",
+ "APP3" => "http://$app_url",
+ "APP4" => "http://$app_url"
+ );
+// Application log directory
+// the directory where the logs are going to be stored
+// has to be writable by www-data
+$log_dir = "/var/log/aguilas/";
+
+
+/* ========== MYSQL Database ========== */
+
+/// IP or Domain of the server where the MYSQL database is located
+$mysql_host = "localhost";
+/// Database name (will be created if it does not exist)
+$mysql_dbname = "aguilas";
+/// User with permissions to read and create tables on the database
+$mysql_user = "mysql_user";
+/// Password for the user
+$mysql_pass = "mysql_password";
+
+
+/* ========== LDAP Database ========== */
+
+/// IP or Domain of the server where the LDAP service is located
+$ldap_server = "localhost";
+// Port for connecting to the server
+// 389 for non-secure connection
+// 636 for secure connection
+// must be an integer
+$ldap_port = 389;
+/// DN with read-write priviledges on the LDAP server
+$ldap_dn = "cn=root,dn=example,dn=com";
+/// Password for the writer DN
+$ldap_pass = "ldap_password";
+/// Base DN to perform searches and include new users
+$ldap_base = "dn=example,dn=com";
+// Encrypt algorithm used to save passwords on LDAP
+// Options:
+// CLEAR | MD5 | SHA | CRYPT | SSHA | SMD5 | BLOWFISH | EXT_DES | MD5CRYPT
+$ldap_enc = "SSHA";
+// Use secure tunnel connection (TLS)
+// Must have a valid certificate for autentication
+// Options:
+// FALSE = Don't use TLS (default) | TRUE = Use TLS
+$ldap_tls = FALSE;
+// Entry used as reference to determine the uidNumber of new users
+// will be incremented automatically with each new user
+// will be created if it doesn't exist
+// must be contained within $ldap_base
+$maxuid = "uid=maxUID";
+$maxuidbase = $ldap_base;
+$maxuiddn = $maxuid . "," . $maxuidbase;
+// The start number for the uidNumber attribute of the first user
+$maxuidstart = "1100";
+// Asociative array containing Group Name => Group ID (gidNumber)
+// this is used to parse the name of the group according to the
+// gidNumber assigned to each LDAP DN entry
+$ldap_gid = array("people" => "100", "admin" => "200");
+// The default group assigned to new users
+$ldap_default_group = "people";
+
+?>
diff --git a/tempfile.patch b/tempfile.patch
new file mode 100644
index 000000000000..84c6ce80baaa
--- /dev/null
+++ b/tempfile.patch
@@ -0,0 +1,15 @@
+diff --git a/tools/gen-conf.sh b/tools/gen-conf.sh
+index 412a80c..a9623f1 100755
+--- a/tools/gen-conf.sh
++++ b/tools/gen-conf.sh
+@@ -29,8 +29,8 @@
+ ROOTFLDR="$( pwd )"
+ SAMPLE="${ROOTFLDR}/setup/config.php.example"
+ FILE="${ROOTFLDR}/setup/config.php"
+-VARTMP="$( tempfile )"
+-COMTMP="$( tempfile )"
++VARTMP="$( mktemp )"
++COMTMP="$( mktemp )"
+
+ echo
+ echo "We are going to ask you a couple of questions regarding AGUILAS configuration."