summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEllis Kenyo2024-04-06 06:05:10 +0100
committerEllis Kenyo2024-04-06 06:26:39 +0100
commit491a69ddb783c93e1945acc5d96616affcdf9145 (patch)
tree30a43b0bb441e53c5ec5aa525ea5e960764251f2
parentfeee0094e471f710d11decedea6331d3a91381af (diff)
downloadaur-491a69ddb783c93e1945acc5d96616affcdf9145.tar.gz
fix: 0.8.12 => 0.8.13
Also update to use the new toml config
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c27056b05a80..9d47ba5579ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,23 @@
# Maintainer: Ellis Kenyo <me at elken dot dev>
pkgname=python-xxh
-pkgver=0.8.12
+pkgver=0.8.13
pkgrel=1
pkgdesc="Take your shell with you!"
arch=('x86_64')
url="https://pypi.org/project/xxh-xxh/"
-depends=('python' 'python-pexpect' 'python-setuptools' 'python-yaml')
-makedepends=()
+depends=('python' 'python-pexpect' 'python-yaml')
+makedepends=("python-build" "python-installer" "python-wheel")
license=('BSD')
source=($pkgname-$pkgver::https://github.com/xxh/xxh/archive/refs/tags/$pkgver.zip)
-md5sums=('63b834948c02976d82055218b41d3612')
+md5sums=('a540a8553927f2327fc4454c71a673c7')
+
+build() {
+ cd "$srcdir"/$(echo $pkgname | cut -d- -f2)-$pkgver
+ python -m build --wheel --no-isolation
+}
package() {
cd "$srcdir"/$(echo $pkgname | cut -d- -f2)-$pkgver
- python setup.py install --root="$pkgdir"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}