summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Rebischke2017-05-02 17:30:01 +0200
committerChristian Rebischke2017-05-02 17:30:01 +0200
commit496f6779e71452125910c5d2216a36279328efbb (patch)
tree111c728281d73f9fc9ace72b100401fd54a3b8da
downloadaur-496f6779e71452125910c5d2216a36279328efbb.tar.gz
initial release
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ad0f972b618f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = vim-sslsecure
+ pkgdesc = Highlight insecure SSL configuration in Vim (works for all OpenSSL/ LibreSSL cipher strings, independent of the filetype)
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/chr4/sslsecure.vim
+ arch = any
+ groups = vim-plugins
+ license = GPL3
+ depends = vim
+ source = vim-sslsecure-1.0.0.tar.gz::https://github.com/chr4/sslsecure.vim/archive/v1.0.0.tar.gz
+ sha512sums = 24a534afb0f731d3c8b361d12536d33b1cba4e11d7d4c52f413eebe04bfa168e5d60fde68d646ee72fefdf8f74b76328e38fe6f94b59df9fc0aeea890755c6af
+
+pkgname = vim-sslsecure
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fb5dc5f6dd70
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Christian Rebischke <chris.rebischke[at]archlinux[dot]org>
+_pkgname=sslsecure.vim
+pkgname=vim-sslsecure
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='Highlight insecure SSL configuration in Vim (works for all OpenSSL/ LibreSSL cipher strings, independent of the filetype)'
+arch=('any')
+url='https://github.com/chr4/sslsecure.vim'
+license=('GPL3')
+depends=('vim')
+groups=('vim-plugins')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/chr4/sslsecure.vim/archive/v${pkgver}.tar.gz")
+sha512sums=('24a534afb0f731d3c8b361d12536d33b1cba4e11d7d4c52f413eebe04bfa168e5d60fde68d646ee72fefdf8f74b76328e38fe6f94b59df9fc0aeea890755c6af')
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ install -Dm644 'plugin/sslsecure.vim' "${pkgdir}/usr/share/vim/vimfiles/plugin/sslsecure.vim"
+}
+
+# vim:set et sw=2 ts=2 tw=79: