summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Schumacher2020-09-15 14:11:03 +0200
committerTim Schumacher2020-09-15 14:11:03 +0200
commit4971307770c668012b3ee0d6392e219fec5ec755 (patch)
treeeb592b44066004d67b48de293c77971137c1f4f1
parent4e42dd969393d8588f32de9a07744485adbd04d1 (diff)
downloadaur-4971307770c668012b3ee0d6392e219fec5ec755.tar.gz
Remove the Qt theming patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
-rw-r--r--fix-qt-theme.patch31
3 files changed, 7 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd4bb3e8d4d7..a56292ca4de4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gitahead
pkgdesc = Understand your Git history!
pkgver = 2.6.3
- pkgrel = 2
+ pkgrel = 3
url = https://www.gitahead.com/
arch = x86_64
license = MIT
@@ -16,11 +16,9 @@ pkgbase = gitahead
source = git+https://github.com/gitahead/gitahead#tag=v2.6.3
source = gitahead.desktop
source = gitahead.patch
- source = fix-qt-theme.patch
sha256sums = SKIP
sha256sums = 254b4e970a942c6ac94df177e54a6169fe7e5f5c5d0d92b6f0c0f03b7b7b2fb0
sha256sums = 096e8f3700d7d74884e81eae3282fa1b4fad1cfa7a179ff03f1a7d89867538a0
- sha256sums = 569d9a08059907e002b6b0f1c0b5aa898a0a2bd616e93a6eb20dd617320b987a
pkgname = gitahead
diff --git a/PKGBUILD b/PKGBUILD
index d96bfd2f9990..2f52e24d30d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Angelo Theodorou <encelo@gmail.com>
pkgname=gitahead
-pkgrel=2
+pkgrel=3
pkgver=2.6.3
pkgdesc='Understand your Git history!'
url='https://www.gitahead.com/'
@@ -17,20 +17,17 @@ source=(
"git+https://github.com/gitahead/gitahead#tag=v${pkgver}"
"gitahead.desktop"
"gitahead.patch"
- "fix-qt-theme.patch"
)
-sha256sums=('SKIP'
- '254b4e970a942c6ac94df177e54a6169fe7e5f5c5d0d92b6f0c0f03b7b7b2fb0'
- '096e8f3700d7d74884e81eae3282fa1b4fad1cfa7a179ff03f1a7d89867538a0'
- '569d9a08059907e002b6b0f1c0b5aa898a0a2bd616e93a6eb20dd617320b987a')
+sha256sums=(
+ 'SKIP'
+ '254b4e970a942c6ac94df177e54a6169fe7e5f5c5d0d92b6f0c0f03b7b7b2fb0'
+ '096e8f3700d7d74884e81eae3282fa1b4fad1cfa7a179ff03f1a7d89867538a0'
+)
prepare() {
cd "$srcdir/gitahead"
patch --forward --strip=1 --input="../gitahead.patch"
- # From https://github.com/gitahead/gitahead/pull/445
- patch --forward --strip=1 --input="${srcdir}/fix-qt-theme.patch"
-
git submodule update --init --recursive
}
diff --git a/fix-qt-theme.patch b/fix-qt-theme.patch
deleted file mode 100644
index fe0510b3f85e..000000000000
--- a/fix-qt-theme.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 0817e3933cf8a4122cbba944ff5d32a8cdb78f9b Mon Sep 17 00:00:00 2001
-From: Mick Sayson <mick@sayson.com>
-Date: Fri, 12 Jun 2020 19:52:50 -0700
-Subject: [PATCH] Fix default palette application on Qt 5.15.0
-
----
- src/app/Application.cpp | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/src/app/Application.cpp b/src/app/Application.cpp
-index 7a54b89..143dc05 100644
---- a/src/app/Application.cpp
-+++ b/src/app/Application.cpp
-@@ -27,6 +27,7 @@
- #include <QNetworkReply>
- #include <QOperatingSystemVersion>
- #include <QSettings>
-+#include <QStyle>
- #include <QSysInfo>
- #include <QTimer>
- #include <QTranslator>
-@@ -187,6 +188,9 @@ Application::Application(int &argc, char **argv, bool haltOnParseError)
- // Enable system proxy auto-detection.
- QNetworkProxyFactory::setUseSystemConfiguration(true);
-
-+ // Set default pallete. Pre Qt 5.15.0 this should be the same as the default
-+ QApplication::setPalette(QApplication::style()->standardPalette());
-+
- // Do platform-specific initialization.
- #if defined(Q_OS_MAC)
- // Register service on Mac.