summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordeviantfero2020-02-10 02:16:37 -0600
committerdeviantfero2020-02-10 02:16:37 -0600
commit497e3a154644204d42a835ad63ba6b5eb3bfa8bd (patch)
tree971a73e480a6597ab26e823f8d96d264ab27eb93
parentdf746277d2bf5c3769e3406ce8d3394bff3b18c9 (diff)
downloadaur-497e3a154644204d42a835ad63ba6b5eb3bfa8bd.tar.gz
Update xsettingsd dependency
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
2 files changed, 16 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5284caffb922..cdccd897a896 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wpgtk-git
pkgdesc = A gui wallpaper chooser that changes your Openbox theme, GTK theme and Tint2 theme
- pkgver = r421.413248a
+ pkgver = r752.64b4523
pkgrel = 1
url = https://github.com/deviantfero/wpgtk
arch = any
@@ -13,10 +13,13 @@ pkgbase = wpgtk-git
depends = python-pywal
optdepends = feh: set wallpaper
optdepends = nitrogen: set wallpaper
- optdepends = xsettingsd-git: live reload GTK+ theme
- provides = wpgtk=r421.413248a
+ optdepends = xsettingsd: live reload GTK+ theme
+ provides = wpgtk=r752.64b4523
conflicts = wpgtk
+ noextract = wpgtk.png
source = git://github.com/deviantfero/wpgtk#branch=master
+ source = wpgtk.png::https://github.githubassets.com/images/icons/emoji/unicode/1f3b4.png
+ sha512sums = SKIP
sha512sums = SKIP
pkgname = wpgtk-git
diff --git a/PKGBUILD b/PKGBUILD
index 733d357f3d75..81764ea88595 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,18 +4,20 @@ _gitname=wpgtk
pkgname="${_gitname}-git"
_gitbranch=master
_gitauthor=deviantfero # deviantfero
-pkgver=r668.17f6666
+pkgver=r752.64b4523
pkgrel=1
pkgdesc="A gui wallpaper chooser that changes your Openbox theme, GTK theme and Tint2 theme"
url="https://github.com/${_gitauthor}/${_gitname}"
license=('GPLv2')
-source=("git://github.com/${_gitauthor}/${_gitname}#branch=${_gitbranch}")
-sha512sums=('SKIP')
+source=("git://github.com/${_gitauthor}/${_gitname}#branch=${_gitbranch}"
+ "wpgtk.png::https://github.githubassets.com/images/icons/emoji/unicode/1f3b4.png")
+noextract=('wpgtk.png')
+sha512sums=('SKIP' 'SKIP')
arch=('any')
depends=('python' 'python-pillow' 'python-gobject' 'gtk3' 'libxslt' 'python-pywal')
optdepends=('feh: set wallpaper'
'nitrogen: set wallpaper'
- 'xsettingsd-git: live reload GTK+ theme')
+ 'xsettingsd: live reload GTK+ theme')
conflicts=("${_gitname}")
provides=("${_gitname}=$pkgver")
@@ -32,6 +34,10 @@ package() {
install -Dm644 "$srcdir/$_gitname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -Dm644 "$srcdir/$_gitname/$_gitname/misc/wpg.conf" \
"usr/etc/$_gitname/wpg.conf"
+ install -Dm644 "$srcdir/$_gitname/$_gitname/misc/wpgtk.desktop" \
+ "$pkgdir/usr/share/applications/wpgtk.desktop"
+ install -Dm644 "$srcdir/wpgtk.png" \
+ "$pkgdir/usr/share/pixmaps/wpgtk.png"
install -Dm644 "$srcdir/$_gitname/completions/bash/wpg" \
"usr/share/bash-completion/wpg"
install -Dm644 "$srcdir/$_gitname/completions/zsh/_wpg" \