summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJordan Christiansen2016-08-23 16:14:06 -0500
committerJordan Christiansen2016-08-23 16:14:06 -0500
commit498e57c85b6fb719f63f0efa08e07362d42e5ba3 (patch)
treeb08293a6c39889d50d42cb6c1595e4f919d928f4
downloadaur-498e57c85b6fb719f63f0efa08e07362d42e5ba3.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD51
-rw-r--r--gearhead2.desktop8
-rw-r--r--gearhead2.pngbin0 -> 1666 bytes
-rw-r--r--gearhead2.sh3
5 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..41bbf8cb59ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = gearhead2
+ pkgdesc = A rougelike mecha role playing game, second game in the GearHead series
+ pkgver = 0.630
+ pkgrel = 1
+ url = http://www.gearheadrpg.com/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = fpc
+ depends = sdl
+ depends = sdl_image
+ depends = sdl_ttf
+ source = https://github.com/jwvhewitt/gearhead-2/archive/v0.630.tar.gz
+ source = gearhead2.sh
+ source = gearhead2.desktop
+ source = gearhead2.png
+ md5sums = 7c59dc2aea945ef77e97917bb85fb347
+ md5sums = cd699f36df6275bdb6b345cb5ac8f8f1
+ md5sums = a97a4a561783e23767e223476c0e7899
+ md5sums = 19f59e008bbe3fdcf39363818d3a5cf1
+
+pkgname = gearhead2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a9266eca4c72
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Jordan Christiansen <xordspar0@gmail.com>
+
+# To do:
+# * If upstream adds a way to specify the location of the data files, move the
+# package contents to /usr/bin/ and /usr/share/.
+
+pkgname=gearhead2
+_reponame=gearhead-2
+pkgver=0.630
+pkgrel=1
+pkgdesc="A rougelike mecha role playing game, second game in the GearHead series"
+arch=(i686 x86_64)
+url="http://www.gearheadrpg.com/"
+license=('LGPL')
+depends=(sdl sdl_image sdl_ttf)
+makedepends=(fpc)
+source=("https://github.com/jwvhewitt/${_reponame}/archive/v${pkgver}.tar.gz"
+ ${pkgname}.sh
+ ${pkgname}.desktop
+ ${pkgname}.png)
+md5sums=('7c59dc2aea945ef77e97917bb85fb347'
+ 'cd699f36df6275bdb6b345cb5ac8f8f1'
+ 'a97a4a561783e23767e223476c0e7899'
+ '19f59e008bbe3fdcf39363818d3a5cf1')
+
+build() {
+ cd "${_reponame}-${pkgver}"
+
+ fpc -dSDLMODE gharena
+}
+
+package() {
+ # Install the game itself.
+ cd "${_reponame}-${pkgver}"
+ install -d "${pkgdir}/opt/${pkgname}"
+ cp -ar -t "${pkgdir}/opt/${pkgname}" Image Design GameData Series doc
+ install -Dm755 gharena "${pkgdir}/opt/${pkgname}"
+
+ # Install the command line and desktop runners.
+ cd "${srcdir}"
+ install -Dm755 ${pkgname}.sh "${pkgdir}/usr/bin/${pkgname}"
+ # The .desktop file was adapted from Debian's gearhead package.
+ install -Dm644 ${pkgname}.desktop "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm644 ${pkgname}.png "${pkgdir}/usr/share/pixmaps/${pkgname}.xpm"
+
+ # Install the documentation
+ install -d "${pkgdir}/usr/share/doc/${pkgname}"
+ ln -s "/opt/${pkgname}/doc/man_chara.txt" "${pkgdir}/usr/share/doc/${pkgname}/man_chara.txt"
+ ln -s "/opt/${pkgname}/doc/man_mecha.txt" "${pkgdir}/usr/share/doc/${pkgname}/man_mecha.txt"
+ ln -s "/opt/${pkgname}/doc/man_umek.txt" "${pkgdir}/usr/share/doc/${pkgname}/man_umek.txt"
+}
diff --git a/gearhead2.desktop b/gearhead2.desktop
new file mode 100644
index 000000000000..371687255274
--- /dev/null
+++ b/gearhead2.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Version=1.1
+Type=Application
+Name=Gearhead
+GenericName=Roguelike Game
+Exec=gearhead
+Icon=/usr/share/pixmaps/gearhead.xpm
+Categories=Game;RolePlaying
diff --git a/gearhead2.png b/gearhead2.png
new file mode 100644
index 000000000000..ecbe1d8be575
--- /dev/null
+++ b/gearhead2.png
Binary files differ
diff --git a/gearhead2.sh b/gearhead2.sh
new file mode 100644
index 000000000000..fb536cdf6405
--- /dev/null
+++ b/gearhead2.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd /opt/gearhead
+./gharena