summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Runge2019-01-29 23:31:13 +0100
committerDavid Runge2019-01-29 23:31:13 +0100
commit4996f950836dc1a1110e0c7186e4384fcf4a5161 (patch)
tree046965e64ae95c74323bbf8b44644e1649463b98
parent850ab48bdba277fec9fa865134aebfb9b67170f4 (diff)
downloadaur-4996f950836dc1a1110e0c7186e4384fcf4a5161.tar.gz
PKGBUILD: Upgrading to 2.19.0. Adding tmpfiles.d integration to set the configuration file permission to 0640 (http:http).
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
-rw-r--r--tmpfiles.conf1
3 files changed, 17 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cccd2cdf4564..8c43943c6cf3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mantisbt
pkgdesc = Web-based issue tracking system
- pkgver = 2.18.0
+ pkgver = 2.19.0
pkgrel = 1
url = https://www.mantisbt.org/
install = mantisbt.install
@@ -20,8 +20,10 @@ pkgbase = mantisbt
backup = etc/webapps/mantisbt/custom_relationships_inc.php
backup = etc/webapps/mantisbt/custom_functions_inc.php
backup = etc/webapps/mantisbt/custom_constants_inc.php
- source = https://downloads.sourceforge.net/project/mantisbt/mantis-stable/2.18.0/mantisbt-2.18.0.tar.gz
- sha512sums = 759202ba99214244f905eed4d7b9b8c526af282690cf707c7c91471552537898f9389b4eda681bf42b0016097e390c8ebe6de0bcfe874110c0a40fdd10bfd3fe
+ source = https://downloads.sourceforge.net/project/mantisbt/mantis-stable/2.19.0/mantisbt-2.19.0.tar.gz
+ source = tmpfiles.conf
+ sha512sums = 5d074bc3605a9aae3c4b738e0ea667c3687e97a04e2702941158301ab9c86c14e8bc83fe8d5b9d34d5d011f5b5041d37b1bd44ea40815c2d1ae91f6130b5a987
+ sha512sums = e0c3fc92a3a61f86f780e5e30ccefe751ef0f16727a44006f8c7dae53951abaa0b8c6e0dc3e807668e0fe78252296996a6123cc5d5bf8427055ae07efe3bd37e
pkgname = mantisbt
diff --git a/PKGBUILD b/PKGBUILD
index f12b6dc969a2..4881f16d4762 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# Contributor: Angel 'angvp' Velasquez <angvp@archlinux.com.ve>
pkgname=mantisbt
-pkgver=2.18.0
+pkgver=2.19.0
pkgrel=1
pkgdesc='Web-based issue tracking system'
arch=('any')
@@ -27,8 +27,10 @@ backup=('etc/webapps/mantisbt/config_inc.php'
'etc/webapps/mantisbt/custom_functions_inc.php'
'etc/webapps/mantisbt/custom_constants_inc.php'
)
-source=("https://downloads.sourceforge.net/project/${pkgname}/mantis-stable/${pkgver}/${pkgname}-${pkgver}.tar.gz")
-sha512sums=('759202ba99214244f905eed4d7b9b8c526af282690cf707c7c91471552537898f9389b4eda681bf42b0016097e390c8ebe6de0bcfe874110c0a40fdd10bfd3fe')
+source=("https://downloads.sourceforge.net/project/${pkgname}/mantis-stable/${pkgver}/${pkgname}-${pkgver}.tar.gz"
+ 'tmpfiles.conf')
+sha512sums=('5d074bc3605a9aae3c4b738e0ea667c3687e97a04e2702941158301ab9c86c14e8bc83fe8d5b9d34d5d011f5b5041d37b1bd44ea40815c2d1ae91f6130b5a987'
+ 'e0c3fc92a3a61f86f780e5e30ccefe751ef0f16727a44006f8c7dae53951abaa0b8c6e0dc3e807668e0fe78252296996a6123cc5d5bf8427055ae07efe3bd37e')
install="${pkgname}.install"
prepare() {
@@ -44,15 +46,15 @@ package() {
# configuration
install -vDm 644 config/config_inc.php.sample \
"${pkgdir}/etc/webapps/${pkgname}/config_inc.php"
+ # create customization files
+ touch "${pkgdir}/etc/webapps/${pkgname}"/custom_{strings,relationships,functions,constants}_inc.php
# readme
install -vDm 644 readme.md -t "${pkgdir}/usr/share/doc/${pkgname}/"
+
cp -av --no-preserve='ownership' ../${pkgname}-${pkgver}/* \
"${pkgdir}/usr/share/webapps/${pkgname}"
- # create customization files
- touch "${pkgdir}/etc/webapps/${pkgname}"/custom_{strings,relationships,functions,constants}_inc.php
-
# symlink configuration and configuration
ln -sv "/etc/webapps/${pkgname}/config_inc.php" \
"${pkgdir}/usr/share/webapps/${pkgname}/config/config_inc.php"
@@ -64,6 +66,9 @@ package() {
"${pkgdir}/usr/share/webapps/${pkgname}/config/custom_functions_inc.php"
ln -sv "/etc/webapps/${pkgname}/custom_constants_inc.php" \
"${pkgdir}/usr/share/webapps/${pkgname}/config/custom_constants_inc.php"
+
+ # tmpfiles.d integration
+ install -vDm 644 ../tmpfiles.conf "${pkgdir}/usr/lib/tmpfiles.d/${pkgname}.conf"
}
# vim: ts=2 sw=2 et:
diff --git a/tmpfiles.conf b/tmpfiles.conf
new file mode 100644
index 000000000000..9c31f94df4f1
--- /dev/null
+++ b/tmpfiles.conf
@@ -0,0 +1 @@
+z /etc/webapps/mantisbt/config_inc.php 640 http http