summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabian Bornschein2023-12-26 19:30:06 +0100
committerFabian Bornschein2023-12-26 19:30:06 +0100
commit49a477bf14d004fc3143363ac2a3b3f34c411d8b (patch)
tree815c21372b359ca42e7b6bfbbdb3f79a361f8a6d
parentfd1571b65a0336a680bcda1a42951ca5573b5c88 (diff)
downloadaur-49a477bf14d004fc3143363ac2a3b3f34c411d8b.tar.gz
upgpkg: 5.0.5-0.1
* Upgrade to 5.0.5 * Small cleanup and optimization
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD4
-rw-r--r--asusctl.install12
-rw-r--r--gnome-shell-extension-asusctl-gnome.install2
4 files changed, 15 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff58b36cdbb5..2b25df7b6394 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = asusctl
pkgdesc = A control daemon, tools, and a collection of crates for interacting with ASUS ROG laptops
- pkgver = 5.0.4
+ pkgver = 5.0.5
pkgrel = 0.1
url = https://asus-linux.org
arch = x86_64
@@ -18,7 +18,7 @@ pkgbase = asusctl
makedepends = npm
makedepends = unzip
makedepends = yarn
- source = git+https://gitlab.com/asus-linux/asusctl.git#commit=f421b8ee3b5409811e05b40429f7c47a78ba0a77
+ source = git+https://gitlab.com/asus-linux/asusctl.git#commit=b525411fd3ea9d1882e3370d9704643af620c634
sha256sums = SKIP
pkgname = asusctl
@@ -36,7 +36,7 @@ pkgname = asusctl
pkgname = rog-control-center
pkgdesc = App to control asusctl
- depends = asusctl=5.0.4
+ depends = asusctl=5.0.5
depends = fontconfig
depends = glib2
depends = gtk3
@@ -47,6 +47,6 @@ pkgname = gnome-shell-extension-asusctl-gnome
pkgdesc = A gnome extension exposing some of the base features of asusd in a helpful and easy to use way
install = gnome-shell-extension-asusctl-gnome.install
arch = any
- depends = asusctl=5.0.4
+ depends = asusctl=5.0.5
depends = dconf
depends = gnome-shell
diff --git a/PKGBUILD b/PKGBUILD
index a2e82ecbce72..4df06af79f02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname=(
rog-control-center
gnome-shell-extension-asusctl-gnome
)
-pkgver=5.0.4
+pkgver=5.0.5
pkgrel=0.1
pkgdesc="A control daemon, tools, and a collection of crates for interacting with ASUS ROG laptops"
arch=('x86_64')
@@ -30,7 +30,7 @@ makedepends=(
"unzip"
"yarn"
)
-_commit=f421b8ee3b5409811e05b40429f7c47a78ba0a77 # tags/5.0.4^0
+_commit=b525411fd3ea9d1882e3370d9704643af620c634 # tags/5.0.5^0
source=("git+https://gitlab.com/asus-linux/asusctl.git#commit=$_commit")
sha256sums=('SKIP')
diff --git a/asusctl.install b/asusctl.install
index c1406eaefc2e..dfaacf8b573f 100644
--- a/asusctl.install
+++ b/asusctl.install
@@ -1,9 +1,15 @@
+post_install() {
+ printf ":: asusd provides a service that is activated by an udev rule on\n"
+ printf ":: startup. Please reboot the system or run\n"
+ printf ":: # systemctl start asusd.service\n"
+ printf ":: to make it work.\n"
+}
+
post_upgrade() {
- if [ $(systemctl is-active asusd.service) == "active" ]
+ if systemctl is-active asusd.service --quiet
then
- printf ":: asusd is running, and requires a restart of the service…\n"
+ printf ":: asusd service will be restarted…\n"
systemctl daemon-reload
systemctl restart asusd.service
fi
}
-
diff --git a/gnome-shell-extension-asusctl-gnome.install b/gnome-shell-extension-asusctl-gnome.install
index 92efa8a39214..03c7a191cecd 100644
--- a/gnome-shell-extension-asusctl-gnome.install
+++ b/gnome-shell-extension-asusctl-gnome.install
@@ -5,5 +5,3 @@ post_install() {
post_upgrade() {
post_install
}
-
-