summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaichi Shinozaki2015-06-09 18:11:38 +0900
committerDaichi Shinozaki2015-06-09 18:11:38 +0900
commit49bae6a5a1c14fd57b18d39eb69c062f47fb1d89 (patch)
treec0f528328a29fcb743be05ecc557e9992403fcae
downloadaur-49bae6a5a1c14fd57b18d39eb69c062f47fb1d89.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD34
-rw-r--r--datomic.install16
-rw-r--r--datomic.service11
-rw-r--r--transactor.properties71
5 files changed, 154 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..143d42c0a443
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = datomic
+ pkgdesc = A database of flexible,time-based facts,supporting queries and joins,with elastic scalability,and ACID transactions
+ pkgver = 0.9.5173
+ pkgrel = 1
+ url = https://my.datomic.com/downloads/free
+ install = datomic.install
+ arch = any
+ license = custom:DatomicFreeEditionLicense
+ makedepends = unzip
+ depends = java-environment
+ depends = maven
+ optdepends = leiningen
+ options = !strip
+ source = datomic-0.9.5173.zip::https://my.datomic.com/downloads/free/0.9.5173
+ source = transactor.properties
+ source = datomic.service
+ md5sums = 1b7add77a995f8beeaf1eeb1d161697f
+ md5sums = 19e8f0692138f52961a584d8f428a306
+ md5sums = 1a90dced8cf46b36a2a87c666aa3b47b
+
+pkgname = datomic
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a44a120a5a5d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Daichi Shinozaki <dsdseg at gmail dot com>
+# Special thanks to: James Henderson
+pkgname=datomic
+pkgver=0.9.5173
+pkgrel=1
+pkgdesc="A database of flexible,time-based facts,supporting queries and joins,with elastic scalability,and ACID transactions"
+arch=('any')
+url=https://my.datomic.com/downloads/free
+license=('custom:DatomicFreeEditionLicense')
+depends=('java-environment' 'maven')
+makedepends=('unzip')
+optdepends=('leiningen')
+options=(!strip)
+install="$pkgname.install"
+source=("$pkgname-$pkgver.zip::https://my.datomic.com/downloads/free/$pkgver"
+ 'transactor.properties'
+ $pkgname.service
+)
+md5sums=('1b7add77a995f8beeaf1eeb1d161697f'
+ '19e8f0692138f52961a584d8f428a306'
+ '1a90dced8cf46b36a2a87c666aa3b47b')
+
+package() {
+ _pkgname="$pkgname-free-$pkgver"
+ mkdir -p $pkgdir/usr/lib/ $pkgdir/usr/lib/systemd/system
+ mkdir -p $pkgdir/var/lib/datomic/{data,log}
+ install -Dm644 $srcdir/$_pkgname/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ cp -r "$srcdir/$_pkgname" "$pkgdir"/usr/lib/datomic
+ cp $srcdir/transactor.properties $pkgdir/usr/lib/datomic/config/
+ cp $srcdir/$pkgname.service $pkgdir/usr/lib/systemd/system/
+ install -Td $srcdir/datomic $pkgdir/etc/logrotate.d/datomic
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/datomic.install b/datomic.install
new file mode 100644
index 000000000000..8d1387d6b7a2
--- /dev/null
+++ b/datomic.install
@@ -0,0 +1,16 @@
+pre_install() {
+ useradd -r -d /var/lib/datomic datomic
+}
+
+post_install() {
+ chown -R datomic /var/lib/datomic
+}
+
+pre_remove() {
+ systemctl stop datomic-free
+ systemctl disable datomic-free
+}
+
+post_remove() {
+ userdel datomic
+}
diff --git a/datomic.service b/datomic.service
new file mode 100644
index 000000000000..d5f9974b3883
--- /dev/null
+++ b/datomic.service
@@ -0,0 +1,11 @@
+[Unit]
+Description = Datomic (Free Edition)
+
+[Service]
+User = datomic
+Type = simple
+ExecStart = /usr/lib/datomic/bin/transactor -Xmx4G -Xms1G /usr/lib/datomic/config/transactor.properties
+Restart = always
+
+[Install]
+WantedBy = multi-user.target \ No newline at end of file
diff --git a/transactor.properties b/transactor.properties
new file mode 100644
index 000000000000..361b0634ce41
--- /dev/null
+++ b/transactor.properties
@@ -0,0 +1,71 @@
+################################################################
+# Basic connection settings.
+
+protocol=free
+host=localhost
+port=4334
+
+
+
+## OPTIONAL ####################################################
+# The dev: and free: protocols typically use three ports
+# starting with the selected :port, but you can specify the
+# other ports explicitly, e.g. for virtualization environs
+# that do not issue contiguous ports.
+
+# h2-port=4335
+# h2-web-port=4336
+
+
+
+################################################################
+# See http://docs.datomic.com/capacity.html
+
+
+# Recommended settings for -Xmx4g, ongoing usage.
+memory-index-threshold=32m
+memory-index-max=128m
+object-cache-max=1g
+
+# Recommended settings for -Xmx4g import jobs.
+# memory-index-threshold=512m
+# memory-index-max=1g
+# object-cache-max=1g
+
+# Recommended settings for -Xmx1g usage, e.g. dev laptops.
+# memory-index-threshold=32m
+# memory-index-max=128m
+# object-cache-max=128m
+
+
+
+## OPTIONAL ####################################################
+
+
+# Set to false to disable SSL between the peers and the transactor.
+# Default: true
+# encrypt-channel=true
+
+# Data directory is used for dev: and free: storage, and
+# as a temporary directory for all storages.
+data-dir=/var/lib/datomic/data
+
+# Transactor will log here, see bin/logback.xml to configure logging.
+log-dir=/var/lib/datomic/log
+
+# Transactor will write process pid here on startup
+# pid-file=transactor.pid
+
+
+
+## OPTIONAL ####################################################
+# See http://docs.datomic.com/capacity.html
+
+
+# Soft limit on the number of concurrent writes to storage.
+# Default: 4, Miniumum: 2
+# write-concurrency=4
+
+# Soft limit on the number of concurrent reads to storage.
+# Default: 2 times write-concurrency, Miniumum: 2
+# read-concurrency=8