summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2021-02-04 23:22:34 +0100
committerFabioLolix2021-02-04 23:22:34 +0100
commit49bb6f99c367901234dde6129ad84d9a895e0ed9 (patch)
tree1c0b7f691af839606f6513a642507e38445a3cb4
parent8b55c607fdcaf8ae3a8da65bf367f2680f5aad29 (diff)
downloadaur-49bb6f99c367901234dde6129ad84d9a895e0ed9.tar.gz
revision
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD54
2 files changed, 47 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf72feea3e73..92487c3bda69 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,24 @@
pkgbase = vnote-git
pkgdesc = A Vim-inspired note-taking application, especially for Markdown.
- pkgver = v1.11.1.16.g4202b99
+ pkgver = 2.10.r0.gde753706
pkgrel = 1
url = https://tamlok.github.io/vnote/
- arch = any
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
license = MIT
makedepends = git
depends = qt5-base
depends = qt5-webengine
depends = qt5-svg
- source = git://github.com/tamlok/vnote.git
+ source = git+https://github.com/tamlok/vnote.git#branch=vnote2.0
+ source = git+https://github.com/chjj/marked.git
+ source = git+https://github.com/tamlok/hoedown.git
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = vnote-git
diff --git a/PKGBUILD b/PKGBUILD
index 66e0e897469f..0efa9a135269 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,46 @@
-# Maintainer: erk <v at erk dot io>
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: erk <v at erk dot io>
+
pkgname=vnote-git
-pkgver=v1.11.1.31.g06cac36
+pkgver=2.10.r0.gde753706
pkgrel=1
pkgdesc="A Vim-inspired note-taking application, especially for Markdown."
-arch=('any')
+arch=(x86_64 i686 arm armv6h armv7h aarch64)
url='https://tamlok.github.io/vnote/'
-license=('MIT')
-depends=('qt5-base' 'qt5-webengine' 'qt5-svg')
-makedepends=('git')
+license=(MIT)
+depends=(qt5-base qt5-webengine qt5-svg)
+makedepends=(git)
+source=("git+https://github.com/tamlok/vnote.git#branch=vnote2.0"
+ "git+https://github.com/chjj/marked.git"
+ "git+https://github.com/tamlok/hoedown.git")
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
-source=("git://github.com/tamlok/vnote.git")
-sha256sums=(SKIP)
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
-gitname="vnote"
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
-pkgver() {
- cd "$srcdir/$gitname"
- git describe --tags | sed 's|-|.|g'
+ git submodule init
+ git config 'submodule.src/utils/marked.url' "${srcdir}/marked"
+ git config 'submodule.hoedown.url' "${srcdir}/hoedown"
+ git submodule update
+
+ install -d build
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}/build"
+ qmake-qt5 ../VNote.pro
+ make
}
package() {
- cd "$srcdir/$gitname"
- git submodule update --init
- mkdir build
- cd build
- qmake-qt5 ../VNote.pro
- make
- make INSTALL_ROOT="$pkgdir" install
+ cd "$srcdir/${pkgname%-git}/build"
+ make INSTALL_ROOT="$pkgdir" install
+ install -Dm644 "$srcdir/${pkgname%-git}/LICENSE" "$pkgdir/usr/share/licenses/${pkgname%-git}/LICENSE"
}