summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2022-12-11 22:19:58 +0100
committerFabioLolix2022-12-11 22:19:58 +0100
commit4a1c1cd63192617c15348f84ea243c2d56004d6a (patch)
tree291034067908b22ee480ab31386cc03afe686acc
parent2fcc7e66464945420a9ac4b56d07f27e868c4949 (diff)
downloadaur-4a1c1cd63192617c15348f84ea243c2d56004d6a.tar.gz
revision, use gtk3
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD64
2 files changed, 33 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 453189e66333..fe587232e567 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
pkgbase = amule-git
pkgdesc = Client for the eD2k and Kad networks
- pkgver = 2.3.2.r64.20afd75fa
- pkgrel = 1
+ pkgver = 2.3.3.r42.e26d06a6e
+ pkgrel = 2
url = http://amule.org/
arch = x86_64
license = GPL2
makedepends = git
- makedepends = ccache
makedepends = boost
- depends = boost-libs
+ makedepends = cmake
depends = crypto++
depends = geoip
depends = libupnp
- depends = wxgtk2
+ depends = wxwidgets-gtk3
depends = gd
- depends = boost-libs
+ provides = amule
conflicts = amule
source = git+https://github.com/amule-project/amule.git
source = amuled.systemd
@@ -28,4 +27,3 @@ pkgbase = amule-git
sha256sums = e9d1b7019c7075b0f8616c6507a767b87de8f899936680e9ff5829d8cbba224d
pkgname = amule-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 6c5d5a6c1c36..f834fa6c73d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
-# Maintainer: LIN Ruoshui <lin dot ruohshoei plus archlinux at gmail dot com>
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: LIN Ruoshui <lin dot ruohshoei plus archlinux at gmail dot com>
# Contributor: lukpod
pkgname=amule-git
-pkgver=2.3.2.r64.20afd75fa
-pkgrel=1
+pkgver=2.3.3.r42.e26d06a6e
+pkgrel=2
pkgdesc="Client for the eD2k and Kad networks"
-arch=('x86_64')
-url=http://amule.org/
+arch=(x86_64)
+url="http://amule.org/"
license=(GPL2)
-depends=(boost-libs crypto++ geoip libupnp wxgtk2 gd boost-libs)
-makedepends=(git ccache boost)
+depends=(crypto++ geoip libupnp wxwidgets-gtk3 gd)
+makedepends=(git boost cmake)
+provides=(amule)
conflicts=(amule)
-source=(
-git+https://github.com/amule-project/amule.git
-#git+https://repo.or.cz/amule.git
-amuled.systemd amuleweb.systemd amule.sysusers amule.tmpfiles
-)
+source=("git+https://github.com/amule-project/amule.git"
+ #git+https://repo.or.cz/amule.git
+ amuled.systemd amuleweb.systemd amule.sysusers amule.tmpfiles)
sha256sums=('SKIP'
'20ac6b60c5f3bf49c0b080dfc02409da3c9d01b154344188008c6a75ca69681e'
'f4f43b1154ddccc9036a4291a58c6715f097b171fec62ea7aead0c9d9fa654f2'
@@ -23,40 +23,32 @@ sha256sums=('SKIP'
'e9d1b7019c7075b0f8616c6507a767b87de8f899936680e9ff5829d8cbba224d')
pkgver() {
- cd amule/
+ cd amule
git describe --tags | sed 's/-/.r/; s/-g/./'
}
build() {
- cd amule/
- ./autogen.sh
- ./configure --prefix=/usr \
- --mandir=/usr/share/man \
- --enable-cas \
- --enable-wxcas \
- --enable-amule-daemon \
- --enable-amulecmd \
- --enable-amule-gui \
- --enable-alc \
- --enable-alcc \
- --enable-webserver \
- --disable-debug \
- --enable-optimize \
- --enable-ccache \
- --enable-geoip \
- --enable-upnp \
- --enable-fileview \
- --with-boost
- make
+ cmake -B build -S amule \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_ALC=ON \
+ -DBUILD_ALCC=ON \
+ -DBUILD_AMULECMD=ON \
+ -DBUILD_CAS=ON \
+ -DBUILD_DAEMON=ON \
+ -DBUILD_REMOTEGUI=ON \
+ -DBUILD_WEBSERVER=ON \
+ -DBUILD_WXCAS=ON \
+ -DBUILD_FILEVIEW=ON \
+ -DENABLE_NLS=ON
+ cmake --build build
}
check() {
- make -C amule/ check
+ make -C build test
}
package() {
- cd amule
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
install -Dm644 "$srcdir"/amuled.systemd "$pkgdir"/usr/lib/systemd/system/amuled.service
install -Dm644 "$srcdir"/amuleweb.systemd "$pkgdir"/usr/lib/systemd/system/amuleweb.service
install -Dm644 "$srcdir"/amule.sysusers "$pkgdir"/usr/lib/sysusers.d/amule.conf