summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Martin2017-12-19 14:32:18 +0100
committerTobias Martin2017-12-19 14:32:18 +0100
commit4a231211e50a612f72817f80199fd33502cbaa01 (patch)
treecbb0f3e9403cc6faec0be4b2b1531412f71caed3
downloadaur-4a231211e50a612f72817f80199fd33502cbaa01.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore13
-rw-r--r--PKGBUILD33
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..186682561108
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = fritzctl
+ pkgdesc = A lightweight, easy to use console client for the AVM FRITZ!Box Home Automation.
+ pkgver = 1.4.18
+ pkgrel = 1
+ url = https://github.com/bpicode/fritzctl
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ options = !strip
+ source = https://github.com/bpicode/fritzctl/archive/v1.4.18.tar.gz
+ sha256sums = 97d1239eaac38de3f226704374f8384a7c3335a3ad4a1a21b44a8ee213f4847e
+
+pkgname = fritzctl
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b73905529f23
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,13 @@
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c54bb4eb8c00
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Tobias Martin <tm-x at gmx dot net>
+
+pkgname=fritzctl
+pkgver=1.4.18
+pkgrel=1
+pkgdesc="A lightweight, easy to use console client for the AVM FRITZ!Box Home Automation."
+arch=('x86_64')
+url="https://github.com/bpicode/fritzctl"
+license=('MIT')
+makedepends=('go')
+options=('!strip')
+source=("https://github.com/bpicode/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('97d1239eaac38de3f226704374f8384a7c3335a3ad4a1a21b44a8ee213f4847e')
+
+prepare() {
+ mkdir -p "${srcdir}/src/github.com/bpicode/"
+ mv "${srcdir}/${pkgname}-${pkgver}" "${srcdir}/src/github.com/bpicode/${pkgname}"
+}
+
+build() {
+ cd "${srcdir}/src/github.com/bpicode/${pkgname}"
+ GOPATH="${srcdir}" go build
+}
+
+package() {
+ cd "${srcdir}/src/github.com/bpicode/${pkgname}"
+
+ mkdir -p "$pkgdir/etc/$pkgname"
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: