summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcyril@biminsight.ch2019-05-11 00:29:15 +0200
committercyril@biminsight.ch2019-05-11 00:29:15 +0200
commit4a28535b8707e8bbb62ea757820c8c11f3356bcd (patch)
tree4d58349351c41b0d55f9e270546e331c6e135801
parent23457245b714bc84dde8e43e69ef0f64eff58ad8 (diff)
downloadaur-4a28535b8707e8bbb62ea757820c8c11f3356bcd.tar.gz
Update 2019.05.11
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD38
-rw-r--r--osg340.patch32
-rw-r--r--qt5.patch61
4 files changed, 24 insertions, 127 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b99ef0d8125..33de45ec3ec6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,18 @@
-# Generated by mksrcinfo v8
-# Tue May 3 21:35:12 UTC 2016
pkgbase = ifcplusplus-git
- pkgdesc = Port of IfcPlusPlus on linux. IfcPlusPlus is an open source C++ class model, as well as a reader and writer for IFC files in STEP format.
- pkgver = 0.r161.g73d0b99
+ pkgdesc = IFC++ is an open source C++ class model, as well as a reader and writer for IFC files in STEP format.
+ pkgver = 0.r248.g011fd531
pkgrel = 1
- url = https://github.com/berndhahnebach/IfcPlusPlus
+ url = http://www.ifcquery.com/
arch = x86_64
- arch = i686
- license = custom:OSGPL
+ license = MIT
+ makedepends = cmake
makedepends = boost
- makedepends = chrpath
depends = openscenegraph
depends = boost-libs
depends = qt5-base
- source = IfcPlusPlus::git://github.com/berndhahnebach/IfcPlusPlus.git
- source = qt5.patch
- source = osg340.patch
+ provides = IFC++
+ source = git://github.com/berndhahnebach/ifcplusplus.git
md5sums = SKIP
- md5sums = 3df56628d79a15799aede92466db77a3
- md5sums = 70c0472dac19f4be7c8984cfcdbe54f2
pkgname = ifcplusplus-git
diff --git a/PKGBUILD b/PKGBUILD
index 901c4e4e3333..4fa4b011c6f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,22 @@
-# Maintainer: mickele <mimocciola[at]yahoo[dot]com>
pkgname=ifcplusplus-git
-pkgver=0.r161.g73d0b99
+pkgver=0.r248.g011fd531
pkgrel=1
-pkgdesc="Port of IfcPlusPlus on linux. IfcPlusPlus is an open source C++ class model, as well as a reader and writer for IFC files in STEP format."
-url="https://github.com/berndhahnebach/IfcPlusPlus"
-arch=('x86_64' 'i686')
-license=('custom:OSGPL')
+pkgdesc="IFC++ is an open source C++ class model, as well as a reader and writer for IFC files in STEP format."
+url="http://www.ifcquery.com/"
+arch=('x86_64')
+license=('MIT')
depends=('openscenegraph' 'boost-libs' 'qt5-base')
optdepends=()
-makedepends=('boost' 'chrpath')
+makedepends=('cmake' 'boost')
+provides=('IFC++')
conflicts=()
replaces=()
backup=()
-source=('IfcPlusPlus::git://github.com/berndhahnebach/IfcPlusPlus.git' 'qt5.patch' 'osg340.patch')
+source=('git://github.com/berndhahnebach/ifcplusplus.git')
+clonefolder='ifcplusplus'
pkgver() {
- cd IfcPlusPlus
+ cd ${clonefolder}
if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
@@ -25,28 +26,23 @@ pkgver() {
}
prepare() {
- cd "${srcdir}/IfcPlusPlus"
- patch -Np1 -i "${srcdir}/qt5.patch"
- patch -Np1 -i "${srcdir}/osg340.patch"
+ cd "${srcdir}/${clonefolder}"
}
build() {
- cd "${srcdir}/IfcPlusPlus"
+ cd "${srcdir}/${clonefolder}"
cmake ./ \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt5
+ -OSGDB_LIBRARY_DEBUG=/usr/lib \
make
}
package() {
- cd "${srcdir}/IfcPlusPlus"
- install -Dm755 Debug/SimpleViewerExample "${pkgdir}"/usr/bin/SimpleIFCViewer
+ cd "${srcdir}/${clonefolder}"
+ install -Dm755 Release/SimpleViewerExample "${pkgdir}"/usr/bin/SimpleIFCViewer
chrpath -d "${pkgdir}"/usr/bin/SimpleIFCViewer
install -d "${pkgdir}/usr/lib"
- install -m755 -D Debug/*.so "${pkgdir}/usr/lib"
+ install -m755 -D Release/*.so "${pkgdir}/usr/lib"
install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-md5sums=('SKIP'
- '3df56628d79a15799aede92466db77a3'
- '70c0472dac19f4be7c8984cfcdbe54f2')
+md5sums=('SKIP')
diff --git a/osg340.patch b/osg340.patch
deleted file mode 100644
index b28f4dff4296..000000000000
--- a/osg340.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-diff -Naur IfcPlusPlus.orig/IfcPlusPlus/src/ifcpp/geometry/ConverterOSG.h IfcPlusPlus/IfcPlusPlus/src/ifcpp/geometry/ConverterOSG.h
---- IfcPlusPlus.orig/IfcPlusPlus/src/ifcpp/geometry/ConverterOSG.h 2016-05-03 22:48:45.167336967 +0200
-+++ IfcPlusPlus/IfcPlusPlus/src/ifcpp/geometry/ConverterOSG.h 2016-05-03 22:59:10.007285252 +0200
-@@ -481,10 +481,9 @@
- const osg::Geode* child_geode = dynamic_cast<const osg::Geode*>( node );
- if( child_geode )
- {
-- const osg::Geode::DrawableList& drawable_list = child_geode->getDrawableList();
-- for( auto it_drawables = drawable_list.begin(); it_drawables != drawable_list.end(); ++it_drawables )
-+ for( int i=0; i < child_geode->getNumDrawables(); ++i )
- {
-- osg::Drawable* drawable = ( *it_drawables );
-+ const osg::Drawable* drawable = child_geode->getDrawable(i);
- const osg::Geometry* child_gemetry = dynamic_cast<const osg::Geometry*>( drawable );
- if( !child_gemetry )
- {
-diff -Naur IfcPlusPlus.orig/IfcPlusPlus/src/ifcpp/geometry/GeomUtils.h IfcPlusPlus/IfcPlusPlus/src/ifcpp/geometry/GeomUtils.h
---- IfcPlusPlus.orig/IfcPlusPlus/src/ifcpp/geometry/GeomUtils.h 2016-05-03 22:48:45.167336967 +0200
-+++ IfcPlusPlus/IfcPlusPlus/src/ifcpp/geometry/GeomUtils.h 2016-05-03 22:59:51.353727925 +0200
-@@ -1223,10 +1223,9 @@
- continue;
- }
- set_applied.insert( child_geode );
-- const osg::Geode::DrawableList& drawable_list = child_geode->getDrawableList();
-- for( osg::Geode::DrawableList::const_iterator it_drawables = drawable_list.begin(); it_drawables != drawable_list.end(); ++it_drawables )
-+ for( int i=0; i < child_geode->getNumDrawables(); ++i )
- {
-- osg::Drawable* drawable = ( *it_drawables );
-+ osg::Drawable* drawable = child_geode->getDrawable(i);
- osg::Geometry* child_geometry = dynamic_cast<osg::Geometry*>( drawable );
- if( !child_geometry )
- {
diff --git a/qt5.patch b/qt5.patch
deleted file mode 100644
index ad33095e0f84..000000000000
--- a/qt5.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-diff -Naur IfcPlusPlus.orig/SimpleViewerExample/CMakeLists.txt IfcPlusPlus/SimpleViewerExample/CMakeLists.txt
---- IfcPlusPlus.orig/SimpleViewerExample/CMakeLists.txt 2015-10-28 19:30:23.433684274 +0100
-+++ IfcPlusPlus/SimpleViewerExample/CMakeLists.txt 2015-10-28 19:35:52.540352016 +0100
-@@ -11,25 +11,6 @@
- SET(CMAKE_LIBRARY_OUTPUT_DIRECTORY_RELEASE ${CMAKE_BINARY_DIR}/${CMAKE_BUILD_TYPE})
- SET(CMAKE_RUNTIME_OUTPUT_DIRECTORY_RELEASE ${CMAKE_BINARY_DIR}/${CMAKE_BUILD_TYPE})
-
--
--# Qt library --> to be able to use precompiled osg binary of Linux distributions qt4 is used on Linux Plattform
--IF(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
-- MESSAGE(STATUS "Linux OS --> Qt4 is used")
-- FIND_PACKAGE(Qt4 REQUIRED)
-- SET(QT_USE_QTOPENGL TRUE)
-- INCLUDE(${QT_USE_FILE})
-- ADD_DEFINITIONS(${QT_DEFINITIONS})
-- ADD_DEFINITIONS(-DQT_GUI_LIBS -DQT_CORE_LIB)
-- QT4_ADD_RESOURCES(SimpleViewerExample_RESOURCES_RCC ${IFCPP_SOURCE_DIR}/SimpleViewerExample/Resources/ifcplusplus.qrc)
-- INCLUDE_DIRECTORIES(${INCLUDE_DIRECTORIES}
-- ${QT_INCLUDES}
-- ${QT_INCLUDE_DIR}
-- ${QT_QT_INCLUDE_DIR}
-- ${QT_QTCORE_INCLUDE_DIR}
-- ${QT_QTGUI_INCLUDE_DIR}
-- ${QT_QTOPENGL_INCLUDE_DIR}
-- )
--ELSE(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
- MESSAGE(STATUS "Qt5 is used")
- FIND_PACKAGE(Qt5Core REQUIRED)
- FIND_PACKAGE(Qt5Widgets REQUIRED)
-@@ -44,7 +25,6 @@
- ${QT_QTOPENGL_INCLUDE_DIR}
- ${Qt5Widgets_INCLUDE_DIRS}
- )
--ENDIF()
-
- FIND_PACKAGE(OpenSceneGraph REQUIRED osgDB osgUtil osgGA osgFX osgSim osgText osgQt osgViewer)
-
-@@ -98,11 +78,7 @@
- ADD_DEFINITIONS( -DCARVE_SYSTEM_BOOST )
- ENDIF()
-
--IF(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
-- QT4_WRAP_CPP( IFCPPVIEWER_MOC_GENERATED_FILES ${IFCPPVIEWER_MOC_FILES})
--ELSE(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
- QT5_WRAP_CPP( IFCPPVIEWER_MOC_GENERATED_FILES ${IFCPPVIEWER_MOC_FILES})
--ENDIF()
-
- LINK_DIRECTORIES (${LINK_DIRECTORIES} ${CMAKE_BINARY_DIR}/${CMAKE_BUILD_TYPE})
- LINK_DIRECTORIES (${LINK_DIRECTORIES} ${CARVE_BINARY_DIR}/lib)
-@@ -116,11 +92,7 @@
- ${SimpleViewerExample_RESOURCES_RCC}
- )
-
--IF(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
-- # do nothing
--ELSE(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
- QT5_USE_MODULES(SimpleViewerExample Core Gui Widgets OpenGL)
--ENDIF()
-
- TARGET_LINK_LIBRARIES(SimpleViewerExample ${OPENTHREADS_LIBRARY} )
- TARGET_LINK_LIBRARIES(SimpleViewerExample ${OSG_LIBRARY} )