summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormaz-12015-10-07 22:20:35 +0800
committermaz-12015-10-07 22:20:35 +0800
commit4a2b9c86ee20df3aed547f0c967b347e295384a7 (patch)
tree370bbbd55808c2ce670b73e28032eb72eae1f77f
downloadaur-4a2b9c86ee20df3aed547f0c967b347e295384a7.tar.gz
initial
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD42
-rw-r--r--build.patch13
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..41997e2c5742
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = deadbeef-plugin-customizabletb-git
+ pkgver = 95.5df8f49
+ pkgrel = 1
+ url = https://github.com/kravich/ddb_customizabletb
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = mercurial
+ depends = deadbeef>=0.6
+ source = git+https://github.com/kravich/ddb_customizabletb
+ source = build.patch
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = deadbeef-plugin-customizabletb-gtk2-git
+ pkgdesc = Customizable toolbar plugin for DeadBeeF music player. The GTK2 version.
+
+pkgname = deadbeef-plugin-customizabletb-gtk3-git
+ pkgdesc = Customizable toolbar plugin for DeadBeeF music player. The GTK3 version.
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..71eb2cc1816f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Ignat Loskutov <ignat.loskutov@gmail.com>
+pkgbase='deadbeef-plugin-customizabletb-git'
+_gitname='ddb_customizabletb'
+pkgname=('deadbeef-plugin-customizabletb-gtk2-git' 'deadbeef-plugin-customizabletb-gtk3-git')
+pkgver=95.5df8f49
+pkgrel=1
+_pkgdesc="Customizable toolbar plugin for DeadBeeF music player."
+arch=('i686' 'x86_64')
+url="https://github.com/kravich/ddb_customizabletb"
+license=(GPL2)
+depends=('deadbeef>=0.6')
+makedepends=(mercurial)
+source=('git+https://github.com/kravich/ddb_customizabletb'
+ 'build.patch')
+md5sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ echo "$(git rev-list --count HEAD).$(git describe --always)"
+}
+
+prepare() {
+ cd $srcdir/$_gitname
+ patch -p1 < ../build.patch
+}
+
+build() {
+ cd $srcdir/$_gitname
+ make gtk2
+ make gtk3
+}
+
+package_deadbeef-plugin-customizabletb-gtk2-git() {
+ pkgdesc=$_pkgdesc' The GTK2 version.'
+ install -D -m644 $srcdir/$_gitname/ddb_customizabletb_gtk2.so $pkgdir/usr/lib/deadbeef/ddb_customizabletb_gtk2.so
+}
+
+package_deadbeef-plugin-customizabletb-gtk3-git() {
+ pkgdesc=$_pkgdesc' The GTK3 version.'
+ install -D -m644 $srcdir/$_gitname/ddb_customizabletb_gtk3.so $pkgdir/usr/lib/deadbeef/ddb_customizabletb_gtk3.so
+}
diff --git a/build.patch b/build.patch
new file mode 100644
index 000000000000..0080c8300e37
--- /dev/null
+++ b/build.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index 2d2dc91..0e944a0 100644
+--- a/Makefile
++++ b/Makefile
+@@ -19,7 +19,7 @@
+ #
+
+
+-CC = gcc
++CC ?= gcc
+
+ CFLAGS += -std=c99 -fPIC -Wall -Werror -Wfatal-errors -Wno-deprecated-declarations
+ CFLAGS += -Wno-error=deprecated-declarations -Wno-error=unused-variable -Wno-error=unused-but-set-variable -Wno-error=unused-function