summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2023-03-27 21:14:38 -0400
committerGuillaume Horel2023-03-27 21:14:38 -0400
commit4a42f5ec921a6ac153138ee78e876fe84a832abf (patch)
treed75a806e45a0fb4a0abf6d9cdd4a2909725cfecd
parent80dab21ab94bfa472450557b6555631392b5e9fb (diff)
downloadaur-4a42f5ec921a6ac153138ee78e876fe84a832abf.tar.gz
bump to 0.3.22
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 14 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c3fbd0b0e24c..aa8d9d72e27e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = openblas-lapack
pkgdesc = Optimized BLAS library based on GotoBLAS2 1.13 BSD (providing blas, lapack, and cblas)
- pkgver = 0.3.21
+ pkgver = 0.3.22
pkgrel = 1
url = http://www.openblas.net/
arch = x86_64
@@ -9,17 +9,17 @@ pkgbase = openblas-lapack
makedepends = gcc-fortran
depends = gcc-libs
provides = openblas
- provides = blas=3.8.0
- provides = lapack=3.9.0
- provides = cblas=3.8.0
- provides = lapacke=3.9.0
+ provides = blas=3.11.0
+ provides = lapack=3.11.0
+ provides = cblas=3.11.0
+ provides = lapacke=3.11.0
conflicts = openblas
conflicts = blas
conflicts = lapack
conflicts = cblas
conflicts = lapacke
options = !emptydirs
- source = OpenBLAS-0.3.21.tar.gz::https://github.com/xianyi/OpenBLAS/releases/download/v0.3.21/OpenBLAS-0.3.21.tar.gz
- sha256sums = f36ba3d7a60e7c8bcc54cd9aaa9b1223dd42eaf02c811791c37e8ca707c241ca
+ source = OpenBLAS-0.3.22.tar.gz::https://github.com/xianyi/OpenBLAS/releases/download/v0.3.22/OpenBLAS-0.3.22.tar.gz
+ sha256sums = 7fa9685926ba4f27cfe513adbf9af64d6b6b63f9dcabb37baefad6a65ff347a7
pkgname = openblas-lapack
diff --git a/PKGBUILD b/PKGBUILD
index e56a6543dafc..df0cb93b7ce7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,10 +6,10 @@
pkgname=openblas-lapack
_PkgName=OpenBLAS
_pkgname=openblas
-pkgver=0.3.21
+pkgver=0.3.22
# grep VERSION "${srcdir}/${_PkgName}-${pkgver}"/lapack-netlib/README.md | tail -n 1 | cut -d ' ' -f 2
-_lapackver=3.9.0
-_blasver=3.8.0
+_lapackver=3.11.0
+_blasver=3.11.0
pkgrel=1
pkgdesc="Optimized BLAS library based on GotoBLAS2 1.13 BSD (providing blas, lapack, and cblas)"
arch=('x86_64')
@@ -21,29 +21,21 @@ provides=('openblas' "blas=${_blasver}" "lapack=${_lapackver}" "cblas=${_blasver
conflicts=('openblas' 'blas' 'lapack' 'cblas' 'lapacke')
options=(!emptydirs)
source=(${_PkgName}-${pkgver}.tar.gz::https://github.com/xianyi/OpenBLAS/releases/download/v${pkgver}/OpenBLAS-$pkgver.tar.gz)
-sha256sums=('f36ba3d7a60e7c8bcc54cd9aaa9b1223dd42eaf02c811791c37e8ca707c241ca')
+sha256sums=('7fa9685926ba4f27cfe513adbf9af64d6b6b63f9dcabb37baefad6a65ff347a7')
# Add the following line to the _config variable if you want to set the number of make jobs
# MAKE_NB_JOBS=2 \
_config="FC=gfortran USE_OPENMP=1 USE_THREAD=1 \
USE_TLS=1 \
- NO_LAPACK=0 BUILD_LAPACK_DEPRECATED=1 \
MAJOR_VERSION=${_lapackver:0:1} NO_STATIC=1"
build(){
- cd "${srcdir}/${_PkgName}-${pkgver}"
-
- make ${_config} CFLAGS="${CFLAGS}" libs netlib shared
-}
-
-check(){
- cd "${srcdir}/${_PkgName}-${pkgver}"
-
- make ${_config} tests
+ cd "${_PkgName}-${pkgver}"
+ make ${_config} libs netlib shared
}
package(){
- cd "${srcdir}/${_PkgName}-${pkgver}"
+ cd "${_PkgName}-${pkgver}"
make ${_config} PREFIX=/usr DESTDIR="${pkgdir}" install