summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Abernethy2015-06-12 18:26:25 +0200
committerPhilip Abernethy2015-06-12 18:26:25 +0200
commit4a6025b74fce0b8c4c9544d30e68eb03c4fcdd79 (patch)
tree8c6faaf704d4db3794f489ccd5640fcf21708f1b
downloadaur-4a6025b74fce0b8c4c9544d30e68eb03c4fcdd79.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
-rw-r--r--arprec.changelog75
3 files changed, 120 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..15d1e15275f7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = arprec
+ pkgdesc = An arbitrary precision math library for C++ and Fortran-90.
+ pkgver = 2.2.17
+ pkgrel = 1
+ url = http://crd.lbl.gov/~dhbailey/mpdist/
+ changelog = arprec.changelog
+ arch = x86_64
+ arch = i686
+ license = custom:BSD-LBNL
+ source = http://crd.lbl.gov/~dhbailey/mpdist/arprec-2.2.17.tar.gz
+ source = http://crd.lbl.gov/~dhbailey/mpdist/BSD-LBNL-License.doc
+ sha512sums = d10f7d3e3d61274a36d253d2b50004bbf15447be3ffbd37bb0334ba62bd624e27fb9e26364fa1b89c1d4dfbb4136ab93d865f990ce123ecf94d9614e3ac567d1
+ sha512sums = 5db2d242c249ccd6ed4e7fc59a6ebba7c83274b1cf330d0d12e97da32ea0da9b9b0b0c1f51c58f809658ea92f7afbf5d3a1c75d899f94ec38a0d91926608cf85
+
+pkgname = arprec
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb6326563b11
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Philip Abernethy<chais.z3r0@gmail.com>
+pkgname=arprec
+pkgver=2.2.17
+pkgrel=1
+pkgdesc="An arbitrary precision math library for C++ and Fortran-90."
+url="http://crd.lbl.gov/~dhbailey/mpdist/"
+arch=('x86_64' 'i686')
+license=('custom:BSD-LBNL')
+changelog="${pkgname}.changelog"
+
+source=("http://crd.lbl.gov/~dhbailey/mpdist/${pkgname}-${pkgver}.tar.gz"
+ "http://crd.lbl.gov/~dhbailey/mpdist/BSD-LBNL-License.doc")
+sha512sums=('d10f7d3e3d61274a36d253d2b50004bbf15447be3ffbd37bb0334ba62bd624e27fb9e26364fa1b89c1d4dfbb4136ab93d865f990ce123ecf94d9614e3ac567d1'
+ '5db2d242c249ccd6ed4e7fc59a6ebba7c83274b1cf330d0d12e97da32ea0da9b9b0b0c1f51c58f809658ea92f7afbf5d3a1c75d899f94ec38a0d91926608cf85')
+
+# Uncomment for big packages
+#PKGEXT=".pkg.tar"
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr && make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}/" install
+ install -Dm644 "${srcdir}/"${pkgname}-${pkgver}/COPYING "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+ install -m644 "${srcdir}"/BSD-LBNL-License.doc "${pkgdir}"/usr/share/licenses/${pkgname}/
+}
diff --git a/arprec.changelog b/arprec.changelog
new file mode 100644
index 000000000000..6b2ed1a2ce9a
--- /dev/null
+++ b/arprec.changelog
@@ -0,0 +1,75 @@
+Changes for 2.2.17
+ - Added an input parameter mpstrlen to mp_inp.f.
+
+Changes for 2.2.15
+ - Fixed intermittent memory problem in dotd.cpp.
+
+Changes for 2.2.6
+ - Fixed F-format bug in Fortran file mp_mod.f.
+ - Fixed mpread bug in Fortran file mp_modx.f
+
+Changes for 2.2.2
+ - Clean up mp_mod.f, added mpeq_xz (assignment to complex)
+ and cmplx (creation of mp_complex).
+ - Fix dble to be more accurate, and avoid spurious underflow.
+ - Make C++ I/O of mp_real closer to standard C++ I/O.
+ - Added to_string function.
+
+Changes for 2.2.1
+ - Some bug fixes for Cygwin environment.
+
+Changes for 2.2.0
+This is a major update to ARPREC, there are several API incompatibilities.
+ - Moved C++ main entry in libqdmod.a to libarprec_f_main.a.
+ This allows to link Fortran code using ARPREC with custom C++
+ main function. Pure Fortran code will need to be linked with
+ arprec_f_main library in addition to arprecmod and arprec library.
+ - Constructor taking integers now just initializes the data.
+ For example "x = mp_real(35)" now initializes x to 35, instead
+ of creating an mp_real with 35 words. To get the old behaviour,
+ do something like mp_real(0.0, 35).
+ - String output routines write and to_string routines now takes a single
+ fmtflags.
+ - Members are now all public, making it a plain-old-data type.
+ - Removed mpr_location, set/getData accessors.
+ - mp_real(double *) constructors are now explicit.
+ - Renamed several static variables in class mp to more descriptive names.
+ - Various constants are now in mp_real class (mp_real::_pi, _log2,
+ _log10, and _eps).
+
+Changes for 2.1.104
+ - Fixed bug in division and increments for mp_int.
+ - Output correct number of digits in c_mpwrite / c_mpout.
+ - Fixed compilation errors and warnings.
+
+Changes for 2.1.103
+ - Minor changes to accomodate Windows build.
+
+Changes for 2.1.102
+ - Ignore CC compiler on Apple systems.
+ - Fix C++ pslq demos to print out integers when appropriate.
+ - Fix dependency of Fortran modules to allow parallel make.
+ - Fix bug in mp_real::mpnorm that was accessing past end of an array.
+
+Changes for 2.1.101
+ - Added third display option in math toolkit.
+ - Bug fix in math toolkit.
+
+Changes for 2.1.100
+ - Added fortran/Makefile.sample, a sample Makefile for using ARPREC
+ library with Fortran programs.
+ - Fixed bug in arprec-config where --fcflags had an extra @.
+
+Changes for 2.1.99
+ - Added read_binary and write_binary for binary I/O.
+ - Fixed bug where decimal point and minus sign was not printed correctly
+ in certain cases.
+ - General improvements in I/O routines, including adjustable exponent
+ width and column width.
+ - Added mp_real constructor accepting std::string.
+ - Perform some I/O tests during "make check".
+
+Changes for 2.2.3
+ - Removed dynamic precision from quadgs routine of Fortran and C++
+ versions of the Gaussian quadrature demonstration program.
+ - Fixed some bugs in the erf and erfc routines.