summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Souza2024-01-21 15:59:23 -0300
committerDaniel Souza2024-01-21 15:59:23 -0300
commit4a8392312b93b74fc2997cb66dad1910a49711fc (patch)
tree38cbc7f0357e8e81ce2ff1ce457674beb652047d
parent869e4e5db572ad870cdccc2478f77e0d84a30760 (diff)
downloadaur-4a8392312b93b74fc2997cb66dad1910a49711fc.tar.gz
feat: use prepare()
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4bd48e80e7a5..604676840cdb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = arbie-git
pkgdesc = Encrypted backup and synchronization tool
pkgver = v1.3.0.r3.g369fe50
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/danisztls/arbie
install = arbie.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index f56a3785d53d..3a472cb0a765 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _gitbranch="main"
pkgname="${_pkgname}-git"
pkgver=v1.3.0.r3.g369fe50
-pkgrel=3
+pkgrel=4
pkgdesc="Encrypted backup and synchronization tool"
arch=('any')
url="https://github.com/${_gitauthor}/${_pkgname}"
@@ -36,11 +36,14 @@ pkgver() {
)
}
+prepare() {
+ cd "${_pkgname}"
+}
+
# build() {
# }
package() {
- cd "${_pkgname}"
make DESTDIR="${pkgdir}/" install
install -vDm 644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
install -vDm 644 README.md -t "${pkgdir}/usr/share/doc/${_pkgname}"