summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMorten Linderud2021-12-03 23:45:34 +0100
committerMorten Linderud2021-12-03 23:45:34 +0100
commit4a8799f11e6e1e20cbf31966eacef3e4bae3677b (patch)
tree5ae79217bf1c7f926cb453686757c1f0b4719af3
parent375a623de77960cc4a50389d6bef23f22563ffde (diff)
downloadaur-4a8799f11e6e1e20cbf31966eacef3e4bae3677b.tar.gz
import from community
-rw-r--r--.SRCINFO47
-rw-r--r--PKGBUILD77
-rw-r--r--fix-test.patch12
3 files changed, 98 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 45ea176b2b9f..d420d2700956 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,51 @@
-# Generated by mksrcinfo v8
-# Mon May 14 20:56:58 UTC 2018
pkgbase = python-language-server
pkgdesc = An implementation of the Language Server Protocol for Python
- pkgver = 0.18.0
- pkgrel = 2
+ pkgver = 0.36.2
+ pkgrel = 5
url = https://github.com/palantir/python-language-server
arch = any
license = MIT
- makedepends = python-setuptools
+ checkdepends = python-pytest
+ checkdepends = python-pytest-runner
+ checkdepends = python-pytest-cov
+ checkdepends = python-pyflakes
+ checkdepends = flake8
+ checkdepends = python-mock
+ checkdepends = python-jedi
+ checkdepends = python-future
+ checkdepends = yapf
+ checkdepends = python-mccabe
+ checkdepends = python-pycodestyle
+ checkdepends = autopep8
+ checkdepends = python-rope
+ checkdepends = python-pydocstyle
+ checkdepends = python-pylint
+ checkdepends = python-jsonrpc-server
+ checkdepends = python-numpy
+ checkdepends = python-pandas
+ checkdepends = python-matplotlib
+ checkdepends = python-flaky
depends = python
- depends = python-json-rpc
+ depends = python-setuptools
+ depends = python-jsonrpc-server
depends = python-future
depends = python-jedi
depends = python-pluggy
+ depends = python-ujson
optdepends = python-mccabe: for complexity checking
optdepends = python-rope: for completions and renaming
optdepends = python-pyflakes: for linter to detect various errors
+ optdepends = flake8: for code linting
optdepends = python-pycodestyle: for style checking
+ optdepends = python-pylint: for code linting
optdepends = autopep8: for code formatting
optdepends = yapf: for code formatting (preferred over autopep8)
- optdepends = pydocstyle: for docstring style checking
- conflicts = python-language-server
- conflicts = python-language-server-git
- source = https://github.com/palantir/python-language-server/archive/0.18.0.tar.gz
- md5sums = 7081b960ec3418956a98aed75f08f26a
- sha256sums = c7b6febf9e853f2a68903f8f7835b789072b09ebc48d71d24d75f951ddec11f9
+ optdepends = python-pydocstyle: for docstring style checking
+ source = https://files.pythonhosted.org/packages/source/p/python-language-server/python-language-server-0.36.2.tar.gz
+ source = fix-test.patch
+ source = jedi-018-support.patch::https://github.com/palantir/python-language-server/commit/40afab312a6bf0dcd620c82e59555ea2967aacdf.patch
+ sha256sums = 9984c84a67ee2c5102c8e703215f407fcfa5e62b0ae86c9572d0ada8c4b417b0
+ sha256sums = 75bee7f9e288bf72e116c8a8f10d32758a800409a91266c7cd15888c6c254bdf
+ sha256sums = 84dc8c69f7bee9d60679141b25c81a849ff0b45e91f435e1aa8ae6dd6db6bb84
pkgname = python-language-server
-
diff --git a/PKGBUILD b/PKGBUILD
index b5937db45d9b..2d966d4021ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,62 @@
-# Maintainer: fenuks
+# Maintainer: Morten Linderud <foxboron@archlinux.org>
+# Maintainer: Maxim Baz <$pkgname at maximbaz dot com>
+# Maintainer: Bruno Pagani <archange@archlinux.org>
+# Contributor: fenuks
pkgname=python-language-server
-pkgver=0.18.0
-pkgrel=2
+pkgver=0.36.2
+pkgrel=5
pkgdesc="An implementation of the Language Server Protocol for Python"
-arch=("any")
-url="https://github.com/palantir/${pkgname}"
-license=("MIT")
-depends=("python" "python-json-rpc" "python-future" "python-jedi" "python-pluggy")
-optdepends=(
- "python-mccabe: for complexity checking"
- "python-rope: for completions and renaming"
- "python-pyflakes: for linter to detect various errors"
- "python-pycodestyle: for style checking"
- "autopep8: for code formatting"
- "yapf: for code formatting (preferred over autopep8)"
- "pydocstyle: for docstring style checking"
-)
-makedepends=("python-setuptools")
-conflicts=("${pkgname}" "${pkgname}-git")
-# install=$pkgname.install
-source=("https://github.com/palantir/${pkgname}/archive/${pkgver}.tar.gz")
-md5sums=('7081b960ec3418956a98aed75f08f26a')
-sha256sums=('c7b6febf9e853f2a68903f8f7835b789072b09ebc48d71d24d75f951ddec11f9')
+arch=(any)
+url="https://github.com/palantir/python-language-server"
+license=(MIT)
+depends=(python python-setuptools python-jsonrpc-server python-future python-jedi python-pluggy python-ujson)
+optdepends=('python-mccabe: for complexity checking'
+ 'python-rope: for completions and renaming'
+ 'python-pyflakes: for linter to detect various errors'
+ 'flake8: for code linting'
+ 'python-pycodestyle: for style checking'
+ 'python-pylint: for code linting'
+ 'autopep8: for code formatting'
+ 'yapf: for code formatting (preferred over autopep8)'
+ 'python-pydocstyle: for docstring style checking')
+checkdepends=(python-pytest python-pytest-runner python-pytest-cov python-pyflakes flake8
+ python-mock python-jedi python-future yapf python-mccabe python-pycodestyle
+ autopep8 python-rope python-pydocstyle python-pylint python-jsonrpc-server
+ python-numpy python-pandas python-matplotlib python-flaky)
+source=(https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz
+ fix-test.patch
+ jedi-018-support.patch::${url}/commit/40afab312a6bf0dcd620c82e59555ea2967aacdf.patch)
+sha256sums=('9984c84a67ee2c5102c8e703215f407fcfa5e62b0ae86c9572d0ada8c4b417b0'
+ '75bee7f9e288bf72e116c8a8f10d32758a800409a91266c7cd15888c6c254bdf'
+ '84dc8c69f7bee9d60679141b25c81a849ff0b45e91f435e1aa8ae6dd6db6bb84')
+
+
+prepare() {
+ cd ${pkgname}-${pkgver}
+ patch -Np1 < ../fix-test.patch
+ patch -Np1 < ../jedi-018-support.patch
+ sed -i 's/jedi<0.18.0,/jedi/' python_language_server.egg-info/requires.txt
+ sed -i 's/pycodestyle<2.7.0,/pycodestyle/g' python_language_server.egg-info/requires.txt setup.py
+ sed -i 's/pyflakes<2.3.0,/pyflakes/g' python_language_server.egg-info/requires.txt setup.py
+ sed -i 's/pycodestyle>=2.6.0,<2.7.0/pycodestyle>=2.6.0/g' python_language_server.egg-info/requires.txt setup.py
+ sed -i 's/pyflakes>=2.2.0,<2.3.0/pyflakes>=2.2.0/g' python_language_server.egg-info/requires.txt setup.py
+}
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd ${pkgname}-${pkgver}
python setup.py build
}
+check() {
+ cd ${pkgname}-${pkgver}
+ py.test -k 'not test_pyqt_completion and not test_snippet_parsing and not test_numpy_hover'
+}
+
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}/" --optimize=1
+ cd ${pkgname}-${pkgver}
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE -t "${pkgdir}"/usr/share/licenses/${pkgname}/
}
+
+# vim:set ts=4 sw=4 et:
diff --git a/fix-test.patch b/fix-test.patch
new file mode 100644
index 000000000000..7c86c289b6a4
--- /dev/null
+++ b/fix-test.patch
@@ -0,0 +1,12 @@
+diff --git a/test/plugins/test_folding.py b/test/plugins/test_folding.py
+index 05f0cdd..06e644f 100644
+--- a/test/plugins/test_folding.py
++++ b/test/plugins/test_folding.py
+@@ -118,6 +118,7 @@ def test_folding(workspace):
+ {'startLine': 2, 'endLine': 3},
+ {'startLine': 5, 'endLine': 6},
+ {'startLine': 8, 'endLine': 11},
++ {'startLine': 9, 'endLine': 10},
+ {'startLine': 12, 'endLine': 20},
+ {'startLine': 13, 'endLine': 14},
+ {'startLine': 15, 'endLine': 16},