summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072020-09-12 02:28:56 +0200
committersL1pKn072020-09-12 02:28:56 +0200
commit4a886b5261135f58f5a83df3e0555e4557171ae8 (patch)
tree6c5acd46fc94bff18a94049bd1e33f7b72eddebe
downloadaur-4a886b5261135f58f5a83df3e0555e4557171ae8.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD41
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d7bb846e1cad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vapoursynth-plugin-cas-git
+ pkgdesc = Plugin for Vapoursynth: cas (GIT version)
+ pkgver = r2.0.gd0df8c2
+ pkgrel = 1
+ url = https://forum.doom9.org/showthread.php?t=172172
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = meson
+ depends = vapoursynth
+ provides = vapoursynth-plugin-cas
+ conflicts = vapoursynth-plugin-cas
+ source = cas::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-CAS.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-cas-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..33dad1000415
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=cas
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r2.0.gd0df8c2
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('x86_64')
+url='https://forum.doom9.org/showthread.php?t=172172'
+license=('MIT')
+depends=('vapoursynth')
+makedepends=('git'
+ 'meson'
+ )
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-CAS.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ arch-meson "../${_plug}" \
+ --libdir /usr/lib/vapoursynth
+
+ ninja
+}
+
+package(){
+ DESTDIR="${pkgdir}" ninja -C build install
+
+ install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+}