summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 20:33:55 +0200
committersl1pkn072015-06-08 20:33:55 +0200
commit4a8b27754b00befcfb43ec2bc33bcb87543882e9 (patch)
tree1d16768ba63ae84c201894a82ea55e92595d4da2
downloadaur-4a8b27754b00befcfb43ec2bc33bcb87543882e9.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..146e13c4cbc7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = vapoursynth-plugin-dfttest-git
+ pkgdesc = Plugin for Vapoursynth: dfttest (GIT version)
+ pkgver = r2.0.g1fe8a2c
+ pkgrel = 1
+ url = http://forum.doom9.org/showthread.php?t=171678
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = vapoursynth
+ depends = fftw
+ provides = vapoursynth-plugin-dfttest
+ conflicts = vapoursynth-plugin-dfttest
+ source = dfttest::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-DFTTest.git
+ sha1sums = SKIP
+
+pkgname = vapoursynth-plugin-dfttest-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4828806ea713
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=dfttest
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r2.0.g1fe8a2c
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('i686' 'x86_64')
+url="http://forum.doom9.org/showthread.php?t=171678"
+license=('GPL')
+depends=('vapoursynth' 'fftw')
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-DFTTest.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+build() {
+ cd "${_plug}"
+ ./configure --install="${pkgdir}/usr/lib/vapoursynth"
+ make
+}
+
+package(){
+ cd "${_plug}"
+ make install
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+}