summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrank Seifferth2022-05-22 18:32:41 +0200
committerFrank Seifferth2022-05-22 18:32:41 +0200
commit4a9636dc6ee99085748da2be0292f1d2a8f690cf (patch)
tree056d088c88bb9e4a9e0ce20d37ed385d925cf7c1
parent053e91adf2f9ce404bb89a825a93629ab19210cf (diff)
downloadaur-4a9636dc6ee99085748da2be0292f1d2a8f690cf.tar.gz
Use 'npm pack' for creating the package files
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f606ab89328..7411e1fa4747 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,12 @@
pkgbase = abricotine
pkgdesc = A markdown editor with inline preview
pkgver = 1.1.2
- pkgrel = 1
+ pkgrel = 2
url = http://abricotine.brrd.fr
arch = x86_64
license = GPL3
makedepends = npm
makedepends = nodejs
- makedepends = libxcrypt-compat
- makedepends = rpm-tools
- makedepends = dpkg
depends = libxss
source = abricotine-1.1.2.tar.gz::https://github.com/brrd/abricotine/archive/1.1.2.tar.gz
source = abricotine.desktop
diff --git a/PKGBUILD b/PKGBUILD
index 1a04523db827..0a0725764cc9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
pkgname=abricotine
pkgver=1.1.2
-pkgrel=1
+pkgrel=2
pkgdesc="A markdown editor with inline preview"
arch=('x86_64')
url="http://abricotine.brrd.fr"
license=('GPL3')
depends=('libxss')
-makedepends=('npm' 'nodejs' 'libxcrypt-compat' 'rpm-tools' 'dpkg')
+makedepends=('npm' 'nodejs')
source=("abricotine-${pkgver}.tar.gz::https://github.com/brrd/abricotine/archive/${pkgver}.tar.gz"
"abricotine.desktop")
sha256sums=('d821d767535d859ff0334f2d17b87f3398a073d86387cc8ff39766f5d49fc358'
@@ -19,7 +19,7 @@ build() {
cd "${srcdir}/abricotine-${pkgver}"
npm install --cache ../cache --devdir="${srcdir}/devdir"
- npm run dist --cache ../cache --devdir="${srcdir}/devdir"
+ npm run pack --cache ../cache --devdir="${srcdir}/devdir"
}
package() {