summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 18:26:13 +0800
committerSukanka2022-06-06 18:26:13 +0800
commit4aa34741f20cffee39d7fc58e86ae4bee127f7eb (patch)
treeca850e141252e97e9ea979cda77d242415168f76
downloadaur-4aa34741f20cffee39d7fc58e86ae4bee127f7eb.tar.gz
add r-phosr
-rw-r--r--.SRCINFO49
-rw-r--r--PKGBUILD65
2 files changed, 114 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b1a59792fc15
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,49 @@
+pkgbase = r-phosr
+ pkgdesc = A set of methods and tools for comprehensive analysis of phosphoproteomics data
+ pkgver = 1.6.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/PhosR
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-biocgenerics
+ depends = r-circlize
+ depends = r-dendextend
+ depends = r-dplyr
+ depends = r-e1071
+ depends = r-ggally
+ depends = r-ggdendro
+ depends = r-ggplot2
+ depends = r-ggpubr
+ depends = r-ggtext
+ depends = r-igraph
+ depends = r-limma
+ depends = r-network
+ depends = r-pcamethods
+ depends = r-pheatmap
+ depends = r-preprocesscore
+ depends = r-rcolorbrewer
+ depends = r-reshape2
+ depends = r-rlang
+ depends = r-ruv
+ depends = r-s4vectors
+ depends = r-summarizedexperiment
+ depends = r-tidyr
+ optdepends = r-annotate
+ optdepends = r-biocstyle
+ optdepends = r-calibrate
+ optdepends = r-cluer
+ optdepends = r-directpa
+ optdepends = r-knitr
+ optdepends = r-org.mm.eg.db
+ optdepends = r-org.rn.eg.db
+ optdepends = r-reactome.db
+ optdepends = r-rgl
+ optdepends = r-rmarkdown
+ optdepends = r-sna
+ optdepends = r-stringr
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/PhosR_1.6.0.tar.gz
+ sha256sums = e24af46b24fd6144d042e94b1e09696f91e3d538bbb32a43540b968a0ac9f865
+
+pkgname = r-phosr
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..335fb86e245b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=PhosR
+_pkgver=1.6.0
+pkgname=r-${_pkgname,,}
+pkgver=1.6.0
+pkgrel=1
+pkgdesc='A set of methods and tools for comprehensive analysis of phosphoproteomics data'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-biocgenerics
+ r-circlize
+ r-dendextend
+ r-dplyr
+ r-e1071
+ r-ggally
+ r-ggdendro
+ r-ggplot2
+ r-ggpubr
+ r-ggtext
+ r-igraph
+ r-limma
+ r-network
+ r-pcamethods
+ r-pheatmap
+ r-preprocesscore
+ r-rcolorbrewer
+ r-reshape2
+ r-rlang
+ r-ruv
+ r-s4vectors
+ r-summarizedexperiment
+ r-tidyr
+)
+optdepends=(
+ r-annotate
+ r-biocstyle
+ r-calibrate
+ r-cluer
+ r-directpa
+ r-knitr
+ r-org.mm.eg.db
+ r-org.rn.eg.db
+ r-reactome.db
+ r-rgl
+ r-rmarkdown
+ r-sna
+ r-stringr
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('e24af46b24fd6144d042e94b1e09696f91e3d538bbb32a43540b968a0ac9f865')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: