aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortwomyn2012-04-12 00:32:03 -0700
committeryar2015-07-03 16:58:14 -0700
commit4aacf9fe853dbe808caffbc2b63460f126e93306 (patch)
tree653164c0697a05986ac87ab890b395867acfe7ea
parent4e763ae44f81e649cd432bc56ace277b5b12e345 (diff)
downloadaur-4aacf9fe853dbe808caffbc2b63460f126e93306.tar.gz
Bump 3.3.1
removing ancient messy nconfig-wrapper - just follow UPDATING
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
-rw-r--r--config.x86_642
-rw-r--r--linux-linode.install2
-rwxr-xr-xnconfig-wrapper48
5 files changed, 11 insertions, 56 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dbef4110b73d..c4a30a0c652d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux
pkgdesc = The Linux Kernel and modules
- pkgver = 3.3
+ pkgver = 3.3.1
pkgrel = 3
url = http://www.kernel.org/
install = linux-linode.install
@@ -21,12 +21,14 @@ pkgbase = linux
options = !strip
backup = etc/mkinitcpio.d/linux-linode.preset
source = http://www.kernel.org/pub/linux/kernel/v3.x/linux-3.3.tar.xz
+ source = http://www.kernel.org/pub/linux/kernel/v3.x/patch-3.3.1.xz
source = config.x86_64
source = menu.lst
source = linux-linode.preset
source = change-default-console-loglevel.patch
md5sums = 7133f5a2086a7d7ef97abac610c094f5
- md5sums = 17cb4a818ff04d88fc7ec759afc963f5
+ md5sums = 10771d657c5bf342bcfe66ed06653ecb
+ md5sums = 52ae958ccc83ecd6a3f20d5c6fd9e077
md5sums = 4c45d442db6239f0b3d0008c0a17c76c
md5sums = ee66f3cd0c5bc0ba0f65499784d19f30
md5sums = 9d3c56a4b999c8bfbd4018089a62f662
diff --git a/PKGBUILD b/PKGBUILD
index e710ffa2528a..9ccb1f554665 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@ pkgbase=linux
pkgname=linux-linode
_kernelname=${pkgname#linux}
_basekernel=3.3
-pkgver=${_basekernel}
+pkgver=${_basekernel}.1
pkgrel=3
arch=(x86_64)
url="http://www.kernel.org/"
@@ -10,13 +10,14 @@ license=(GPL2)
makedepends=(xmlto docbook-xsl)
options=('!strip')
source=("http://www.kernel.org/pub/linux/kernel/v3.x/linux-3.3.tar.xz"
- #"http://www.kernel.org/pub/linux/kernel/v3.x/patch-${pkgver}.xz"
+ "http://www.kernel.org/pub/linux/kernel/v3.x/patch-${pkgver}.xz"
'config.x86_64'
'menu.lst'
"${pkgname}.preset"
'change-default-console-loglevel.patch')
md5sums=('7133f5a2086a7d7ef97abac610c094f5'
- '17cb4a818ff04d88fc7ec759afc963f5'
+ '10771d657c5bf342bcfe66ed06653ecb'
+ '52ae958ccc83ecd6a3f20d5c6fd9e077'
'4c45d442db6239f0b3d0008c0a17c76c'
'ee66f3cd0c5bc0ba0f65499784d19f30'
'9d3c56a4b999c8bfbd4018089a62f662')
@@ -30,7 +31,7 @@ install=${pkgname}.install
build() {
cd "${srcdir}/linux-${_basekernel}"
- #patch -p1 -i "${srcdir}/patch-${pkgver}"
+ patch -p1 -i "${srcdir}/patch-${pkgver}"
patch -Np1 -i "${srcdir}/change-default-console-loglevel.patch"
cp "${srcdir}/config.x86_64" ./.config
sed -i "s|CONFIG_LOCALVERSION=.*|CONFIG_LOCALVERSION=\"${_kernelname}\"|g" ./.config
diff --git a/config.x86_64 b/config.x86_64
index 4e78d2dfde11..fb3fde46f283 100644
--- a/config.x86_64
+++ b/config.x86_64
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86_64 3.3.0-1 Kernel Configuration
+# Linux/x86_64 3.3.1-3 Kernel Configuration
#
CONFIG_64BIT=y
# CONFIG_X86_32 is not set
diff --git a/linux-linode.install b/linux-linode.install
index a98d2946eaaa..2b615149defc 100644
--- a/linux-linode.install
+++ b/linux-linode.install
@@ -2,7 +2,7 @@
# arg 2: the old package version
KERNEL_NAME=-linode
-KERNEL_VERSION=3.3.0-3-linode
+KERNEL_VERSION=3.3.1-3-linode
post_install () {
echo ">>> Updating module dependencies. Please wait ..."
diff --git a/nconfig-wrapper b/nconfig-wrapper
deleted file mode 100755
index 42af14ea87dd..000000000000
--- a/nconfig-wrapper
+++ /dev/null
@@ -1,48 +0,0 @@
-#!/bin/bash
-[ -a ./nconfig-wrapper ] || {
- echo "You have to run this from the same directory!"
- exit 1
-}
-croak() { echo "ERROR: $@"; exit; }
-[ -f /etc/bash.functions ] && . /etc/bash.functions
-[ -f /usr/share/ppz/bash.functions ] && . /usr/share/ppz/bash.functions
-[ "$1" ] && REPO="$1" || croak USAGE: ./package-this [repo-directory]
-[ -d ${REPO} ] || croak ${REPO} not mounted!
-
-eval $(awk '/^(pkgver|_basekernel)=/ {print}' PKGBUILD)
-ldir=src/linux-$pkgver
-
-makepkg -oecd
-mold=($(md5sum config.x86_64))
-sed -i 's/^[#]*\s*\(return\s*1\)$/\1/ig' PKGBUILD
-makepkg -cd
-askyn "continue?" || exit
-cd $ldir
-make nconfig
-cd ../..
-diff config.x86_64 $ldir/.config
-
-askyn "update package?" && {
- cat $ldir/.config > config.x86_64
- mnew=($(md5sum config.x86_64))
- sed -i s_${mold[0]}_${mnew[0]}_ig PKGBUILD
- pkgrel=0
- eval $(sed 's/^pkgrel=/\0/i;t;d;' PKGBUILD)
- let pkgrel++
- sed -i 's/^pkgrel=.*$/pkgrel='$pkgrel'/i' PKGBUILD
- sed -i 's/^[#]*\s*\(return\s*1\)$/# \1/ig' PKGBUILD
- makepkg -oecd
- makepkg -cd
- PF=$(ls -1Atr linux-linode-*.pkg.tar.xz | tail -n 1)
- mv "${PF}" "${REPO}"/
- repo-add "${REPO}"/hir.db.tar.gz "${REPO}/${PF}"
- IFS=$'\n'
- for file in $(ls -1Atr "${REPO}"/linux-linode-*.pkg.tar.xz | head -n -1); do
- rm -i "$file"
- done
-} || {
- sed -i 's/^[#]*\s*\(return\s*1\)$/# \1/ig' PKGBUILD
- makepkg -oecd
-}
-
-git diff --color=auto