summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Felipe Pizarro Naranjo2017-03-23 20:15:17 -0300
committerDavid Felipe Pizarro Naranjo2017-03-23 20:15:17 -0300
commit4acc2d1a10337f922b17ea782d3c48b45489c9bf (patch)
tree47012b8ca9fb72337f2c8e117b01223794842f60
downloadaur-4acc2d1a10337f922b17ea782d3c48b45489c9bf.tar.gz
added dbus-elogind
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD76
-rw-r--r--dbus-enable-elogind.patch73
3 files changed, 183 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0cd2e84fb5e2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = dbus-elogind
+ pkgdesc = Freedesktop.org message bus system
+ pkgver = 1.10.16
+ pkgrel = 4
+ url = https://wiki.freedesktop.org/www/Software/dbus/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = custom
+ makedepends = xmlto
+ makedepends = docbook-xsl
+ makedepends = python
+ makedepends = yelp-tools
+ makedepends = doxygen
+ makedepends = git
+ depends = expat
+ depends = libx11
+ depends = libelogind
+ optdepends = dbus-openrc: dbus initscript
+ provides = libdbus
+ provides = dbus=1.10.16
+ provides = dbus-x11=1.10.16
+ conflicts = libdbus
+ conflicts = dbus
+ conflicts = dbus-x11
+ source = git+https://anongit.freedesktop.org/git/dbus/dbus#commit=8b582cb10d7cf00af7a70496aec48af24edc542b
+ source = dbus-enable-elogind.patch
+ validpgpkeys = DA98F25C0871C49A59EAFF2C4DE8FF2A63C7CC90
+ validpgpkeys = 3C8672A0F49637FE064AC30F52A43A1E4B77B059
+ sha256sums = SKIP
+ sha256sums = faffcaa5b295f49fcedeed2c9ece5298949096be3062fd99a4bf1a6ac3ad1ea0
+
+pkgname = dbus-elogind
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1ced135df384
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,76 @@
+# Maintainer: artoo <artoo@manjaro.org>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Tom Gundersen <teg@jklm.no>
+# Contributor: Link Dupont <link@subpop.net>
+
+_pkgname=dbus
+_commit=8b582cb10d7cf00af7a70496aec48af24edc542b # tags/dbus-1.10.16^0
+
+pkgname=dbus-elogind
+pkgver=1.10.16
+pkgrel=4
+pkgdesc="Freedesktop.org message bus system"
+url="https://wiki.freedesktop.org/www/Software/dbus/"
+arch=(i686 x86_64)
+license=(GPL custom)
+provides=('libdbus' "dbus=$pkgver" "dbus-x11=$pkgver")
+conflicts=('libdbus' 'dbus' 'dbus-x11')
+depends=('expat' 'libx11' 'libelogind')
+makedepends=('xmlto' 'docbook-xsl' 'python' 'yelp-tools' 'doxygen' 'git')
+optdepends=('dbus-openrc: dbus initscript')
+source=("git+https://anongit.freedesktop.org/git/dbus/dbus#commit=$_commit"
+ 'dbus-enable-elogind.patch')
+sha256sums=('SKIP'
+ 'faffcaa5b295f49fcedeed2c9ece5298949096be3062fd99a4bf1a6ac3ad1ea0')
+validpgpkeys=('DA98F25C0871C49A59EAFF2C4DE8FF2A63C7CC90' # Simon McVittie <simon.mcvittie@collabora.co.uk>
+ '3C8672A0F49637FE064AC30F52A43A1E4B77B059') # Simon McVittie <simon.mcvittie@collabora.co.uk>
+
+prepare() {
+ cd $_pkgname
+ git cherry-pick -n 09cb6d7b467f6d1c6685ee9ccc171f4dddbe1f42
+ patch -Np 1 -i ${srcdir}/dbus-enable-elogind.patch
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd $_pkgname
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --libexecdir=/usr/lib/dbus-1.0 \
+ --with-dbus-user=dbus \
+ --with-system-pid-file=/run/dbus/pid \
+ --with-system-socket=/run/dbus/system_bus_socket \
+ --with-console-auth-dir=/run/console/ \
+ --enable-inotify \
+ --enable-elogind \
+ --disable-static \
+ --disable-verbose-mode \
+ --disable-asserts \
+ --without-systemdsystemunitdir \
+ --disable-systemd \
+ --disable-user-session \
+ --enable-x11-autolaunch
+
+ make
+}
+
+check() {
+ cd $_pkgname
+ make check
+}
+
+package() {
+ cd $_pkgname
+
+ make DESTDIR="$pkgdir" install
+
+ rm -r "$pkgdir/var/run"
+
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$_pkgname/COPYING"
+
+ # Remove docs
+ rm -r "$pkgdir/usr/share/doc"
+}
diff --git a/dbus-enable-elogind.patch b/dbus-enable-elogind.patch
new file mode 100644
index 000000000000..5cb5d649cd91
--- /dev/null
+++ b/dbus-enable-elogind.patch
@@ -0,0 +1,73 @@
+--- a/dbus/dbus-userdb-util.c 2015-09-30 16:48:40.000000000 +0200
++++ b/dbus/dbus-userdb-util.c 2016-11-03 11:09:42.550520587 +0100
+@@ -32,6 +32,9 @@
+ #if HAVE_SYSTEMD
+ #include <systemd/sd-login.h>
+ #endif
++#if HAVE_ELOGIND
++#include <elogind/sd-login.h>
++#endif
+
+ /**
+ * @addtogroup DBusInternalsUtils
+@@ -54,7 +57,7 @@
+ const DBusUserInfo *info;
+ dbus_bool_t result = FALSE;
+
+-#ifdef HAVE_SYSTEMD
++#if defined(HAVE_SYSTEMD) || defined(HAVE_ELOGIND)
+ /* check if we have logind */
+ if (access ("/run/systemd/seats/", F_OK) >= 0)
+ {
+--- a/configure.ac 2016-11-03 11:13:58.286528265 +0100
++++ b/configure.ac 2016-11-03 11:22:11.210543063 +0100
+@@ -185,6 +185,7 @@
+ AC_ARG_ENABLE(kqueue, AS_HELP_STRING([--enable-kqueue],[build with kqueue support]),enable_kqueue=$enableval,enable_kqueue=auto)
+ AC_ARG_ENABLE(console-owner-file, AS_HELP_STRING([--enable-console-owner-file],[enable console owner file]),enable_console_owner_file=$enableval,enable_console_owner_file=auto)
+ AC_ARG_ENABLE(launchd, AS_HELP_STRING([--enable-launchd],[build with launchd auto-launch support]),enable_launchd=$enableval,enable_launchd=auto)
++AC_ARG_ENABLE(elogind, AS_HELP_STRING([--enable-elogind],[build with elogind user seat support]),enable_elogind=$enableval,enable_elogind=auto)
+ AC_ARG_ENABLE(systemd, AS_HELP_STRING([--enable-systemd],[build with systemd at_console support]),enable_systemd=$enableval,enable_systemd=auto)
+
+ AC_ARG_WITH(init-scripts, AS_HELP_STRING([--with-init-scripts=[redhat]],[Style of init scripts to install]))
+@@ -1184,6 +1185,24 @@
+
+ AM_CONDITIONAL(HAVE_CONSOLE_OWNER_FILE, test x$have_console_owner_file = xyes)
+
++dnl elogind detection
++if test x$enable_elogind = xno ; then
++ have_elogind=no;
++else
++ PKG_CHECK_MODULES([ELOGIND],
++ [libelogind >= 209],
++ [have_elogind=yes],
++ [have_elogind=no])
++fi
++
++if test x$have_elogind = xyes; then
++ AC_DEFINE(HAVE_ELOGIND,1,[Have elogind])
++fi
++
++if test x$enable_elogind = xyes -a x$have_elogind != xyes ; then
++ AC_MSG_ERROR([Explicitly requested elogind support, but libelogind not found])
++fi
++
+ dnl systemd detection
+ if test x$enable_systemd = xno ; then
+ have_systemd=no;
+@@ -1290,7 +1309,7 @@
+ fi
+
+ #### Set up final flags
+-LIBDBUS_LIBS="$THREAD_LIBS $NETWORK_libs $SYSTEMD_LIBS"
++LIBDBUS_LIBS="$THREAD_LIBS $NETWORK_libs $SYSTEMD_LIBS $ELOGIND_LIBS"
+ AC_SUBST([LIBDBUS_LIBS])
+
+ ### X11 detection
+@@ -1949,6 +1968,7 @@
+ Building AppArmor support: ${have_apparmor}
+ Building inotify support: ${have_inotify}
+ Building kqueue support: ${have_kqueue}
++ Building elogind support: ${have_elogind}
+ Building systemd support: ${have_systemd}
+ Building X11 code: ${have_x11}
+ Building Doxygen docs: ${enable_doxygen_docs}