summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-08-14 07:56:51 -0700
committerxiota2023-08-14 07:56:51 -0700
commit4adabe4470f2cb545e1a45f994e5f1d4f0023e21 (patch)
treefc64d41cf6ccc5853bb5341e036f88decd50625c
parent57c57b466afaf407e62e89e2c2baeaafc936f7c9 (diff)
downloadaur-4adabe4470f2cb545e1a45f994e5f1d4f0023e21.tar.gz
23.04.3.r23
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD24
2 files changed, 17 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca643372dfb1..220a34986a27 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = filelight-git
pkgdesc = View disk usage information
- pkgver = 23.04.2.r0.g2f2b5a1
+ pkgver = 23.04.3.r23.g796dbcb
pkgrel = 1
url = https://invent.kde.org/utilities/filelight
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index c53dd74cf5bf..28bc2e50a2dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname="filelight"
pkgname="$_pkgname-git"
-pkgver=23.04.2.r0.g2f2b5a1
+pkgver=23.04.3.r23.g796dbcb
pkgrel=1
pkgdesc="View disk usage information"
arch=('i686' 'x86_64')
@@ -24,7 +24,7 @@ makedepends=(
)
provides=("$_pkgname")
-conflicts=(${provides[@]})
+conflicts=("$_pkgname")
source=(
"$_pkgname"::"git+$url"
@@ -46,7 +46,7 @@ pkgver() {
echo "$_line" | sed -E "s@$_regex@\1@"
)
_commit=$(
- git log -S "$_line" -1 --pretty=oneline --no-color | sed 's@\ .*$@@'
+ git log -G "$_line" -1 --pretty=oneline --no-color | sed 's@\ .*$@@'
)
_revision=$(
git rev-list --count $_commit..HEAD
@@ -55,15 +55,23 @@ pkgver() {
git rev-parse --short HEAD
)
- echo "$_version.r$_revision.g$_hash"
+ printf '%s.r%s.g%s' \
+ "$_version" \
+ "$_revision" \
+ "$_hash"
}
build() {
- cmake -B build -S "$_pkgname" \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DKDE_INSTALL_LIBDIR=lib \
+ _cmake_options=(
+ -B build
+ -S "$_pkgname"
+ -DCMAKE_BUILD_TYPE=Release
+ -DCMAKE_INSTALL_PREFIX=/usr
+ -DKDE_INSTALL_LIBDIR=lib
-DBUILD_TESTING=OFF
+ )
+
+ cmake "${_cmake_options[@]}"
cmake --build build
}