summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnthony Wang2021-10-13 15:07:18 -0500
committerAnthony Wang2021-10-13 15:07:18 -0500
commit4af0408609e8a65b1a7baf22c53bf326aacff9e2 (patch)
treef5a2bf6b742a4254ec40728f4a2ce313aed8dc3a
downloadaur-4af0408609e8a65b1a7baf22c53bf326aacff9e2.tar.gz
Inital commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD51
-rw-r--r--icon.pngbin0 -> 334548 bytes
-rw-r--r--oh-my-git4
-rw-r--r--oh-my-git.desktop7
5 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d93d84267d34
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = oh-my-git-git
+ pkgdesc = An interactive Git learning game!
+ pkgver = r465.929c634
+ pkgrel = 1
+ url = https://ohmygit.org/
+ arch = any
+ license = custom
+ makedepends = godot
+ makedepends = zip
+ source = oh-my-git-git::git+https://github.com/git-learning-game/oh-my-git.git
+ source = https://downloads.tuxfamily.org/godotengine/3.3.4/Godot_v3.3.4-stable_export_templates.tpz
+ source = oh-my-git
+ source = oh-my-git.desktop
+ source = icon.png
+ sha512sums = SKIP
+ sha512sums = 1c5463842148b2682ae4122b818b5612bd22f2eafd57ba27c393c837721e81a3e6ba8c8680702ebeb2fca605d7b93c1fe0d3d13039630c6953673f72c8f13a21
+ sha512sums = 617b41e7fc2f05c6cb5c06ef3f0ef134d52bb40d8461b6b0013acf0d0903a96aa3f614da593d3a06072162caadd233e327aa7006b67b69da647cec6eb8fa653f
+ sha512sums = 7bfc8766cc46c1a2c8ffa63e1d6613763d91f38a53c6ef31ff3943305880507796e4704fdfea814f7af54f43040011291f6dd7f954bbe67adac95562df7a69f0
+ sha512sums = 12816c20c190222f3a70937a3721184a94fc4ea9a36e55fe4873f06a0b4e8205b34f7927b880a5968588db228051ab87a5168abddf882303a70c9b61fdb39e08
+
+pkgname = oh-my-git-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d924de785e92
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Anthony Wang <ta180m@pm.me>
+pkgname=oh-my-git-git
+pkgver=r465.929c634
+pkgrel=1
+pkgdesc='An interactive Git learning game!'
+arch=(any)
+url='https://ohmygit.org/'
+license=(custom)
+makedepends=(godot zip)
+godotver=$(godot --version | cut -d'.' -f1-3)
+source=("${pkgname}::git+https://github.com/git-learning-game/oh-my-git.git"
+ "https://downloads.tuxfamily.org/godotengine/${godotver}/Godot_v${godotver}-stable_export_templates.tpz"
+ oh-my-git
+ oh-my-git.desktop
+ icon.png)
+sha512sums=('SKIP'
+ '1c5463842148b2682ae4122b818b5612bd22f2eafd57ba27c393c837721e81a3e6ba8c8680702ebeb2fca605d7b93c1fe0d3d13039630c6953673f72c8f13a21'
+ '617b41e7fc2f05c6cb5c06ef3f0ef134d52bb40d8461b6b0013acf0d0903a96aa3f614da593d3a06072162caadd233e327aa7006b67b69da647cec6eb8fa653f'
+ '7bfc8766cc46c1a2c8ffa63e1d6613763d91f38a53c6ef31ff3943305880507796e4704fdfea814f7af54f43040011291f6dd7f954bbe67adac95562df7a69f0'
+ '12816c20c190222f3a70937a3721184a94fc4ea9a36e55fe4873f06a0b4e8205b34f7927b880a5968588db228051ab87a5168abddf882303a70c9b61fdb39e08')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+build() {
+ cd templates
+
+ mkdir -p $HOME/.local/share/godot/templates/${godotver}.stable
+ cp linux_x11_64* $HOME/.local/share/godot/templates/${godotver}.stable
+
+ cd ../"${pkgname}"
+
+ make linux
+}
+
+package() {
+ install -Dm755 oh-my-git "$pkgdir/usr/bin/oh-my-git"
+ install -Dm644 icon.png "$pkgdir/usr/share/${pkgname%-git}/icon.png"
+ install -Dm644 oh-my-git.desktop "$pkgdir/usr/share/applications/oh-my-git.desktop"
+
+ cd "${srcdir}/${pkgname}"
+
+ install -Dm755 build/oh-my-git-linux/oh-my-git "$pkgdir/usr/lib/${pkgname%-git}/oh-my-git"
+ install -Dm644 build/oh-my-git-linux/oh-my-git.pck "$pkgdir/usr/lib/${pkgname%-git}/oh-my-git.pck"
+}
+
+# vim:set sw=2 sts=2 et:
diff --git a/icon.png b/icon.png
new file mode 100644
index 000000000000..1a0ab9618226
--- /dev/null
+++ b/icon.png
Binary files differ
diff --git a/oh-my-git b/oh-my-git
new file mode 100644
index 000000000000..db565497f21a
--- /dev/null
+++ b/oh-my-git
@@ -0,0 +1,4 @@
+#!/bin/bash
+
+cd /usr/lib/oh-my-git
+./oh-my-git "$@"
diff --git a/oh-my-git.desktop b/oh-my-git.desktop
new file mode 100644
index 000000000000..24096198b130
--- /dev/null
+++ b/oh-my-git.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Type=Application
+Name=Oh My Git!
+Comment=An interactive Git learning game!
+Exec=/usr/bin/oh-my-git
+Icon=/usr/share/oh-my-git/icon.png
+Categories=Game;