summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo (XenGi) Band2020-05-22 01:37:31 +0200
committerRicardo (XenGi) Band2020-05-22 01:37:31 +0200
commit4b0538126afb765a811aa3a2bfdd54ae852a336d (patch)
tree33a47c21fcd24652aba3efde0f195805df8430f2
downloadaur-4b0538126afb765a811aa3a2bfdd54ae852a336d.tar.gz
initial dump
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore21
-rw-r--r--PKGBUILD29
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b392b4c7909d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = cephadm-git
+ pkgdesc = Cephadm deploys and manages a Ceph cluster by connection to hosts from the manager daemon via SSH to add, remove, or update Ceph daemon containers
+ pkgver = 16.0.0.r1754.g617298c201f
+ pkgrel = 1
+ url = https://ceph.com/
+ arch = any
+ license = GPL2
+ license = LGPL2.1
+ license = LGPL3
+ depends = lvm2
+ optdepends = podman: container backend
+ optdepends = docker: container backend
+ optdepends = chrony: time sync service
+ optdepends = ntp: time sync service
+ provides = cephadm
+ conflicts = cephadm
+ source = git+https://github.com/ceph/ceph
+ sha256sums = SKIP
+
+pkgname = cephadm-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0e2052d5345b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,21 @@
+ceph
+
+# Created by https://www.gitignore.io/api/archlinuxpackages
+# Edit at https://www.gitignore.io/?templates=archlinuxpackages
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+# End of https://www.gitignore.io/api/archlinuxpackages
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2830970262a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# maintainer: Ricardo Band <email@ricardo.band>
+
+pkgname=cephadm-git
+pkgver=16.0.0.r1754.g617298c201f
+pkgrel=1
+pkgdesc='Cephadm deploys and manages a Ceph cluster by connection to hosts from the manager daemon via SSH to add, remove, or update Ceph daemon containers'
+arch=('any')
+url="https://ceph.com/"
+license=('GPL2' 'LGPL2.1' 'LGPL3')
+depends=('lvm2')
+optdepends=('podman: container backend'
+ 'docker: container backend'
+ 'chrony: time sync service'
+ 'ntp: time sync service')
+provides=('cephadm')
+conflicts=('cephadm')
+source=("git+https://github.com/ceph/ceph")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $srcdir/ceph
+ git describe --long | sed 's/^v//;s/-/.r/;s/-/./'
+}
+
+package() {
+ cd $srcdir/ceph
+ install -Dm0755 src/cephadm/cephadm $pkgdir/usr/bin/cephadm
+}
+