summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Reimer2015-06-08 11:09:30 +0200
committerChristopher Reimer2015-06-08 11:09:30 +0200
commit4b05496dd01c3e2dfdb72bf43a3e41fd0987e696 (patch)
treeee03cfbcf896d457d13f04dd0bc3c569198fb184
downloadaur-4b05496dd01c3e2dfdb72bf43a3e41fd0987e696.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/3bf8a4492e3b973a559fd2c53855b231e25c7e74)
-rw-r--r--.SRCINFO21
-rw-r--r--50-channellists.conf3
-rw-r--r--PKGBUILD31
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1d03f5d28b21
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = vdr-channellists
+ pkgdesc = Plugin to manage your Channellists
+ pkgver = 0.0.5
+ pkgrel = 6
+ url = http://www.zulu-entertainment.de/content.php?f=VDR-Plugins&sub=Channellists
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ license = GPL2
+ depends = libcdio-paranoia
+ depends = vdr-api=2.2.0
+ backup = etc/vdr/conf.avail/50-channellists.conf
+ source = http://www.zulu-entertainment.de/files/vdr-channellists/vdr-channellists-0.0.5.tgz
+ source = 50-channellists.conf
+ md5sums = 20ab294c48164b513ed0557acee5c66c
+ md5sums = 6a30260380a577d8514d37d8f318f8fd
+
+pkgname = vdr-channellists
+
diff --git a/50-channellists.conf b/50-channellists.conf
new file mode 100644
index 000000000000..ffe5be93ab7d
--- /dev/null
+++ b/50-channellists.conf
@@ -0,0 +1,3 @@
+[channellists]
+#--script=SCRIPT
+# path to update script
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d2c1a2cf197d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# This PKGBUILD is part of the VDR4Arch project [https://github.com/vdr4arch]
+
+# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
+pkgname=vdr-channellists
+pkgver=0.0.5
+_vdrapi=2.2.0
+pkgrel=6
+pkgdesc="Plugin to manage your Channellists"
+url="http://www.zulu-entertainment.de/content.php?f=VDR-Plugins&sub=Channellists"
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
+license=('GPL2')
+depends=('libcdio-paranoia' "vdr-api=${_vdrapi}")
+_plugname=$(echo $pkgname | sed 's/vdr-//g')
+backup=("var/lib/vdr/plugins/$_plugname/cd.mpg")
+source=("http://www.zulu-entertainment.de/files/$pkgname/$pkgname-$pkgver.tgz"
+ "50-$_plugname.conf")
+backup=("etc/vdr/conf.avail/50-$_plugname.conf")
+md5sums=('20ab294c48164b513ed0557acee5c66c'
+ '6a30260380a577d8514d37d8f318f8fd')
+
+build() {
+ cd "${srcdir}/${_plugname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${_plugname}-${pkgver}"
+ make CFGDIR=$(pkg-config --variable=resdir vdr)/plugins/$_plugname DESTDIR="${pkgdir}" install
+
+ install -Dm644 "$srcdir/50-$_plugname.conf" "$pkgdir/etc/vdr/conf.avail/50-$_plugname.conf"
+}