summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIlias Stamatis2015-06-14 14:39:43 +0300
committerIlias Stamatis2015-06-14 14:39:43 +0300
commit4b07c6c8ff3a2767857134c89775fe351365c0ea (patch)
tree45cb00fddbb863a941ab074b90a480738d341df3
parentff5aee1a745066a91f4dfd248beecde008df4ad2 (diff)
downloadaur-4b07c6c8ff3a2767857134c89775fe351365c0ea.tar.gz
add patch for compatibility with newer versions of pyqt4
-rw-r--r--PKGBUILD14
-rw-r--r--make-compatible-with-pyqt4-4.11.4.patch22
2 files changed, 33 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 994ffb414139..dd56671ebb6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=ffmulticonverter
pkgver=1.7.0
-pkgrel=3
+pkgrel=4
pkgdesc="Convert audio, video, image and document files between all popular formats"
arch=(any)
url="https://sites.google.com/site/ffmulticonverter/"
@@ -13,8 +13,16 @@ optdepends=('ffmpeg: for video conversions'
'imagemagick: for image conversions'
'unoconv: for document conversions')
conflicts=('ffmulticonverter-git')
-source=(https://sourceforge.net/projects/ffmulticonv/files/$pkgname-$pkgver.tar.gz)
-sha256sums=('d466c59a7c5c71bae5660924a4d89523bdceeab5f3b38d9d4f8d9f62c16f8c69')
+source=(https://sourceforge.net/projects/ffmulticonv/files/$pkgname-$pkgver.tar.gz
+ make-compatible-with-pyqt4-4.11.4.patch)
+sha256sums=('d466c59a7c5c71bae5660924a4d89523bdceeab5f3b38d9d4f8d9f62c16f8c69'
+ '470eea40610656629c236c3a71db0d70651f3ca63d31b533d18aeaf997f9f91b')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ # make compatible with pyqt 4.11.4 and above
+ patch -p1 -i "${srcdir}/make-compatible-with-pyqt4-4.11.4.patch"
+}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
diff --git a/make-compatible-with-pyqt4-4.11.4.patch b/make-compatible-with-pyqt4-4.11.4.patch
new file mode 100644
index 000000000000..c6781b07fad4
--- /dev/null
+++ b/make-compatible-with-pyqt4-4.11.4.patch
@@ -0,0 +1,22 @@
+--- ffmulticonverter-1.7.0/ffmulticonverter/audiovideotab.py.old 2015-06-14 13:17:17.141921225 +0300
++++ ffmulticonverter-1.7.0/ffmulticonverter/audiovideotab.py 2015-06-14 13:20:22.085067124 +0300
+@@ -183,7 +183,7 @@
+ line.setFrameShape(QFrame.HLine)
+ line.setFrameShadow(QFrame.Sunken)
+ self.moreQPB = QPushButton(QApplication.translate('Tab', 'More'))
+- self.moreQPB.setSizePolicy(QSizePolicy(QSizePolicy.Fixed))
++ self.moreQPB.setSizePolicy(QSizePolicy.Fixed, QSizePolicy.Fixed)
+ self.moreQPB.setCheckable(True)
+ hlayout3 = utils.add_to_layout('h', line, self.moreQPB)
+
+--- ffmulticonverter-1.7.0/ffmulticonverter/progress.py.old 2015-06-14 13:01:24.662991040 +0300
++++ ffmulticonverter-1.7.0/ffmulticonverter/progress.py 2015-06-14 13:24:31.447864509 +0300
+@@ -75,7 +75,7 @@
+ self.cancelQPB = QPushButton(self.tr('Cancel'))
+
+ detailsQPB = QCommandLinkButton(self.tr('Details'))
+- detailsQPB.setSizePolicy(QSizePolicy(QSizePolicy.Fixed))
++ detailsQPB.setSizePolicy(QSizePolicy.Fixed, QSizePolicy.Fixed)
+ detailsQPB.setCheckable(True)
+ detailsQPB.setMaximumWidth(113)
+ line = QFrame()